USB-C/Thunderbolt Dock Megathread

Can I get help troubleshooting a post code of 10111000 = code 184?

I recently received my 12th gen (batch 1) Framework laptop and have 2 docks (one at home and one at work) that I used with my previous Dell XPS 15 (9560) laptop. These are the

  • Dell TB16
  • Dell WD19TB

and both have been updated to the latest firmware using my previous laptop.

I’m running Fedora Linux 36 and as reported by several others (for the 11th gen laptops) these docks seem to have played mostly fine (other than having to unplug and plug in after turning on in order to charge) even under Linux.

I don’t want to throw a spanner in the works but I have found definite differences between the 11th gen Framework laptop and the 12th gen one. In particular, I was having issues getting my 12th gen Framework laptop to recognise a display connected to the DisplayPort on the Dell TB16 dock. Weirdly, the only time it seemed to show something on the display was during boot (the boot logo) but once it got into the OS, the display wasn’t recognised at all. I thought it might be Fedora as I used Ubuntu on my old Dell so I tried the Fedora live USB on my old laptop and it seemed to work fine. My friend happened to have an 11th gen Framework laptop so I thought I’d try that (again using the Fedora live USB) and amazingly, it had no problem recognising the display connected to the TB16 DisplayPort. Thankfully, I have been able to connect my 12th gen laptop to my 4K display at 60Hz via the Dell TB16 using a spare USB-C to DisplayPort cable I had lying around (the HDMI port is only v1.4 so 4K is only at 30Hz).

I guess the moral is that it might be worth specifying in the wiki post at the top whether experiences are with the 11th or 12th gen laptops.

TL;DR: Dell TB16 DisplayPort works with 11th gen but not with 12th gen on Fedora Linux.

1 Like

Frame.work 11th gen with Windows 11. Works fine with TS3+ dock but does not work AT ALL with the TS4. The TS4 does not even do a fallback to USB mode, it just recognises it as USB hub with the usb devices and nothing more. A Qnap 10G TB3 adapter also works fine. The dock itself works fine with a Macbook, even when booted with Bootcamp/Windows 10.

Enjoying using my Framework with a Dell D6000 dock. Works really well and the firmware went on fine, unlike the other Dell WD15 I got, that will only install if you use a Dell machine…

…if only that were true as I have used at least 6 Dell machines and they all say “No Dell machine” or “No Dock” detected. But I think the D6000 is better for non Dell machines anyway.

I just wanted to drop an update on the Corsair TBT-100 dock for anyone else who might be using it. The investigation done by @UniversalSuperBox determined that the Corsair TBT-100 was only negotiating a 20gbps link using boltctl instead of the full 40gbps link. Someone on another forum mentioned potentially trying another thunderbolt cable for the issue, so I thought I’d give it a try. I purchased a Thunderbolt 4 cable (even though the dock is only TB3) thinking that might help the Framework firmware understand this is a 40gbps capable Thunderbolt device and it works!

If anyone is having trouble utilizing two monitors over a single cable via a TB3 dock I’d give a TB4 cable a try, it might be worth it, especially if you can confirm with boltctl that the device is only connected at 20gbps. I used this cable by Cable Matters.

1 Like

Setup:

  • 12th Gen 1240P (Batch 2)
  • Dockingstation Dell WD19TB (updated to the latest firmware)
  • Fedora 36 (Kernel 5.,18.18)
  • Two monitors connected to the Dockingstation (1xDP, 1xUSB-C)

Behaviour:

  • During boot all three monitors show the Fedora loading screen.
  • On the login screen only one of my external monitors shows an image, the other is black
  • In the display settings both monitors are shown

What i have tried so far and does not work:

  • Using Xorg
  • Changing the cables (2xDP; 1xDP + 1HDMI)

What seems to fix it (temporary) is setting any option for the non functioning display in the display settings. E.g. disable and enable it or set a different resolution / framerate.
After that the monitor turns on and everything works just fine.

I also tried using a different SSD with PopOS 22.04 (Kernel 5.19), which was coming from another system that worked just fine with the setup. This resulted in a few other graphical quirks and additionally had the same behaviour. So i guess it is a bug in the Kernel / Intel driver.

Also to mention that the original kernel that shipped with the Fedora install did only recognize 1 monitor. So it seems like it got better with recent kernels / intel drivers :slight_smile:

My contribution with a dock I have since 2021. unfortunately pricing has gone up over 100EUR in 2022. Used the dock with multiple Dell laptops and M1 Mac. Bellow is the table testing with Framework laptop Intel 12th Gen from 2022.


+------------------------+--------------+------------------------------------------------+--------------------+----------------------------------------------------------+
|          Name          | Model Number |                    Vendors                     | Contributing Users |                          Notes                           |
+------------------------+--------------+------------------------------------------------+--------------------+----------------------------------------------------------+
| OWC Thunderbolt 4 Dock | OWCTB4DOCK   | https://geizhals.eu/?fs=owc-thunderbolt-4-dock |  @DamDam           | Tested on Framework (Intel Gen12) with Windows 11 Pro.   |
|                        |              |                                                |                    | Working:                                                 |
|                        |              |                                                |                    | • TB4/USB-C host port (40Gb/s, max 96W charging)         |
|                        |              |                                                |                    | • Front USB-A USB 2.0 (480Mb/s)                          |
|                        |              |                                                |                    | • Combo audio 3,5mm Headphone + Microphone               |
|                        |              |                                                |                    | • Back- 3x USB-A (10Gb/s, 7.5W)                          |
|                        |              |                                                |                    | • Back- 3x Thunderbolt 4/USB-C ports (15W)               |
|                        |              |                                                |                    | • USB-C to displayport (dp 1.4 cable) 3,840x2,160 @144Hz |
|                        |              |                                                |                    | • On TB3 cable, Qnap T310G1S adapter at 10GbE            |
|                        |              |                                                |                    | • Back- Gigabit Ethernet                                 |
|                        |              |                                                |                    |                                                          |
|                        |              |                                                |                    | Not tested:                                              |
|                        |              |                                                |                    | • SD card (up to uhs-ii, 312Mb/s)                        |
+------------------------+--------------+------------------------------------------------+--------------------+----------------------------------------------------------+


1 Like

The external monitor feature is not working with this hub either in combination with the Framework laptop and Arch Linux. When the Cable Matters 201054 dock is plugged in, the logs are full of intel graphics driver DRM errors. I reported a bug about it here, but it was marked as “fixed” even though several people still experience it. I re-opened the bug here:

1 Like

I’ve been looking at the Caldigit T4 Station. It’s VERY expensive but, so far as I can find out, it is the only dock that has 2.5Gb ethernet, which I want for transferring large files. It says the ethernet will only work with T3 or T4. I’m concerned that Framework has still not received Thunderbolt certification after well over a year and I wonder whether there is some reason for this. Has anyone used the ethernet port on this Caldigit model with their Framework?

Another option, is to get a 2.5Gb USB-C ethernet dongle and connect it to my old Dell dock’s T3 port. That should work (and be a lot cheaper), shouldn’t it?

(I know Framework are due to bring out a 2.5Gb ethernet expansion card but it will protrude quite a bit which means I would have to keep inserting it when necessary and remove it when I am not using it.)

I have the Cable Matters Hybrid Thunderbolt 3 Docking Station Model 107044 and have tested it with my Gen-11 Framework laptop and my new Gen-12 (batch 2) running Ubuntu Linux 22.04. I only have one monitor so I have not tested a dual monitor configuration. It works well with my 4K Lenovo ThinkVision P32U-10 monitor with either HDMI or DisplayPort.

This dock lacks a thunderbolt output port and so I have not tried driving the monitor that way.

I am using 4 of the 5 rear USB ports and have used both front USB ports (type-A and type-C). I am using the ethernet port as my primary network connection.

My monitor also has a built-in 4-port USB 3.0 hub. To use it with this dock it is necessary to have an additional USB cable plugged into the monitor. I have the other end plugged into one of the dock’s rear USB-A ports. This seems to work but I have not tested it extensively.

The dock also powers/charges the laptop as expected and so far the laptop is maintaining a 60% maximum charge level on the battery (as I set in the BIOS) to hopefully avoid battery degradation from being at the top of charge constantly (nice feature of the laptop BTW).

The SD card slot seems ok but I have not tested it very much. An odd thing is that the micro SD slot requires cards to be inserted upside down (contacts up). This is not explained in the manual as far as I can find. I have also not used it very much.

I can use the laptop’s builtin display joined to my 4K Monitor, or I can use either one as a single display controlled easily with Settings → Displays on Ubuntu 22.04. I find that the laptop will boot on the builtin display but switch to the external monitor after logging in if it is configured to use it as the single display. No software or drivers need to be installed for this to work - the functionality is all built in to Ubuntu 22.04, making this plug and play and quite easy to setup except of course for the myriad of cables.

I cannot comment on how bandwidth is allocated or shared by this dock but I have not had a problem using single high bandwidth external SSD’s on either of the front USB ports or doing substantial data transfers across ethernet. I have run reasonably large rsync transfers which would exercise ethernet and the front USB-C port at the same time. I did not measure the transfer speeds, but it seemed comparable to what I have observed on another machine.

One shortcoming is the single USB-C port on the Dock (on the front) that lacks charging capability. That is likely to be an issue for some applications or into the future.

Only the front USB-A port has charging (BC1.2).

I like having a single cable to my laptop that is made possible by this dock and having wired ethernet which is otherwise not quite yet available for the Framework laptop.

2 Likes

Has anyone tried Anker 565 USB-C Hub (11-in-1)? I’m also wondering whether if a USB port is described as a “Data port” does that mean it provides no power? Specifically would that not let me plug in my keyboard/mouse dongle into it?

Great list! Thanks for the effort!

As the initial post is old I guess it’s for the 11th Gen Intel and not for the 12th Gen, am I correct?

1 Like

@mahe I would think so. I’m waiting a U100 Pro from Haigibis off AliExpress. It’s TB4, but cheaper to other first party brands.

Yes, Ethernet works here on Arch Linux. But I still encounter some issues with hibernation that could related to the dock (not sure yet). And my external monitor sometimes fails to turn on after boot, then I have to replug the dock… So it’s not optimal.

1 Like

An update on this dock. I just noticed a firmware update for the dock posted on the CableMatters website that mentioned the flickering issue. After I installed the update, I can now run both my monitors stably.

Link to the update: Cable Matters Hybrid Thunderbolt 3 Docking Station (Model No. 107044) – Firmware Update to Resolve Flickering Issue - Cable Matters Knowledge Base

1 Like

I have a sonnet 750ex and it works fine with my 12th gen framework supplying power and used as an eGPU. eGPU is a 6700XT. I boot with it plugged in and have no issues.

1 Like

I really like the look of the GPU sitting out free; my question is if you use a Thunderbolt 3/4 dock/base that has a NVME M.2 slot in it and instead plug a GPU through a PCIE to M.2 adapter in, would it work?
Of course the power would have to come from an external source. But but plugging the monitors directly into the GPU should work. Right?

I’ve got it (Anker 565 USB-C Hub (11-in-1)). Generally works, but when using PD to charge the laptop through it HDMI output becomes unstable (blinks/desync from time to time). Took me a while to figure it out, because I got it precisely so I can plug one cable and get charging, HDMI and keyboard&mouse working. I’m on Linux, tried different kernels, no difference. I have no other devices to try to pin point if this a problem with the laptop or the hub.

When laptop is charging through another port, or not charging at all, everything is fine.

I ended up getting that hub anyway and haven’t had issues with charging. Although I did switch to a 100w charger at the same time. Running Pop! Os.
To answer my own question, plugging a wireless mouse adapter and wired keyboard into the data ports still work fine.

Are you using HDMI/DP port while charging? Useful datapoint, so thanks! I did try a 100W charger and it didn’t change anything.