USB-C/Thunderbolt Dock Megathread

(I was unable to edit the table because there are too many @-mentions in it).

I have a Belkin Thunderbolt 3 Express Dock HD. The DisplayPort, Ethernet, USB and Audio all work. Power Delivery is the problem. It only trickle-charges, it does not deliver the full 85W. I need to plug in a separate power supply into the laptop to use this dock.

@Ruurd_Offringa try getting a small/short usb2 extension cable. USB 3 causes interference for wireless adapters. I see it does have two USB 2 ports on the back but it’s worth a shot.

Hi @Samuel_Chaboya

I’ve tried that and it hasn’t fixed the problem. I ended up contacting support and they are sending me a replacement. I’ll update when I get it and test it.

1 Like

Another report for the Cable Matters USB C docking station (model number 201053).

Host information:

  • OS: NixOS 21.11
  • Kernel: 5.15.24

I’ve tested most functionality with success. If you’re considering one of these, I might suggest taking a gamble on one of the newer model numbers since the bandwidth limitations are a little annoying.

  • Displays: I can drive one monitor at a resolution of 1920x1080 at a rate of 50.00 and another 3840x2160 display at a rate of 23.98. I have to toggle the 4K setting on to get sufficient display bandwidth (which throttles USB and ethernet speed)
  • While running dual displays, pretty much everything seems to work. Wired ethernet, all the USB-A ports, power supply. I have yet to try the mic in/mini-jack out.

For those who might try out the hardware, I did have to enable vsync in picom/i3, otherwise I had bad screen tearing.

@privilegejunkie compatibility with the WD19S (which I am issued through work) is a big deal for me. I have seen around the forums that there are issues using dual monitors through the WD19S… do you have any experience with that?

Hi all. I’ve been looking for a suitable dock for the framework laptop this week. This thread is immensely useful to get an idea of what’s available and what works. However, there still seems to be a lot of things unclear (to me) about how things work under the hood, and what combinations of hardware and software can be expected to work or not, especially in the display department. This is probably because there are a lot of older and newer standards and different ways things can work, and dock manufacturers do not seem to verbose about this. I wondered about adding a section in the wikipost about the technologies involved to provide some guidance to others, but thought to first figure out this stuff myself. That turned out to be a lot of stuff, so I ended up creating a new topic to discuss such details (to not sidetrack the discussion about specific docks here). It might lead to a less-detailed summary for the wikipost here at some point though.

In any case, here’s the topic, comments welcome: Details about USB, Thunderbolt and dock operation

4 Likes

@Ddoc I only use one external monitor, but I will try with two here in a day or so and report back.

I can confirm the Dell WD19TB dock works on my Batch 6 i5 unit, but for some reason I am unable to POST with the dock connected. I need to wait until at least GRUB is visible before I can connect, after which everything will work as intended. I have not tried the latest BIOS yet, nor have I confirmed if it’s a BIOS setting that I need to disable. I’ll see if I can investigate further. A handful of other issues are OS (Ubuntu 21.04) level ones, including an unknown program crash when I reconnect the dock and the occasional shuffling of active audio devices at random moments.

In the meantime, I have the dock almost fully loaded with an Ethernet connection, two displays (one HDMI, one DisplayPort), a USB hub for my 6+ total peripherals including an external hard drive, a headset, and a Lightning cable to connect my iPhone.

I just got a thunderbolt 3 dock from pluggable (Plugable Thunderbolt™ 3 and USB-C Dual Display Dock with 96W Host Char – Plugable Technologies) and it works great! I have it connected via HDMI to two 4K monitors and I’m able to run them both (although at 30Hz rather than the native 60, haven’t tried displayport yet)

I also have a number of USB devices and an ethernet cable pluged in and everything seems to be working great!

OS: elementary OS 6.1 with kernel 5.13

@asonix I have the very similar Cable Matters dock. I haven’t been able to get dual displays up on it yet under Windows. Thanks for letting us know that this one works - I’ll try and order this for myself when it goes on sale next.

I just got my Delock 87772 Dockingstation and tested it using Arch Linux. Everything works out of the box (Charging [separate USB-PD charger required], Ethernet, Audio, card reader, USB, HDMI).

The only problem I noticed is that I’m unable to get 4k@60 using HDMI for some reason, 4k@30 is maximum for my beamer. When I use a Framework USB to HDMI adapter 4k@60 is no problem. I contacted the vendor and will update the wiki post when I got more information.

1 Like

This smaller USB-C travel dock by Old World Computing is something I wanted to share my experience

The USB-c docking station supports two USB 3.2 Type-A ports, HDMI 2.0 port, SD card reader, Gigabit Ethernet port, and USB-C power pass through.

I was able to confirm it works with the Framework hardware (batch 6) using Debian/Ubuntu/Pop!_OS.

Hope to see this dock is added to the list.

1 Like

ThinkPad Thunderbolt 3 Dock Gen 2 tested with 135W power supply on Pop!_OS.

No problems with…

  • Second screen
  • Audio Interface
  • USB ports
  • Ethernet cable
  • Display Port
  • HDMI

I encountered a weird issue:

The laptop WILL NOT be powered if the USB-C expansion card is mounted on the right side. If mounted on the right side everything works fine except of the power supply. I do not know why that makes a difference but at least at works :slight_smile:

3 Likes

UNSUPPORTED

P/N: CADUAL4KDOCK
manufacturer: i-tec
name: USB 3.0 / USB-C / Thunderbolt 3 Dual Display Docking Station
link: CADUAL4KDOCK | i-tec USB 3.0 / USB-C / Thunderbolt 3 Dual Display Docking Station | i-tec

OS: Pop!_OS

Issues: power delivery does not work at all. USB hub does work, rest untested

edit: added to table

Also I’ll be using a macbook for work. Can somebody recommend a dock that works for both framework & mac?

We’ve got an ATEN UH7230 Thunderbolt 3 Multiport Dock that works with both a Framework laptop and Macbook Pro.

1 Like

I’ve tested the replacement unit for a while now and still notice some USB response issues, although it does seem better than the first unit.

I had some monitor problems (displays randomly swapping place) and found the solution to that here: Windows on second monitor moves to primary monitor after sleep/lock - Super User

Basically there are hidden monitors, likely from using different docks, and Windows 10 seems to get confused by them. Uninstalling all the hidden monitors in Device Manager and rebooting solves the problem.

I just came across to these two blogposts, which have a great list of USB-C and TB4 docks (no TB3 it seems, though), with summarized specs as well. I suspect these might be handy to anyone looking for a dock!

1 Like

Earlier in the thread I posted my experience with a hub very similar to the image in the first link.

It’s no longer available but there are many just like it - a greyish silver box with lots of ports. There are so many that are all very similar.

They’re much cheaper than the docks posted in this thread, some of which don’t appear to work all that well.

Seems to be a difference, “hub” vs. “dock”.

Mine still works perfectly.

Update on this Delock Dock after using it for some days: everything works fine, except for 4k@60Hz. Docking, undocking, suspending, starting up - no problems at all here.

Missing support for 4k@60Hz seems to be a problem with Linux DRM, I opened an issue for this: Docking station, no 4k@60Hz, intel(0): failed to set mode: No space left on device [28] (#5377) · Issues · drm / intel · GitLab

Sadly I have no Windows available here to check if it is a hardware fault.