USB EFI Boot Failed

I had no issues installing Fedora from an USB Drive. Now, when I try to install Endeavouros from a USB (using the same dd command on the same computer to copy the ISO to the USB) I get a EFI Boot Failed.

What should I do to get this USB recognized?

I’m not familiar with the technical details of what goes into creating a bootable USB device these days. I haven’t seen anyone suggest using dd for that in a number of years (though I haven’t gone looking either); I suspect there’s a little more to it, with modern systems, than just copying the bits of an ISO file verbatim.

Fortunately, there are a number of software tools for that purpose, so bootable USB drives can easily be created under both Windows and Linux. One of those should do the trick.

1 Like

Probably a secure boot issue, have you tried turning that off?

1 Like

dd is perfectly fine since it did properly the copy for Fedora.

Secured boot does not exist in the Framework Bios. There’s a switch for USB that is not related to booting but to the dongles. I disabled this one. I will see if it changes the error.

Secure boot is in the BIOS and enabled by default, but it’s in a different section from the rest of the options. If you don’t disable it then a vast majority of distros, especially the less popular corporate-backed ones, won’t boot (Fedora not included in this category).

2 Likes

a secure boot toggle and custom root of trust options have to exist in the firmware config* to get windows certified last time i checked (which was ages ago, see footnote) so id be pretty surprised if they were missing (given that framework also meets some of the other requirements such as around the labelling of the super key even though otherwise it would not make sense for them to meet those requirements)

*this only applied to x86 platforms last time i checked. on arm platforms, it had to be always on, with no option for a custom root of trust. then again, this was in the windows rt days, so it might have changed.

edit to add: with a quick duckduckgo it would appear that endeavouros requires configuring a custom root of trust if secure boot is to be used.

Where on the Framework 16 latest BIOS is this secured option located?

I cannot find it with or without the USB Drive.

I installed tons of distros on tons of computers. I know what I need to do to boot from a USB. It looks like something is amiss with this BIOS.

Secure boot is not in the regular BIOS menus. You have to select “Administer Secure XXXX” or whatever it’s called by spamming F2 during boot. You cannot enter this mode after attempting (and failing) to boot an unsigned os/kernel.

1 Like

IDK what you are seeing, but it is kinda obvious on mine:

Thanks.

Here is the process I followed:

  1. during initial booting, press F2 repeatedly
  2. using the Administer Secured Boot menu,
    2a- disable the Secured Boot
    2b- plug your USB Bootable drive
    2c- Use the option for EFI Management (first option on the administer secured boot screen)
    2d- Browse Arch bootable drive and select the x64 shell efi file, and then, in the folder in the folder the x64 boot efi file
  3. use F10 to save the settings

The computer will keep booting and most likely will land on your login screen if the laptop is configured with an OS.

  1. Restart your computer
  2. During that second booting sequence, use F12 to call the BIOS Boot Menu
  3. Choose the entry (typically third) displaying your USB Drive within those listed EFI entries

Your bootable drive should boot.

2 Likes