Linux Boot Issues (Manjaro, Arch and SystemRescue) (Solved, I had to turn off Secure Boot, duh!)

I’m trying to figure out why I can’t boot to anything except the verified Linux distros - Fedora 39 and Ubuntu 22.04 both boot fine on various removable drives, but I can’t get Manjaro (either XFCE or KDE) to boot at all, nor does Arch or the SystemRescue thumb drive that I keep around.

I’ve tried on:

  • Multiple thumb drives
  • A WD 1tb SSD in an external case
  • A microSD card in the Framework microSD expansionion port as well as a USB-C microSD reader and USB-A reader

On all of these devices, which work fine to boot on ANY other computer, I get the error “EFI USB Device (XXXXXX) boot failed.”

This is bizarre - why would nothing except the verified distros be able to boot? On the Linux Compatibility page (Framework | Linux Compatibility on the Framework Laptop) it says:

“We designed the Framework Laptop from the outset to be a great Linux laptop, and the Framework Laptop DIY Edition comes with no OS loaded to let you bring your favorite Linux distribution.”

And, indeed, I can boot any live media on my Framework 13.

Is this a fault in my hardware, or something specific to the 16’s design?

The Framework page indicates that Arch works and is community supported, but even that won’t boot for me. No notes on the Arch Farmework 16 page about boot issues or workarounds.

1 Like

You did turn off secureboot?


OMG, you’re the man!

Honestly, I just don’t install on anything other than self-built PCs enough that it’s something I would think about.

I guess if it were in the BIOS settings, I’d probably have thought to change it, but since it wasn’t (and I had to dig around to find instructions to get to it) and I don’t generally deal with MBs having it turned on by default, it wasn’t even on my radar.

Sure enough, turned it off and it booted right up.

(Why didn’t support mention this when I asked? Curse you Framework!!! j/k, I love your products and I know you’re slammed with support requests right now…like why only one channel of my memory is working…)

1 Like

That thing got me too, I knew I needed to turn it off but finding the bloody setting was a whole other ordeal, frankly the bios is one of the worse parts of the thing.

Idk what it does, but I also turned my audio drivers to the linux setting instead of windows.

1 Like

It just does some configuration which would normally be done by the Windows driver (Getting full speaker performance with Linux on Framework Laptop 16 - #13 by Kieran_Levin)


I see, thanks!

I saw that one, so did it. It wasn’t as hidden :slight_smile:

Where did you find the secure boot setting at? I see the “Administer Secure Boot” option on the main menu, but it seems I need to be able to boot to get in to that.

The strange boot requirement is that you have to boot into that menu before attempting (and failing) a boot. So just power down completely, then turn on and spam f2. If you don’t get into that menu on the first boot attempt, it won’t let you in.


Sure enough… that’s a little wacky, but hey I got in. Thanks!