Wifi slow to connect when booting or waking from sleep

Hello world - this is my 1st post!

Whenever I boot or wake from sleep mode, the ax210 wifi always takes up to 15 seconds to connect. Is this common? Any help or ideas are appreciated.

Setup is DIY i5, AX210 Wifi (no vPro), Win 10 21H2.
Wifi driver is Intel (upgraded after installing the FW driver kit)
Router is TPLink Deco M9 mesh (AC2200) with both 2.4 and 5G active.

Other than the wifi connection lag, I love this thing and I’m happy to support a company that provides real consumer choice in this space.

1 Like

I’ve found the same issue, if I join a hotspot from a phone it connects almost instantly but if I connect to a standard building wifi it takes much longer,

Throwing my hat in there too. Only relevant thread so far when searching for “wifi sleep”.

Every time I wake from sleep (“modern sleep”), the WiFi is in a coma for about 30 full seconds or so. Long enough for me to try going to a site, “dns_probe_finished_no_internet”, get frustrated, try disconnecting/reconnecting, open the troubleshooter, aaaaaand by the time the troubleshooter starts, it’s finally actually connected.

I can also say that in my Windows power options, there’s no “Allow connectivity during connected-standby (on battery)” option in the power plan settings, and there’s no “when my PC is asleep… disconnect network after…” option in the modern Settings panel. Those options simply don’t exist. But I am getting “modern sleep” at least best as I can tell… (I can play music with the lid closed, whaaaat)

I suspect the two are related: the incredibly long WiFi startup time, and the lack of network options related to sleep.

My Framework laptop is brand new, btw - just 4 days old and about now 2 weeks since ordering it - no idea what batch, though. I have the Tempo/IDT audio codec, not Realtek, though :slight_smile:

Oh - and also the same WiFi card (AX210 no vPro), Windows 10 freshly installed with the driver pack + Intel updates, and in one case it’s Google Wifi and the other it’s a Ubiquiti AP - both AC WiFi.

UPDATE! Thanks to Matt_Falcon for giving me some clues that the wifi connection lag may have been related to Modern Standby. Some googling brought me to this page:

I followed these steps and “Network Connectivity on Standby” appeared as an option in the Advanced Power Settings. I then changed “On Battery” to “Enabled”. My wifi now remains connected during sleep, no more lag!

There’s still a wifi connection lag after a reboot but I can live with that.

1 Like

I’ve been experiencing the same very long wifi lag when my i5-1135G7 Framework laptop resumes from sleep. I’ve already enabled the “Network connectivity on standby” option, but that hasn’t made a difference.

Have there been any other workarounds to get this working? If I recall correctly, wifi used to connect very quickly when resuming from standby when I first got my laptop.