Win 10 Driver Problems Framework Laptop 13 / 13th gen

Hello fellow Framework Users,

i got the task to look if the Framework Notebook is a suitable Notebook for our company.
My Problem now is that we are obligated to use Windows 10 and stay with Intel CPUs.
Therfore i have a drivers Problem. Yes most of the drivers are Intel and i can istall them never the less but there are 3 drivers missing and I cant seem to figure out wher to get them. I also installed the win 11 driver package what also soved some other drivers but not all.

the following drivers are the Problem. Im sorry for it being in German but it should be clear what it is.

PCI-Datensammlungs- und Signalverarbeitungscontroller
Hardware ID: PCI\VEN 8086&DEV A77D&SUBSYS 0003F111&REV_01
USB (Universal Serial Bus)-Controller
Hardware ID: PCI\VEN 8086&DEV A76D&SUBSYS 0003F111&REV_OO
USB (Universal Serial Bus)-Controller
Hardware ID: PCI\VEN 8086&DEV A73E&SUBSYS 0003F111&REV_00

I hope somebody can help me.
Thanks in advance!!

Google the usb device ID numbers + “windows driver” or “windows 10 driver”.
For example, for the first one “Hardware ID: PCI\VEN 8086&DEV A77D&SUBSYS 0003F111&REV_01”
You would google “8086 A77D windows driver”.

Hi and welcome to the forum.

You don’t say which generation you have of the 13" Are you implying you do not have an 11th Gen by installing Win 11 drivers?

Why did you install the Win 11 drivers, did you try the Win 10 first.

The idea is

  • not to instal the Intel drivers but to use the Framework package.
  • the windows will update if and when a more suitable one is available, which is unlikely to happen.

Thank you that worked. It seems like I was the Problem here by looking up the wrong ID part.

yes i have the Laptop 13 with 13th gen cpu. So there is only a divers Package for win11 and not 10. It worked but there were the 3 missing drivers i was able to install thanks to the reply above.

Thank you for your reply.

1 Like