Windows 11 BSoD: Bug Check 0x9F

I’ve been testing framework laptop with HT disabled. Reboot occurs every ~30mins of laptop at sleep/idle, charger connected. After I left the laptop alone it rebooted. Investigating Event Logs I’ve found this error:

The computer has rebooted from a bugcheck. The bugcheck was: 0x0000009f (0x0000000000000006, 0xffff8a0da184dab0, 0x0000000000000000, 0x0000000000000000). A dump was saved in: C:\Windows\MEMORY.DMP

MS site tells that this is driver related so I decided to share this info with you:
Bug Check 0x9F DRIVER_POWER_STATE_FAILURE - Windows drivers | Microsoft Docs.

Configuration (all bought with DIY edition):

  • i7 1165G7
  • 64Gb RAM
  • wifi/bt
  • 1 Tb WD SN850
  • BIOS 3.06
  • Hyper-Threading disabled
  • Win 11
  • expansion cards used while testing: storage 250 Gb (with Fedora), HDMI, 2x USB type C
  • PD 65W charger connected

Should I share more info while I have this problem reproducable?

Do you have the November Preview update, KB5007262, installed? I started seeing these bugchecks on sleep after updating, and haven’t seen one since rolling back.

1 Like

Yes, KB5007262 installed. Thanks, will try to rollback it

the scheduler was re-written for Windows 11. I wonder if they have not conceived of an instances where the user would intentionally disable hyper threading. My guess is that it has something to do with that.

Thanks. I filed feedback on this and promoted it to a bug in the OS tracker.

Currently looking at crash reports to see how widespread it is :slightly_smiling_face:

@2disbetter I’m not running with HT disabled :wink:

1 Like

Maybe, but I don’t believe so. HT is not a desirable feature for highly optimized environments (MathLab, compilers, build systems). HT might also affect TDP/power consumption.

The whole system feels rock solid, no problems during heavy lifting (VMs, embedded stuff, BT mouse & keyboard, backup over WiFi) but sleep definitily touched some bug :slight_smile:

1 Like

Crash dumps: about 800k hits in the last 14 days!

For those of you who are following along at home, this is Bug 36614436.

Resolution: “[Intel’s] IntcAudioBus 10.29.00.5714 has been released to OEMs” – @Kieran_Levin may be able to roll it into an updated driver package!

1 Like

No difference. Got BSOD after removing this update package

Interesting. Based on the bug report and the official notice (which I had missed before, and which incorrectly reports the wrong lower bound version number) it looks like this isn’t unique to the new KB.

I wonder what it was about this update that tickled the bug for me, and why it went away when I rolled back… and conversely, why that didn’t hold for you!

I might go so far as to think you’re hitting a different 0x9F bugcheck, but that seems so unlikely given the rest of the driver stack being pretty stable. Would you mind filing feedback in the Feedback Hub for correlation? :slight_smile:

If you an on an SN850 ssd, this sounds like potentially My system is rebooting to a “Default Boot Device Missing or Boot Failed” message

2 Likes

Interesting. I’ll give it a try. Indeed, firmware version was a bit outdated (613000 vs new 623200). Maybe, this will also fix crashes in Fedora ¯\_(ツ)_/¯

Thanks!

I don’t know, and I would certainly hope not.
I always run with HT disabled because it make no sense since very few task can actually benefit from more cores running at a slower speed, not even compilers and certainly not games.
I believe disabling HT will actually result in better performance as the scheduler is able to access the physical cores more directly.

It seems like the update is the cause especially since its a preview

Which also include some interesting changes (e.g., making the crach screen blue again instead of black)

I seem to be having this same issue as well.

2 Likes

I’ve tested with HT enabled and disabled, SN 850 firmware updated, win11 nov kb installed and uninstalled - nothing helped. Still got sudden reboots from time to time with 0x9F record in event logs

If you’re willing to live without audio until a fix is released, you might try disabling the Smart Sound Audio Controller. Note, though, that this is contingent upon my diagnosis being correct. :slightly_smiling_face:

At least on my machine, this unloads the driver that seems to be causing the failed power state transition:

# sc query intcaudiobus

SERVICE_NAME: intcaudiobus
        TYPE               : 1  KERNEL_DRIVER
        STATE              : 1  STOPPED                     <-------
        WIN32_EXIT_CODE    : 31  (0x1f)
        SERVICE_EXIT_CODE  : 0  (0x0)
        CHECKPOINT         : 0x0
        WAIT_HINT          : 0x0

However, it might require a reboot to release any other resources it was holding.

2 Likes

Maybe, it would be enough to just turn off “Allow computer to turn off this device” in power management?

Just to double check that driver version is the same:

That may be the case! I went for the nuclear option, and my machine hasn’t yet bugchecked.

That is the same version as mine.

1 Like

You may be interested in this! The SST driver version there is definitely newer than the one indicated as the fix in the issue report. :slight_smile:

1 Like

Anything to do with PCIe link power state management?
I always turn off any of those potential power saving tricks because in reality they do little yet causes more trouble

have no idea. But after bios 3.07 + drivers pack upgrade BSoDs are gone

2 Likes