11th Gen BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle

@Kieran_Levin Thank you for the EFI based updater. I hope to give it a shot this weekend (after our crazy holiday rush at work).

The EFI based updater messed up my boot settings. I had 2 EFI boot images (Ubuntu and Debian), and the Debian image was what I usually used. After installing the BIOS update, only the Ubuntu image was accessible.

The EFI updater worked for me; glad to not have needed to use WTG or something.

I’m finding that the power light seems to sometimes flash orange too, but I haven’t set the limit at all (so it’s still at 100). Replugging the power cable brings it back to being white, but a few hours later, it’s back to flashing again, so I’m not sure what the deal is.

1 Like

Succesfully updated using the EFI on USB method. Thanks @Kieran_Levin for getting that out there for us linux users!

However, I am seeing the same issue as others regarding boot options disappearing. I had rEFInd set up on a 500M boot partition on /dev/nvme0n1p1 . Before, in 3.06, all of the possible boot options from /boot/efi/EFI were listed in the BIOS boot order menu. After update to 3.07, only my Fedora install on /dev/nvme0n1p2 showed up in that menu (none from p1 or p4 partitions), and p2 is the one the BIOS would automatically boot to. Secure boot was off before, during, and after the BIOS update and the resulting loss of boot options. Also, I did not notice any missing files or directories from my boot partition.

Reinstalling rEFInd did put the rEFInd boot manager back into the BIOS boot list, and did get me back to proper dual boot functionality. However, I am still at a loss to explain how / why the BIOS update would mess with already installed EFI boot options, unless this was a new regression/flaw in 3.07 itself?!? Does 3.07 not scan /boot/efi/EFI, but only /boot/efi ?

1 Like

I am happy to report Batch 2 laptop with Alpha drivers for Windows 11 working well. Device Encryption is enable and I’m also grateful. I do have a question on graphic driver from Framework. Is it a customized driver or plain jane from Intel? I’m hoping to upgrade is 97% lifecycle battery, and buy ethernet card. Merry Happy Holiday’s to all.

I was able to update using the provided EFI Shell update. However, I experienced the issue noted above “losing” my boot entry/device for Debian.

With Secure Boot disabled I was able to use the EFI Shell in rEFInd and added the necessary boot entry using the bcfg command.

I used the Linux EFI setup, flashed successfully however once it was done my Framework was not able to locate my EFI boot partition.

After some mucking around (chrooting from a live USB, recreating the Grub config, nuking the partition and recreating, etc – all which did not work), I used efibootmgr and found that my partition wasn’t there. Using efibootmgr I manually re-added the partition and everything worked again. Was concerning, but fixable. *Note: I did not experience this issue when upgrading from 3.02 to 3.06 (EFI settings remained intact) when using a bootable version of Windows to handle the firmware update.

Running Gentoo 5.15.11 under ~amd64 testing with Grub v2.06, on a Seagate FireCuda 530

1 Like

XMP Support is needed as well as the ability to undervolt the ram/cpu in the bios would also be nice. I also wouldn’t mind getting a menu to adjust the individual ram timings either these are must haves in a laptop like this.

I have been following the BIOS beta releases for a while now, but I haven’t seen any stable releases yet. Is that right?

Apart from the version that the laptops are shipping with, are there any other newer stable releases out there?

1 Like

Updated to Bios 3.07 using the EFI Shell update and fat32 USB drive and went through with no issues. Running Linux Mint Cinnamon. Didn’t reinstall the OS but I dont really see a need too.

I also ran into the issue where rEFInd mysteriously vanished after saving the new battery % limit for the first time after updating to 3.07

Fixed by re-adding the boot entry using efibootmgr (see here).

ArchLinux, installed 3.07 via efi shell with no issue yet.

Do note that this installation method uses the fallback efi bootloader path /efi/boot/bootx64.efi, which may overwrite your bootloader if you installed it this way on the same medium.
For this reason, you should use a usb stick for installation.

I am not sure if this update wipes your efi boot options. I would hope/assume not. But if it does, then you will only be able to boot if your original bootloader was also installed to the fallback location on your nvme.


It does, I mentioned in an earlier comment it happened to me, and it looks like other people have experienced similar issues where their EFI boot options are wiped.

1 Like

Just installed it myself. Lost my bootloader, but that wasn’t what bugged me, it was that the as script happily reflashed on top of the same version - Because it was missing another boot options, it probably looped six or seven times when I looked away.

Now that it’s reconfigured, seems to be working well.

Just got a email saying ‘We wanted to let you know of a couple of firmware updates that we strongly recommend running to keep your laptop running smoothly and at peak performance: BIOS 3.07…’.

I got a Batch 5 laptop a week ago and both Win 10 and Pop OS 21 work more or less fine on it. I’m not satisfied at all by the time of working from battery (4-5 hours of web browsing with medium brightness), but this doesn’t seem to be addressed by that specific update. My laptop seems to have BIOS 3.03, so are there any real reasons to upgrade? Especially considering all the problems risen above and that 3.07 is still in beta.

P.S. anyway, still cannot get why the BETA version of software is strongly recommended.


In my specific setup, I have Linux on the internal SSD + Windows on a storage add-in card. As expected, I can confirm that unplugging my internal SSD, doing the update from Windows, and then plugging the SSD back in left its EFI boot partition intact.

1 Like

@Kieran_Levin It would be good if the instructions reminded you to have the framework plugged in; saves a reboot if you forget to plug in, since it’s a requirement of the updater.

I had no trouble updating using the FAT16 USB method. However, I went to reinstall from my Ubuntu 20.04 live USB (because I found out that hibernation on ZFS is not supported–yikes! I thought ZFS was supposed to be way more supported than btrfs!) and I noticed that the touchpad was not working.

Now I understand that this version is not supported, but I have the PS2 mouse emulation setting on auto and the touchpad still doesn’t work. So it seems like there may be some sort of regression on that setting. I tried both disabling and enabling that setting and couldn’t get it to work. Anyone else having a similar issue?

I run Manjaro Linux with Secure Boot, Systemd-Boot, TPM2 Backed Full Disk Encryption and kernel 5.15.

I used the EFI USB update option without any major problems.

Two minor problems:

  1. Had issue getting the USB boot, but I think that was an issue with my existing boot configuration.

  2. Some BIOS settings got reset. But I was pleasantly surprised to see that my custom secure boot keys stayed. I only had to re-enable secure boot and re-initialize my TPM.

So far so good.

1 Like

I was able to get the install to go fine via a FAT32 formatted USB, as expected.

However, setting battery limits in the bios has caused problems with battery state detection on linux. Wondering if this is a known issue and what I might be able to do to fix it.