11th Gen BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle

@Jake_Naviasky battery state detection (as in discharging or not) seems ok here. Charge time remaining, when on AC, is broken when the limit is set (mine is at 80% atm). Always shows “Estimating”.

But that has been the state of upower/Fedora since about Fedora 19 back in 2013, and Ubuntu before that for I-can’t-remember-how-many years, using Thinkpads and tlp. So no regression I can see (yet, anyway; I just upgraded to 3.07 today).

Edit: Are you seeing some other issue when the limit is set?

I’m with @ololobus on this, why did we get an email telling us its recommended to update to a Beta BIOS, then the KB article page warns us we should be wary of it cause its a Beta BIOS.
Make up your minds!

I’m also a bit frustrated cause I wanted to avoid this strange no boot scenario when I might really need the notebook so I rolled the dice on the Beta BIOS anyway, figuring it couldn’t be any worse, probably. And it wipes the whole BIOS settings save for the Secure Boot DB. This would be fine except this also includes the dang EFI boot entries. With no option to manually add back in the boot option inside of the BIOS I had to go find out how to do so in Windows. At least that worked as expected.

Plus, please fix it so we can actually find everything necessary for the product when we click the Support option. Having to search the KB article DB everytime I wanna look for BIOS or other download options is downright tedious and unorganized.

Which email? Framework Newsletter? I haven’t received the email yet.

It was an email sent by Nirav Dec 24:

Important Firmware Updates for your Framework Laptop

Hi, we hope you’re enjoying your Framework Laptop! We wanted to let you know of a couple of firmware updates that we strongly recommend running to keep your laptop running smoothly and at peak performance: BIOS 3.07, and an update from Western Digital for SN850 SSDs.

The first update is for anyone on BIOS 3.06 (though we recommend that anyone on older firmware update as well). Most Framework Laptops from Batch 5 and later shipped with 3.06 installed. You can double check your BIOS version in the first screen of your BIOS menu, in System Information in Windows, or by running “sudo dmidecode -s bios-version” on Linux. We found an issue where in some circumstances, fully draining the battery while suspended on a laptop running 3.06 prevents it from charging (we have a workaround if you run into this). This is resolved in 3.07, and we have a few other fixes and improvements like being able to set a battery charge limit. You can download and update to 3.07 by following the instructions in this knowledge base article. While you’re on that page, you can also update your drivers to the latest Windows 10 or Windows 11 driver bundle.

The second update only applies if you are using a Western Digital SN850 SSD on Windows. Some SN850 SSDs ship with a firmware version that can cause random reboots or blue screens on Windows, with the system booting back to a screen that states “Default Boot Device Missing or Boot Failed”. You can update to the latest SN850 firmware using the Western Digital Dashboard to resolve this. We have instructions in a knowledge base article.

Please let us know if you have any questions or run into any issues; we’re here to help! You can reach our Support team through our contact form.


1 Like

Thanks for sharing it! It seems the email is only sent to the users using the laptop where the BIOS 3.06 (most laptops from Batch 5) is installed. I am Batch 2. That’s why I haven’t received it. I can understand the approach.

I had the nuked GRUB issue with my machine as well - thankfully I was able to boot into a Arch install USB and reinstall GRUB and everything appears to be working normally.

I installed it and everything have been working well … however, today I put my Ubuntu’s installed machine to sleep and after a while I was around the machine and I noticed how it had the fan at full speed even being sleeping. I am not sure if this is firmware related, just a “curious” behavior.

Ad a note, I am using Ubuntu Studio, so I had the secure boot deactivated (if not, it is not possible to install such distribution) … I need to check if the update changed my settings and if this have something related with the fan.

Okay so I just updated my BIOS from 3.06 to 3.07 and ran into a “bootable device not found” error after the update.

I’m running:

  • GRUB
  • arch linux
  • Samsung evo pro 970 500gb

I used a bootable usb to chroot into my ssd, copied my grub.cfg to /tmp (just in case it got wiped) and then reinstalled grub:

grub-install --target=x86_64-efi --efi-directory=esp --bootloader-id=GRUB

where esp in my case was /boot.

After reboot everything worked as normal.


I had the same question too , did anyone answer?

systemd-boot user here: Flashed via the USB/EFI method, without any hassles. No bootloaders were harmed during the making of this film


I successfully updated my Batch 4 machine from version 3.02 to 3.07 using the EFI shell. I run Manjaro Linux. To avoid issues with my GRUB configuration, I just popped out my SSD prior to running the update. Thanks to mackncheesiest for the idea, and thanks to Framework for making that easy to do.

My one complaint is that it wasn’t obvious when the update was done. It rebooted once or twice while updating, and then kept rebooting a couple times saying that my current version was 3.07 before I just removed the USB stick.

1 Like

Is it good to download right now or should I just wait for the update via windows?

Windows 11

1 Like

These bios updates are not going through windows update.

Does anyone know if the Windows 11 driver bundle has any compatibility benefits over the Windows 10 driver bundle?

I am running the Intel Driver & Support Assistant, so some of my drivers are newer, for example my Wifi driver is How does the installer handle the system when newer drivers are already installed?

If you are running Windows 11, you will need to use the Windows 11 driver bundle to avoid a crash on sleep.

If you’re running Windows 10, it might be worth trying but it probably doesn’t benefit you nearly as much.

Already running Windows 11. Installed it using the Windows 10 bundle before the Windows 11 bundle was available. Everything seems to be working fine but sleep states are kinda weird where the system won’t sleep when I close the lid. No crashing though.

Is there an ETA when the Windows 11 drivers will move into stable?


Update: I updated the BIOS from 3.02 to 3.07 via the UEFI script and the instructions provided in the framework resources.

  1. Prepare the USB stick
  • Format it to FAT32, but don’t forget to turn on the boot flag

  1. Download the zip and extract it to the USB stick
  2. Restart the laptop into the BIOS and turn off boot options for the internal SSD, leaving only the USB stick as the boot option.
  3. Restart the laptop again (with the BIOS USB) and let the laptop do it’s own thing to update the BIOS.
  4. Let it restart by itself until it says that the BIOS is the same version.
  5. Grab another USB stick with a rescue option and reinstall GRUB.

I had the exact same symptoms of a Bluetooth issue after installing the 3.07 BIOS. Only noticed a couple days after installing BIOS update but suspected it was related. Reinstalling drivers and removing the unknown device didn’t work. Finally got Bluetooth to show up again by just re-running the 3.07 BIOS installer.

In my opinion, that Framework thinks the BIOS 3.07 beta version is strongly recommended if you are using BIOS 3.06. Because there is an issue “a laptop left for an extended period of time (days/weeks) in hibernate or shutdown with power unplugged can get into a state where it won’t charge.” on BIOS 3.06, explained at the knowledge base. Saying “If you are on 3.06 or older, please install BIOS 3.07!” at the knowledge base, they actually only sent the email to users using BIOS 3.06.

So, personally, as I am using Linux on BIOS 3.02, I will wait until Framework ships a stable version of BIOS, via the Linux Vendor Firmware Service (LVFS) with fwupd to install the firmware easily with less risk on Linux.

By the way, one more thing, I find the BIOS’s version numbering schema is interesting. Here is the current actual situation for the BIOS versions.

  • 3.02 (initially shipped version).
  • 3.03 (beta, adding new features)
  • 3.06 (beta, adding new features)
  • 3.07 (beta, adding new features)

According to the Wikipedia Software versioning - Wikipedia, the beta version is generally named as “X.Y-betaN”, or the major version “0” such as “0.Y” or “0.Y.Z” is used as software’s initial always beta versions. In Framework’s BIOS versioning, I think “3.Y” is used as the initial beta versions. So, perhaps, in this case, the version “4.Y” or “4.Y.Z” could be used for their stable versions, using “4.Y-betaN” or “4.Y.Z-betaN” for the beta versions in the future.