11th Gen BIOS 3.09 Beta release

I honestly can’t imagine leaving my laptop for a week; that would be so sad.


Went from 3.0.3 => 3.0.9

Before updating: Could not go into the EFI fw settings (bios) by pressing the DEL button or open the boot menu (f12). The laptop just hung forever.
Had to select uefi settings from GRUB, enable quick boot, then f12 was accepted and fw could be flashed

After update was successful, (no issues) it rebooted and I was still not able to go into the EFI settings (bios), del/f2 buttons did nothing.
After 3-4 trys, I was able to go into boot menu, select grub, go select efi settings from grub, and reorder boot items

After booting to linux => restart f2 works and takes me to efi settings correctly

I think this is related to a BIOS setting “Boot performance mode”, my fans were not loud at all perhaps because I set this parameter to “Max Battery” rather than the default “Turbo Performance”
Can be seen below second image here


By the way, are the hibernate and shutdown battery drain issues also part of the fixes? I somewhat remember that it was part of the reason why people switched to 3.08!

Yeah, nrp said it’s fixed:

On my dual boot Win 11 and Ubuntu 22.04 I had no issues with battery drain in either state, but I don’t use the USB A and HDMI ports that apparently keep a live state, and yes I think there is mention of a fix for when those cards are used.

See Battery slowly drains when completely shut down - #106 by Anand_Gadiyar

The above post and those following


More than sad, but I’d be more concerned about the RTC|CMOS battery holding out :slight_smile:

1 Like

If you are on Ubuntu or Fedora there are no issues.

This journey has taught me: Every early adopter is a willing sucker…no matter how good the PR & marketing materials were. Willing to settle for less, willing to suck it up, willing to wait it out.

For me the EFI Shell method worked without any major issues (from 3.07 to 3.09 beta). PopOS with LUKS encrypted nvme.

I however have two minor findings:

  • The maximum battery percentage setting was lost and I had to set it again
  • I have set a BIOS supervisor password and I kind of expected that I had to fill it in before the upgrade. But that wasn’t needed in the end.

In the OP:
Updating the BIOS firmware will erase NVRAM boot variables

Guess it’s not just boot variables.

Not sure this is accurate, at least with my current board (could be defective) I’m losing 1% per hour with 2 USB-A ports.

1 Like

I have upgraded on Windows and so far so good!

Still have some issues with Modern Standby but that is likely more of a Windows driver issue than a BIOS one.

Not sure if it’s been mentioned in this thread but I noticed that after going from 3.07 to 3.09 I would constantly have disconnecting/reconnecting USB sounds coming from windows. I looked up the event viewer logs and saw that it had to do with USB Selective Suspend. I didn’t have anything with USB in the power settings so I wound up disabling shutting down USB power in device manager. Is there a better fix for this or do I keep this setting on until another BIOS version is released?

Maybe related to the battery useage.

Best Power Efficiency
Best performance

The later will stop idle things being powered down etc. So that would mean the USB A may be powered continuously.

Updated with LVFS from Fedora 36. No issues so far. Took maybe 5 minutes.


Everything worked, used fwupdmgr update, took 5:49min. Now full battery, going to let the laptop in sleep mode for 12h to see how much battery loss there is.

First impressions are good. Fingerprint scanner feels snappier and more accurate, on the older bios it took 2 or 3 turns before my fingerprint was recognized. Now it works the first time.

Also my external monitor gets recognized immediately after boot and hibernation, before I had to unplug and replug (usbc to dipslaylink cable).

Using Archlinux, I3WM with LUKS encryption.


One strange thing I found was that post bios update my laptop cannot seem to enter a sleep state. The screen turns off and the power button flashes, but the battery keeps draining at a enormous rate and the laptop gets HOT (almost burned myself when I took it out of my backpack. I never experienced this problem on 3.07/3.08.

This proabably isn’t BIOS though as I just recently updated from Windows 11 Insider Beta preview to developer preview. Sleep Study also doesn’t update any more.

Yes I noticed the drain and heat in 3.07 and 3.08 though too.

I wouldn’t put it to sleep in a bag, only on the desk when I frequently visit, else it’s hibernate.

1 Like

My observations of sleep in Linux have been rock solid. Windows was problematic, with Windows sometimes acting like it was sleeping but thinking it was cool to still be awake to work on updates or other nonsense. I got around worrying about this on Windows with hibernation.

I operate essentially the same under Linux, but standby time is greatly improved. I see about 1-3% drain per hour, with 1% being the the average. I have had the computer sleeping for 8 hours to come back to only 9% drained. That, to me, is great standby battery life.

Sadly most of the issues I had with my Framework seemed to be Windows oriented in nature. Life under Ubuntu and running Windows in a VM has been pretty excellent.


Not seeing differences in standby drain on Windows (only one datapoint though). This is with 1 USB-C, 2 USB-A, 1 HDMI cards.