11th gen main board mount point degradation?

So I just ordered a 13th gen main board to replace the 11th gen main board in my framework. While I was unscrewing the main board mounting screws one of them just pulled right out complete with the threaded insert that the screw goes into. The hole looks like it’s not in good condition, maybe it’s the heat from the CPU that melted it? Here are some pictures:

location of the damaged mount point is:

Close up of the damaged mount point:

Close up of a good mount point

More importantly what do I do about it? I still have the threaded insert but do I have a better option than hot glue? Actually come to think of it if this IS heat damage I would need a heat resistant glue? Also, does anyone else think this might be an issue for others in the future?

I don’t think hot glue would bond well enough. I’d suggest epoxy. You’d have to be careful not to get any inside.

1 Like

he could use a longer bolt while putting it in its place, so none can get inside and then remove it when its half solid

1 Like

@MJ1 & @CMDR_unematti thanks for the suggestions, I will go to the hardware store later and see what kinds of epoxies they have. I think i need one that bonds well with plastic/aluminum and can handle high heat.

The issue is finding a longer bolt. these screw diameter is tiny, maybe 0.5mm or so? I tried some of the other screws and they seem to be too large to fit the threads. I doubt I would find this screw at a hardware store so I would need to order it online and wait. Do you know where I can find info on the thread and diameter of this screw?

@CMDR_unematti nevermind I think I found it in the marketplace: Framework | Fastener Kit - Bottom Cover and Mainboard

It’s either

  1. M1.6 1.5mm fastener with a T5 head which is 5.5mm diameter and 0.6mm thick (x5)
  2. M2 5.75mm with a T5 head which is 4.6mm diameter and 0.8mm thick (x5)

I think it’s 1?

It says that one is an M1.6. It’s standardized, and the number tells both the diameter and thread pitch. Framework: “Unless otherwise noted, all of the fasteners use ISO standard thread pitches and shaft diameters.”

But without the board in place, you should have extra length with the original screw so that it can go in until it bottoms out. As CMDR_unematti mentioned, remove it before fully cured. I would try to be careful and only apply a small amount to the sides of the insert. Avoid getting any where it could have gone inside to begin with.

I gave both JB Weld Epoxy and a Super glue a try. Neither worked.

After 1 hour cure time I took the screw out and the insert stayed in place, I tried screwing the screw back in and everything came back out of the hole. It doesn’t seem to want to stick to the plastic there. The super glue was worse. It just never bonded to the plastic either.

I’m going to give the epoxy 1 more try. I might have to remove the plastic, but idk. This is getting very sketchy

Superglue has been really bad when I tried on plastic. Bond was weak.

There is also gorilla glue which says

Gorilla Glue will work well on many types of plastic; however, we do not recommend for use on polypropylene (PP) or polyethylene (PE)

Original Gorilla Glue | Gorilla Glue

I don’t think the Framework case would be polypropylene or polyethylene. A lot of consumer plastic products seem to be abs or an abs/pc mix.

Note that full strength cure time for epoxy, even quick epoxy, is usually much longer. Like 24 hours. It should say on the package.


I think the second try with the epoxy might work. This time I left it 2 hours and then unscrewed the screw. The insert stayed in place. I bushed some new epoxy around the insert and got just a tiny bit over the top edge. Then I put the screw back in and only gave it 2 or 3 screws in just to block the entrance so no epoxy goes down in. Idk if I need the extra around and above the insert, but I just want it to be extra strong. I will wait 2 more hours and remove the screw, then wait a full day before testing it.

1 Like

@MJ1 I got a bit impatient as I need to get to bed for work tomorrow. I decided to take the screw out after 1 hour. Everything looks solid so far :grinning:. I will wait the full 24hrs then attempt to mount the main board.

I really think the damage to the mounting point was cased by heat from the fan/radiator assembly. It looks melted. You can see black plastic welling to the left of the melted plastic ring along the expansion slot case and smeared below near the usb C entry. If it melted on my computer, it stands to reason it might on others, it might need to be updated to use a more heat resistant material in future framework releases. How do we bring it to their attention?