[RESPONDED] Manjaro Linux - WiFi works - Framework Ethernet adapter does not (more ...)


I was using Ubuntu 22.04 and my Framework Ethernet USB module worked fine (wired ethernet).

I switched to Manjaro, and today I needed wired Ethernet. The module did not work. (A light flashes when it is plugged in, so I don’t think it is dead).

The module does show up on ifconfig as:

enp0s13f0u1c2: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:bf:0d:00:19:f3  txqueuelen 1000  (Ethernet)

But there is not IP address assigned.

Using the same ethernet cable, and another Ethernet to USB C adapter, it works fine.

enp0s13f0u4: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.xx.xx  netmask  broadcast
        inet6 fe80::6f96:d20e:dead:fff  prefixlen 64  scopeid 0x20<link>
        inet6 fdbb:c3c6:2b1:24de:7fdc:e677:dead.fff  prefixlen 64  scopeid 0x0<global>
        ether 00:e0:4c:68:17:2a  txqueuelen 1000  (Ethernet)

Neither adapter shows up under lspci (just the USB C ports)

Is there a driver to install for Manjaro to make the Framewort ethernet module (wired) work?

I spent about 30 minutes searching and I cannot find anything.

Thanks for any info on this. Much appreciated.

Just FYI: here is the adapter that does work (cheapy adapter from Amazon)


This might help: AUR (en) - r8152-dkms

1 Like

Thank you @lbkNhubert

1 Like

So uh, what’s the conclusion? Does the Framework Ethernet card really require an out-of-tree driver? That’s unfortunate, if true. (I’ve had enough grief from broadcom-wl for a lifetime…)

@Alex_Shpilkin not for Ubuntu, but thus far, “Yes” for Manjaro.

I confess that while I believe that the above recommendation is correct, I stopped my attempts to install it.

The install (via yay) started fine and threw many errors related to missing kernel headers. I researched this and installed the recent headers, but the errors were related to an earlier set of headers. Then, further research indicated I am running “the wrong kernel”. Well, that is a show stopper for me. I want as vanilla an install of Manjaro as possible.

Manjaro has been a very good experience for me (compared to Ubuntu). I installed the XFCE variant, and it is very clean, lean and stable.

So when it looks like I need an alternative kernel, I stop. (BTW: I write kernel code and drivers :wink: My goal is to have as stable, and low maintenance operating system config as possible, and vanilla Manjaro does that for me.

My current solution is to use the Uni Ethernet USB C connector I listed in the OP.

I moved away from Apple Mac about a year ago to get a leaner, more “U*NIX” dev environment. Manjaro is as close as I have come to ‘perfect’. There are a few ‘gotchas’, such as running a different Postgres version on my laptop than on my server, but the gotchas are minor (to me) and the advantages major.

Overall, I love my Framework 12th Gen Intel. I have run into a few glitches with their hardware choices WRT running FreeBSD instead of Linux, but Manjaro Linux is solid and meeting my needs. I have another machine to run/test/build FreeBSD, but it is not a laptop (which makes all the driver issues a lot easier).


Hope that lasts for you. Manjaro has a tendency to eventually go off the rails, one of the many reasons I moved to Archlinux and then Fedora. Good luck.

I am running Manjaro, so far so good, fingers crossed. I don’t yet have a Framework Ethernet card, but will be getting one when the 16" on order arrives, so I will be able to test this out at that time. I don’t want to have to build a custom kernel, either. Will see how it goes, and will update at that time.


@nadb I hear you about ‘going off the rails’ :wink: I initially thought that using Ubunutu LTS would be super stable, etc. Well, that did not work out for me. As I described before, my Ubuntu installs (3 of them) went sideways after a few months.

Thus far, Manjaro has been more stable than Ubuntu for my configs.

(see: Spotlight on Manjaro Linux: Interview with the team - #9 by Bluto)

Here is the key issue for me:

  1. I have a backup laptop with an identical config (a very cheap ASUS)
  2. I have a chromebook running penguin as super-emergency backup (and it actually works! - development and all!)

Thus, I have a very light weight install process - all I need is to install my SSH keys, install git, do one repo git clone and everything is then installed and and configured with 3 shell scripts.

My local files are as skinny as possible. I am using Dropbox and pCloud over rclone. (I do get slow initial results on “ls” :wink:

So, I could re-install Manjaro and get 100% of my config done in about an hour. The biggest delay I have is that I use Firefox identities (Profiles) and I have to log into each of them (6 total).

I am waiting for Manjaro to go pear shaped for me, but thus far, touch wood, it is the best yet (by far).

For a variety of reasons, I am using Ubuntu LTS on my production cloud servers (several of them). CentOS is going away, so I am unlikely to go down the Fedora route at present. Best of luck to you - I totally acknowledge these are personal decisions. Overall, one year later, I have yet to regret moving “off of Apple Mac”. Linux / UN*X is my home.

1 Like

Don’t worry, it will :smile: Nature of the beast. Archlinux works best when you are drinking directly from the firehose…tends to be pretty rock solid as long as you check in on the archlinux website where they post potential issues requiring some intervention. Manjaro breaks all sorts of stuff by delaying these updates under the guise of making it more stable. This delay often actually breaks things. So if you notice an update that has been delayed for a long time be wary. Used to be a tester, good distro back in the day, but about five or six years ago the community split in twain due to some shady actions by the principal developer. Regardless if it is working for, great…but good luck.

CentosStream is actually going to be a much better distro than CentOS ever was, up to date and fresh, rather than a poor imitation of RHEL. Yeah they are personal choices obviously, but SELinux is a strong motivator for me and the default policies on Fedora, CentosStream, and Redhat Enterprise Linux are solid. If I can get something working with SELinux I am comfortable saying I can get it working on any Distro. Personally I run everything on Fedora. My servers, workstation, laptops. Completely stable, and I have never had a bad in place upgrade. This last bit has saved me countless hours.

Anyway happy to hear you got out of the Mac orbit and are enjoying a more Unix like experience.

As Manjaro is a community support distro, we do recommend Fedora 38/39 in cases like this.

Not sure if this is relevant, but the following solved my problem with ethernet not working on Manjaro.

Nevertheless, could you confirm whether the Ethernet expansion card has mainline kernel support?

I was enthused by the idea of getting 2.5G LAN connectivity in an EC, but if the driver support is not there, then (whatever the situation on the Framework-blessed distros is) a generic 1G dongle will probably be a better option.

I test against the kernel(s) provided by Fedora and that listed for Ubuntu 22.04. I have not dug into mainline support as we have very limited time and human resourcing.

What I do know is that it works well for the distros I listed and the kernels they are using (OEM C on Ubuntu 22.04).

Hello all, I’m using arch Linux with the “stable” kernel and my Ethernet module works without installing an out-of-tree driver


Also, it was working during the end of the 5.x.x kernel series

1 Like

This would be expected behavior, yes. Same for Ubuntu 22.04.3 and Fedora 38/39.