12th Gen Intel Core BIOS 3.06 Beta

fwupdmgr seems to have successfully updated the BIOS. But the update for Retimer23 does not seems to fail. Running fwupdmgr update does the reboot, boots into framework firmware updater for a second (shows the Framework logo and fwupdmgr efi version at the top left) but the laptop immediately shuts down afterwards.

fwupdmgr get-history currently shows this in the corresponding firmware update stanza:

Update Error: failed to run update on reboot

Not entirely sure what to do about this…

I don’t have secure boot enabled either.

overall not too bad using the Linux EFI shell method to update. a bit of feedback on my experience as it wasn’t the smoothest:

first flash attempt is similar to another user:

line 97 for me.

I’ve 3x USB-C & HDMI modules. HDMI in lower left, and USBC in the others. I used the lower right USBC for first flash.
retried, same line97 issue, moved to upper right USBC module; no change.
I did this exact same process the first time to prep the USB stick: i wiped the existing USB drive, reformat with fat32, copied the required files & unmounted. I shutdown laptop (rather than reboot i did first attempt). USB stick still in the upper right port, the flash sucessfully completed.

I’m now on 3.06.

After the update, my USBC dock was only passing PD. USB & display was inactive but simply re-plugging the dock cable into laptop got things fully working again (upper left port if it matters).

final thought: while i will use LVFS in the future, could there be a dedicated tag/sub-forum that we could subscribe to for UEFI updates (and thus email notifications!)? i mearly stumbled on this 12gen 3.06 release thread via a reddit thread last night so i’m a week late to the party :slight_smile:

Well this is a beta. I’m not sure broadcasting it makes much sense, in that there could be bugs, etc.

I had the same error as you. It was because of the mounting issues Kieran mentioned in his response above.

I know for me personally, I’m sticking to the LVFS method.

Seeing similar issues reported by @Swop , @Ray519, and others. Steps followed:

  1. Ran MSI installer
  2. Reboot
  3. Realize after 30sec or so that my fans are roaring and nothing is on the external monitor:
  • opened the lid
  • First progress bar was at 95% or so, then
  • the laptop rebooted twice in fairly quick succession, first showing a mostly (~60%) completed progress bar, then reboot, then just flashing up another blank (no green) progress bar before rebooting back into windows

After the update, I received the error message that the 23 retimer still needed to be updated, needed another reboot. I rebooted, but no effect, just saw the blank progress bar flash up then back into windows.

I see errors in Device Manager:

Properties dialog shows the same Code 10 error that @Swop reported.

  1. I then re-ran the update msi, which proceeded to reboot, but just flashes the incomplete (no green) progress bar up on the screen then immediately reboots back into windows again.
  2. Ran the EFI update, which was made more complex by the USB drive not being recognized as a bootable device in the right-front port. Once I swapped the modules, it was recognized in the right-rear port.
  3. EFI update appeared to run fully, but still seeing the above errors in device manager.

Another oddity: the USB-C module that power was plugged into during the first flashing process seems to be borked. That module specifically will not allow charging (no light when power is connected). Behaviour is the module, not the port, as a different module in the same port works fine, and that module does not show a power light in any port. The module still recognizes connected peripherals but won’t allow charging.

Update: forgot to mention that I tried both the 30-second power button hold and the shutdown-unplug-2mins-then-reboot tips, but no changes.


Just upgraded using fwupd without a hitch (aside from some USB weirdness which went away after a reboot). Noticed some output that I haven’t seen before which bypasses my systemd.show_status=0 kernel parameter since I prefer a “silent” boot:

Driver "idxd" was unable to register with bus_type "dsa" because the bus was not initialized.

^ may be related to using the linux-clear kernel but has not shown up since the firmware upgrade


tpm tpm0: [Firmware Bug]: TPM interrupt not working, polling instead.

These don’t seem to be critical at all, just throwing it out there to see if there are any known solutions. I don’t use TPM but was thinking about implementing Secure Boot and TPM2-TOTP with signed images… does this mean it is currently borked?

These may just be kernel issues, but are new to me post-3.06 update.

I had the same error at Line 97 when I tried. Did a full cfdisk/mkfs.fat and rewriting the files but that didn’t help.

I ended up switching to LVFS to do the upgrade using the config changes @Kieran_Levin listed, which was mostly successful. For some reason like @Fraoch I have the same issue with it wanting to update “UEFI Device Firmware (207 → 310)” again…

When I run fwupdmgr get-updates this is the status info:

Devices with no available firmware updates: 
 • 0000:00:1f.5
 • Fingerprint Sensor
Devices with the latest available firmware version:
 • System Firmware
 • UEFI Device Firmware
 • UEFI dbx

Devices that were not updated correctly:

 • UEFI Device Firmware (207 → 310)

Devices that have been updated successfully:

 • System Firmware ( →
 • UEFI Device Firmware (207 → 310)
 • UEFI dbx (33 → 217)

(I submitted an uploaded report w/ full details via fwupdmgr, so hopefully that helps…)

I’m not a fwupdmgr super-user, but I installed GNOME Firmware to double check and It appears that I have two “Framework UEFI Device Firmware” items, one that is GUID a9c91b0c-c0b8-463d-a7da-a5d6ec646333 and is listed as v310 now and was successful, and one that is GUID ba2e4e6e-3b0c-4f25-8a59-4c553fc86ea2 that is v207 and still needs to be upgrade (is this each side?)

I have 1 x USB-C and 1 x USB-A on each side, and I had my AC plugged in on the left side, so maybe I’ll flip it and try to update again and see if that helps…

UPDATE: yep, flipping the USB-C power onto the other side seems to have been the issue. Now both sides are showing v310.


Hi @lhl, I took a quick look, I do see two separate eateries for UEFI Device Firmware with the GUID’s listed. For me both are on version 310. Like I mentioned earlier in the thread, I had no issue doing the update a second time for one of these devices.
No clue why they both weren’t updated at the same time, would love to get some insight on it.


I had no problems upgrading from 3.05 to 3.06 using the EFI image on a microSD (and rebooting the required 5 or 6 times).

All is working well (Linux).

The only (important) detail, is that one should not use the F3 menu to choose the boot method: it seems to work but it ends up throwing an error. Instead, the F12 menu is the right solution! By using F12, no error.


The computer I bought in 2023 will come with the new bios?

1 Like

the installation was successful, but with problems. Here is my history:

  • The installation was successful. However, I also had the faulty device (retimer) in the device manager
    o Hard turn off the device (power button longer than 30 seconds) demonstrated the installation at the next start and climbed the error.

  • Now, no display on the USB-C or HDMI port worked anymore.
    o In the BIOS I selected “Battery disconnect” and left the device without power supply for a few hours. In this state, the device cannot be turned on.
    o At the next start my external display also worked again.

1 Like

I got the same error

This device cannot start. (Code 10)

Indicates a revision number encountered or specified is not one known by the service. It may be a more recent revision than the service is aware of.

Firmware failed to update during the last attempt.

Last Attempt Version: 136
Last Attempt Date: 3/1/2023 21:39:06
Last Attempt Status: 0xC0000058

I also use the Lenovo Thunderbolt 3 Graphics Dock as my TB3 device, left Type-C port is not function. Right Type-C port can charge but no any other functions (No USB, Ethernet, GPU…)


I created the UEFI Shell USB drive. Poweroff the laptop for somewhile. Unplugged my SSD so it run and boot only from the USB drive.
After the automated update installation, then poewroff and plugged my SSD again.
First boot: TB3 dock can partially functions on both left and right Type-C ports. (Can charge, Ethernet works. eGPU not fully work.)
Second boot: Everything works completely fine.


Tried the windows installer, timers updated just fine however upon checking the main BIOS, the firmware was not able to start. Waited until all installers finished, restarted twice, but the main BIOS failed to update from 3.04 to 3.06. Tried to roll back firmware, but unsuccessful. Firmware in BIOS shows 3.04. Any tips on how to roll back to 3.04? Right side ports only support USB 2.0 as mentioned in notes? Would a clean windows re-install take me back to 3.04?


Update: I reset windows and kept my apps. Upon startup, I went to device manager, then firmware, then clicked on the 12th Gen BIOS option below the timers with a hazard icon. It then proceeded to allow to me to restart my computer, where 3.06 was successfully installed.

1 Like

So, a report on USB-A funkiness from using the 3.06 beta BIOS - my USB-A ports seem to be a bit finicky now (I’ve had this happen with a mouse receiver and a hardware key) on both sides of the laptop (2 different USB-A expansion modules). After suspend/resume (S0ix), the USB-A port will not detect anything plugged in until I pop the expansion card out and reseat it (and then it works as normal).

I am running on Arch Linux (6.1.2-arch1-1) and I’ve had this issue on both sides and am running the updated v310 firmware for the retimer (ba2e4e6e-3b0c-4f25-8a59-4c553fc86ea2 and a9c91b0c-c0b8-463d-a7da-a5d6ec646333 on 310).


Windows install worked as described in the instructions. USB-C ports (both sides) not recognizing TB4 USB hub (Intpw Model: ID558). The laptop will not boot up with the hub connected. once it does and the hub connected, DP works but is reported as not compatible. RJ45 not connecting to router and any USB devices do not connect. Funny that the DP port would work and the rest would not?
Unit will not go to sleep.

1 Like

I initially used the fwupd method, and an initial reboot did happen and perform at least some of the update - BIOS, one of the retimers, maybe more. But on checking fwupd afterwards, an error report was sent and one of the retimers just wouldn’t update - I was repeatedly prompted, but no amount of switching power between ports or swapping USB-C modules around helped.

I used the USB EFI in the end and that was a flawless experience.

1 Like

I had nearly the same experience as @Dan_Walker;

  • lvfs method failed (repeatedly) on Retimer23, other components seem to have upgraded fine.
  • USB UEFI shell way reported all OK after a number of reboots, as expected
  • but fwupdmgr update still wanted to Upgrade UEFI Device Firmware from 207 to 310?
  • power off, remove AC, wait 2 minutes; that finally made it work.

(repeatedly == multiple runs of fwupdmgr update and the associated reboots. I did try both with secboot on and off, at least twice each, I did do the 30 seconds powerswitch dance during two of the tries, I did try with new boot device priority auto and first)

I’ve updated both the WD nvme and the BIOS firmware to it’s latest versions.

$ sudo dmidecode -s bios-version
$ cat /sys/class/nvme/nvme0/firmware_rev

Edit: I’m running the kernel:

$ uname -rmo
6.1.3_1 x86_64 GNU/Linux

I also have the following inside my /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4 pcie_aspm=off nvme_core.default_ps_max_latency_us=0 nvme.noacpi=1 mem_sleep_default=deep"

Let’s see if something changes on the random disconnects of my nvme on (means: not available after) suspend.

So far, my NVME did disconnect randomly under no load whatsoever 3 times, luckily no fs corruption yet.

Until this problem is solved I cannot move my private workplace to the framework laptop.

1 Like

I have discovered that the powering the Laptop utilizing the PD port on the Hub was the culprit. Powering the Laptop from the left side USB-C port and having the Hub use the right side port fixed the issues with the Hub. The laptop will not sleep while the DP (on the Hub) is active, does otherwise.

1 Like