12th Gen Intel Core BIOS 3.08 Release

I’m having constant external (only) display flickering, I don’t know if it is related to this BIOS update or not:

1 Like

Intresting, especially because they list it as fixed in the opening post:

looked for fwhunt: FwHunt/rules/Vulnerabilities/Insyde/BRLY-SA-2023023.yml at main · binarly-io/FwHunt · GitHub
more easy to understand whats going on:

A new update probably be happening (or a new bios “beta”)
Would be cool to see Binarly releasing the LogoFAIL scan code, guess they cant yet, as it seems to scan exact byte sequences (instructions, and if there, somewhat expose the exploit? might still be under NDA or whatever)


I can share that I managed to resolve the issue by digging in the 3.06 beta thread. The following suggestion helped: 12th Gen Intel Core BIOS 3.06 Beta - #54 by chutwig
I uninstalled the retimer 23 device and ran the 3.08 msi again. This time the system rebooted and applied a firmware update again. After rebooting to windows, the retimer 23 reports no issues. So far all ports are functioning, I will test with a TB3 device today as well.


Glad to hear you were able to resolve your issue!

I think in the non-Beta release, it would be beneficial if Framework add the option of forcing a complete re-update, to resolve failure cases like this.


Hi there,
Very good news, Any update on a release candidate ?
For the UEFI / linux updater too ?


@Kieran_Levin Want to follow up on the previous comment. Do you have an update on where the release timeline stands? I know it was mentioned previously that the beta period would be 2 weeks, except in cases where there are blocking circumstances. Seeing as there’s been some issues with this release on the EFI installer, etc, does this push the release back until these things can be ironed out?

Just want to level-set expectations so this thread doesn’t devolve into the 3.06 beta thread.



I’d also like to add to that:
When FW decides to not progress to the release, but keeps the update itself online and available, they really should update the “Known Issues” listed.

The 3.06 beta update is still available and in over a year has never gotten any known issues listed that would allow customers to judge whether it might be worth it or still beneficial to them to install that update.
But obviously it must have had some rather serious issues to not progress to release.

I’d very much like to see that FW has learned from the past failures with software updates and is improving.

And it might also be beneficial to explain in a little more detail why the EFI version was taken down. Because reading through this thread, it looks like the issues it was pulled for were identical to the ones the 3.06 Beta EFI version had and that not only stayed up for over a year, but it is still up.

Is the 3.08 EFI updater actually dangerous to the device/risks bricking but the 3.06 is not? Or is this just strategy, because you’d like people to try a revised updater for the same version step?


I have my FW 13 laptop with a 1240-P i5. There aren’t any issues other than the HDMI signal dropping out frequently using a Thunderbolt enclosure. I tried setting the battery threshold to 100%. While it seemed like it worked for some time, the issues are back. I was looking to see if maybe is a BIOS thing, if so then i can perhaps flash an updated BIOS to it but This looks to be a Beta release. Not sure if I should flash it or wait until I find some kind of solution for the issue… What do you guys think?

Is there currently any way to install this update without windows?

I’ve been having issues with excessive thermal throttling on 3.06 lately, and I’d love to see if this fixes it.

1 Like

I’m having exactly the same problem as you. My Framework is i7-1280P from batch 2. I’m also on 3.06 beta.
Can you elaborate how to install the BIOS after unpacking? EFI installer is not accessible now and LVFS is not updating everything so my only way is Windows installer :wink:


I could. But look for Kierans response a few posts down. FW linked 3.08b beta installer that works, so that would probably be better for you. Although I have no idea why FW did not update the main link after multiple people reported that solving the problem.

1 Like

It worked. Thanks!

I’ve been having issues with excessive thermal throttling on 3.06 lately, and I’d love to see if this fixes it.

I’ve had excessive throttling on all versions, including factory. This new update doesn’t help.

Bummer, I won’t rush to install this beta then. Thanks for letting me know

I don’t think that there is a issue with the new BIOS/ME/Retimer/… versions, because this would also lead to the windows updater being removed. I think, the biggest issue is, that the ME won’t get updated with the EFI updater and people think, they are uptodate now, which they are not.

The Linux update path is the one without ME, but otherwise uses the same capsule system where the BIOS essentially self-Updates.
And apparently, FW cannot update the ME from a capsule, but requires a separate updater executable.

The EFI update includes the ME. The update tool for it is even called the same (FwUpdLcl), just with .efi extension instead of .exe. Difference is, the EFI update also updates the other firmwares seemingly with separate update tools and not the capsule system.

Fix #4 “Plugging in a USB-A device multiple times would eventually not be recognized anymore” seems to have worked for me.

My 1 USBA port has worked reliably since this update was released.

1 Like
  • FAILURE SKU# and SYS SERIAL NUMBER: FRANDACP04, I’ll have to grab the serial number later since I don’t know how to see it from within Windows
  • SYS CONFIG: Intel i5-1240P
  • RAM: 2 x 16GB Kingston 3200MT/s
  • SSD: 2TB SK Hynix P41 Platinum
  • Wi-Fi: Rando ATH9K card
  • External Devices/Other: Anything attached? If so, what and how? If not, please indicate.
  • BIOS VERSION: 3.06
  • DRIVER PACKAGE VERSION: I don’t think I had updated the drivers yet. This was a fresh install of Win 11.
  • OS VERSION: Windows 11
  • FAIL RATIO: 0%
  • EXTERNAL DEVICE MODE or NAME: I don’t recall there being any external devices attached. Could’ve had a 32GB Lexar USB attached or my CoolerMaster EG200 attached but I don’t think so

Why is there only two people in this thread trying to hold FW accountable?

1 Like

Probably because the topic title says “Beta Release”.