12th Gen Intel Core BIOS 3.08 Release

Successful on the first try, no issues afterward

SYS CONFIG: i5-1240P
RAM: Crucial DDR4-2666 (8x2)
SSD Crucial P5 Plus
Wi-FI: Intel AX210
External Devices/Other: None
EXPANSION CARD TYPES: 2x USB-C (right and left rear - right rear was used for PD input, left rear empty), 1USB-A (front right), 1 storage card (1 TB, front left).
BIOS VERSION: Can’t remember what I started on. Bought the board in fall 2023, if that helps.
OS VERSION: Windows 11 Pro
FAIL RATIO: Used the .msi, success on first try
EXPECTED RESULT: Flashed Successfully

1 Like

There is no download and even if there was:

I hope its just a eDP cable issue that you can resolve by reseating some of it.

contact support is all I would do if reseating by myself would not fix it. and great you made videos, would help support seeing your issues :smiley:

Great news that this enables support for the 61Wh battery! I’ll finally be able to use that!

When will the EFI download be back - I’m running Fedora 39 here.


To me this reads as you can’t downgrade to lower that 3.06. I want to downgrade to 3.06!
Please give me download!!

Yes I have a ticket open with support. I probably won’t hear anything till after the weekend. I have things back to working in windows and just the glitchy nonsense on the splash screen and in the bios so I’m just going to leave the hardware alone for now.

1 Like

All that was ever published was the 3.06 Beta. And that thread is still up, including download links 12th Gen Intel Core BIOS 3.06 Beta. Framework never updated the known issues on that, even though it was enough to kill the release of this version as final, but other than that…


In theory you can, but as stated in that thread and some folks tried, left side ports will not function. If you have a support ticket going, great, hope they contact you with helpfull hints and ideas.

I never seen 3.04 or 3.05 downloads, they where only applied from the factory. 3.06 beta was, and still is available. My best guess is to retry 3.08, maybe with ass less possible hardware attached or inserted. I also rebooted after all updating, and disconnected the battery for 10 seconds (was a guess amount of time). The both side leds showed colorful leds probably finally really pushing the new firmware for the usb host adapters/retimers?

Support will know the best answers.

What was the problem? Was it related to the new BIOS in general?

In my case, under Windows 11, discharge battery to 80%



With patience, one time process bar goes to 100%, back to 95%…
some reboots later. Looks like for me so far everething ok.
With Tunderbolt-4 Dock got second screen like bevor.

SYS CONFIG: 12th Gen Intel(R) Core™ i7-1260P
RAM: Crucial 32GB, 1 Stick
Wi-Fi: Intel Corporation Wi-Fi 6 AX210
External Devices/Other: Power on USB-C
BIOS VERSION: From Factory 3.04
DRIVER PACKAGE VERSION: Framework_Laptop_12th_Gen_Intel_Core_driver_bundle_W11_2022_07_26.exe
OS VERSION: Dualboot: Windows 11, Debian 12
FAIL RATIO: worked on the first try.
STEP TO REPRODUCE: No Failure, so far. Can boot in both OS

1 Like

Thanks everyone for all the help and advice, I eventually got things working normally again.

Support got back to me and provided the same link to the 3.06 bios, they asked that I attempt to install the 3.08 bios again and if that didn’t work try the 3.06 bios. Neither one actually seemed to try to install as soon as the machine rebooted it just showed the normal boot screen (with flickering) and dropped me back into windows.

After another email from support with a long list of things to try. First they asked me to try reseating the display cable again. At first this went as poorly as the first time. No display output to the internal screen but I can connect an external one and things are working okay (of note if I reboot with the external screen connected I can see the boot screen on the external display and it does not flicker) the internal screen’s backlight keeps coming on momentarily but doesn’t recover like it did last time.

They ask me to boot with the internal screen completely disconnected and then reconnect. this time while connecting the internal cable I notice it feels a bit crunchy, so I hit it with some canned air and reconnected. This time when I boot up the boot screen is visible with no flickering and everything seems to be working!!!

Perhaps this was actually just really back timing for an issue with my internal display cable.

I still find it weird that it would happen just at that moment and before I opened the case. It’s also kind of impressive that windows would be able to persevere through a bad connection.

  • SYS CONFIG: i7-1260p
  • RAM: G.Skill 32GB Dual Channel 3200MT/s
  • SSD: Samsung 980 1TB
  • Wi-Fi: AX210
  • External Devices/Other: Only a 90w power cord
  • EXPANSION CARD TYPES: 2x usb C, 2x usb A
  • BIOS VERSION: 3.06
  • OS VERSION: Installing from Windows 11 23H2 from the MSI. Debian was also installed and GRUB2 was the bootloader.
  • FAIL RATIO: The first MSI link failed 100% of the time: “The installer can only be run on Framework Laptop 12 Gen Intel Core Mainboards.” The subsequent 3.08b msi succeeded the first time.
  • STEP TO REPRODUCE: 1. Run the 3.08 MSI file
  • OBSERVED RESULT: “The installer can only be run on Framework Laptop 12 Gen Intel Core Mainboards.”
  • EXPECTED RESULT: Flash bios
  • ISSUE RECOVERY METHOD: Use the 3.08b MSI file linked by Kieran Levin in reply 20 in this chain.
1 Like

Phew, glad it works again. dust got in there maybe or surface level oxi? we may never know. wishing you a display that will now forever work

The msi ran fine for me, no issues. i7 1280P, win11


Not sure if this is a new issue with this firmware or an existing one, but the difference in power consumption between performance modes is have little to no effect on power usage.

Windows balanced
Max battery - 31.5w
Max non-turbo - 33.8w
Max turbo - 30.7w

Windows performance
Max battery - 39w
Max non-turbo - 38w
Max turbo - 37.3w

Windows efficiency
Max battery - 22.62w
Max non-turbo - 25.48w
Max turbo - 22.27w

This is peak power during a benchmark. I was trying to see the performance difference between them to get a good balance of battery and performance but got tripped up by these numbers.

When I have more time I plan on doing more in-depth testing, as well as testing in Linux.

Is it possible to flash back to the original to confirm this is new behavior or will it block me from doing so?

On my system (Linux) the new update is not detected in fwupdmgr. I did 3.06 update with that method in the past, have lvfs-testing enabled. Is this expected?

This update won’t be done through lvfs, intel csme can’t be updated through it.
Also see below, update for linux is temporarily on pause.

1 Like

Apparently yes, you can downgrade, but if “original” means “released” to you, no

1 Like

Wild, that’s fine I’m not having any issues and will just assume this has always been broken which is a bummer.

Thanks for sharing that, re reading it I know I read it before and just forgot.

If you want to discuss tis further I would recommend having this split out from the topic.

At first glance I have several questions: 1) How are you measuring power draw? 2) Times you are measuring against? 3) Thermals while doing so? In short I don’t think anything is broken, or changed. I suspect you are measuring using Powertop which generally polls fairly slowly so “power usage” is not directly representative of what is happening over time you really need to use a kill-a-watt to measure draw from the wall. Also the thermals are going to matter immensely as the difference between the modes is going to be leavened by hitting those thermal limits i.e. throttling because it is a thin light laptop.

1 Like

Windows & HWinfo, I’m not concerned about wall power. Only battery.

In my testing the bios profiles don’t affect wall power only the windows power plans did.

1 Like

Warning: What I’ve attempted isn’t officially endorsed by Framework, replicate at your own discretion. I’m sharing it anyway since it did appear to work, the current lack of EFI update for folks without Windows, and in case Framework consider to officially optimize for this scenario.

Step 1: Installed Windows 11 on an external NVMe to USB drive. (Rufus)
Step 2: Access boot menu via F12 upon startup and boot from the external drive. Install 12th Gen Driver Bundle once booted into this WinToGo installation. Run crap to drain battery to 65%, then connect charger.
Step 3: Download and run 3.08 msi file normally. (3.08b wasn’t needed for my unit)
Step 4: Click ‘Yes’ when prompted by the updater to reboot. Windows will initiate a restart, the normal ‘restarting’ splash screen will show, then go blank. However, laptop will fail to actually power down (let alone restarting). Waited 10 minutes, confirmed laptop is indeed dead by confirming SSD enclosure’s activity light is soft-breathing (indication for ejected/sleeping disk on my enclosure), minimal heat coming from laptop and non-responsive Capslock light.
Step 5: Hold down Power Button until power off, and immediately power the laptop backup.
Step 6: The update will progress, with multiple auto-reboots. Between each reboots, it appears to be updating different components judging by the progress bar taking different time to complete each time.
Step 7 (if applicable): Between each reboots, should the laptop attempt to boot from internal SSD, shut it back down and reboot from the external drive via F12 menu. Between each reboot, should the laptop locks up like in Step 4, verify it is indeed locked up due to a similar situation by using methods described in Step 4, wait sufficient time as described, and then force a reboot.
Step 8: After about 7-8 reboots and progress bars, I noticed each time the progress bar is now taking the same time to complete, a likely indication of it’s now updating the same component repeatedly. When the laptop hanged again due to a ‘failed reboot power off’ like described earlier, I discontinued the loop by simply power off the laptop after a hang.
Step9: WinToGo is now broken, set it aside. Booted into BIOS and verified Intel CSME, Microcode, GOP, EC, PDx2 and BIOS version are all successfully updated. Can’t find where to check for SI and TXT version.

Everything appears to be functioning normally after updating with this method.

Things can be done differently in hindsight:
1: Use a SATA-based SSD, from experience they appears to play nicer for WinToGo applications regarding the Reboot/Power-off behavior, compared to an NVMe enclosure. This could potentially eliminate the ‘reboot power-off fail’ hang first described in Step 4. However, if that hang/lock-up behavior can be eliminated, but the update still enters the loop as described in Step 8 and 9, I don’t know how to safety exit it. Perhaps spamming F12 upon reboot and choose boot from internal, to safely break the boot.
2: Change BIOS boot order/settings to make the external SSD be the top choice, before initiating the update. Could potentially address the issue of laptop erroneously attempt to boot from internal SSD between reboots.

After this, I booted into Windows installation on the internal SSD, and performed the 3.08 update again just to play it safe in case there’s anything unfinished, since I do have an internal Windows installation after all. Everything worked as intended when running the msi updater from internal SSD Windows installation. Nothing noteworthy.

Need to run now. I’ll later update the post to refine my description/wording, and add Matt’s checklist by filling it with information regarding my 2nd, normal update attempt.

Checklist done mostly according to my 2nd, normal update attempt.

  • FAILURE SKU# and SYS SERIAL NUMBER: FRANDACP04 (1240P DIY, late production unit)
  • SYS CONFIG: i5-1240P DIY.
  • RAM: TeamGroup 16GBx2
  • SSD: TeamGroup 1TB TM8FP4001T
  • Wi-Fi: AX210
  • External Devices/Other: 30W charger via right-far port. (closes to power button)
  • BIOS VERSION: originally 3.05, updated to 3.08 with my weird approach above, then re-updated 3.08 from 3.08 by performing it again as intended.
    Original 3.08 package worked for my unit. 3.08b wasn’t necessary, didn’t try it, and unsure what Kieran changed.
  • DRIVER PACKAGE VERSION: The launch driver pack, the only that’s available.
  • OS VERSION: Windows 11
  • FAIL RATIO: Success
  • OBSERVED RESULT: 1st improvised update broke my WinToGo installation. 2nd normal update worked completely fine.
  • EXPECTED RESULT: Obviously this one, we expect it to flash successfully and be reflected in BIOS settings.
  • ISSUE RECOVERY METHOD: N/A. Update appears successful on both 1st and 2nd attempt
  • EXTERNAL DEVICE MODE or NAME: 1st attempt with WinToGo on EC-SNVE and SiliconPower A60, and 30W charger (both on right). 2nd normal attempt is charger-only.

BIOS/Intel CSME/Microcode/GOP/EC/PD versions verified good. Unsure how to check SI/TXT.

1 Like