12th Gen Intel Core BIOS 3.08 Release

Thank you. Interesting. The PCR0 contains the hash (sha256 in this case) of the core system firmware executable code. PCR1 contains the platform-config, which usually changes based on the CPU/RAM/etc. I have the i5-1240P version. Have you also updated the ME?

Indeed, this is the firmware issue discussed here: [TRACKING] Battery flipping between charging and discharging / Draws from battery even on AC

For the lack of a better thread I figured I’d also report this interesting improvement with the new beta:
I often work with 3 type C peripherals:

  • A 4k monitor which also does the charging and has my yubikey connected
  • A thunderbolt nvme ssd (ACASIS TBU401E) for my systemd-homed work environment
  • A type C HUB with additional ports for occasional extras and the LAN connection (EDIT: I tried with a few different ones: a renkforce, a lenovo and another I currently don’t remember the brand of)

The following issue does not happen anymore:
Prior to the update, if I booted with all 3 plugged in the thunderbolt nvme wouldn’t appear until I unplugged the hub and plugged in the nvme without the hub connected, after which I could plug in the hub and everything would work normally.

Note that I did not test any different arrangements of ports because my workspace layout sort of forces me into one of only 2 possible configurations without crossing and bending cables awkwardly.

I can now boot up with all 3 connected and it seems to work fine.


Personally I think it is very good to post it here, especially that this update is important to the Thunderbolt functionality. It is great to hear that it improves it in a real world scenario :slight_smile:

1 Like

Just done mine:

  • SYS CONFIG: i7-1260P
  • RAM: Crucial PC4-25699 1 stick, 32GB
  • SSD: WD Black SN850, 500GB
  • Wi-Fi: Stock Wi-Fi
  • External Devices/Other: None
  • EXPANSION CARD TYPES: LHS: Far USB-C, Near USB-A, RHS: 2x USB-C (Far for charging)
  • BIOS VERSION: 3.05
  • DRIVER PACKAGE VERSION: Last update from Framework + some Intel Updates
  • OS VERSION: Windows 11 Home
  • FAIL RATIO: No Fail
  • EXPECTED RESULT: Obviously this one, we expect it to flash successfully and be reflected in BIOS settings.

Appreciate your understanding that we have to be careful with these beta releases. Yes, it’s still an active process that is getting focus. As noted here, we pulled the EFI option after determining that it wasn’t ready to come out of Beta.

We have a team working on this. I cannot dive too deep into next steps yet as we are still identifying the best path forward. However, yes, it’s actively a focus and yes, there will be more updates coming.

For right now, in the here and now. We have seen a decent success rate getting this updated using Windows. Obviously, like most of you, I am a full-time Linux users. So I have no desire to install Windows to update my BIOS.

That said, in the short term, this method below is shaping up to be a winner:

  • The entire process of USB creation can happen in Linux.
  • Using Ventoy to create a Windows USB, you can boot from it and not install Windows, rather, access its command prompt and get into the second USB drive with the Windows release of the BIOS update.
  • The upside is this can be done without “installing” Windows.

EDIT. Actually, this won’t work with MSI. We’ll need to wait for the EFI fix upcoming


Could you please share some kind of genetic roadmap just to have clearer expectations about what’s happening and dated?

“we are still identifying the best path forward”
From my understanding/experience this means something like: “We are currently talking/thinking about what we should do next, because right now we don’t know or don’t have the time/resources for it.”.
At least that’s what our project leads at work tell the customers and leadership if there is no progress :smiley:

While creating a Windows boot stick to install the update is a good workaround/short term solution, I can’t imagine “normal” users are happy/willing to do this.

1 Like

Did the EFI method break laptops? cause it worked fine for me and some others it seemed. I dont like sharing the efi files while the official beta got removed, cause who can trust little ol me? if the windows stick method truly is such a problem, why consider a beta bios at all. just wait.


@Matt_Hartley Can you please share some details. What is the exact problem of the EFI updater? Is it the missing ME update? If people used the EFI updater (and updated the ME), will they need to wait for another update to fix something? If yes, what?

I’ll also have the impression that this will end as the EFI updater for Gen11 3.19. “Coming soon” forever and no clear communication.


Has anyone done this successfully so far?

  • Nothing but Charger + USB Drives attached
  • I booted a Win10 (22H2) installation media from ventoy (normal mode)
  • I can find the second drive (FAT32 formatted USB drive) with the msi file on it
  • Executing the msi without by simply calling it from cmd gives me a messagebox with “No such interface supported”
  • cmd afterwards shows “Access denied” (cmd was opened as administrator)
  • Calling msiexec /i [installer.msi] cannot find msiexec

Edit: I also tried using Win11 (23H2), but it gives me a messagebox with “An attempt was made to reference a token that does not exist”
Edit2: Formatting the second drive as NTFS does not work either

Any ideas?

  • FAILURE SKU# and SYS SERIAL NUMBER: FRANMACP04 (SN: I have that ready, but not sharing that in a public forum)
  • SYS CONFIG: i5 1240p
  • RAM: Crucial 3200 2x16 GiB (Jedec, CT2K8G4SFRA32A)
  • SSD: Samsung 980 1 TiB (non-pro)
  • Wi-Fi: Original - AX210
  • External Devices/Other: Baseus 100W USB-C charger (worked perfectly in all previous situations)
  • EXPANSION CARD TYPES: Left: USB-C Rear, USB-A Front, Right 2x USB-C (charger plugged in here)
  • BIOS VERSION: 3.04
  • DRIVER PACKAGE VERSION: Framework driver setup (there is only one), updated to newer GPU, WiFi, BT drivers from Intel
  • OS VERSION: Win 11
  • STEP TO REPRODUCE: 3.08b Windows installer.
    1. Installed ME update fine
    2. Reboot into capsule installation
    3. progress bar BS (not intelligible which run)
    4. came back to the device after a few minutes: device off
    5. turning back on manually, Windows loads
    • BIOS & ReTimer 01 updated successfully, ReTimer 23 not. Choosing to retry ReTimer update from Device Manager + Reboot showed update screen shortly, but quits silently and reboots back to Windows without updating
  • EXPECTED RESULT: Device manages to finish all 3 updates on its own
  • ISSUE RECOVERY METHOD: BIOS → Battery Disconnect, wait 5 Minutes. Plug charger into right side, let Windows retry → Success. Everything fine and updated.

This is pretty much the same behavior and solution I observed when updating my personal 1260p (FRANGACP06) from 3.03 to 3.06 last year (WD SN850 back then, more RAM, all USB-C expansion cards). Even was the same ReTimer that failed to update. Although, while I am not 100%, I believe I had a different charger plugged in and on the left side back then.
So it seems very much that the ReTimers updating is what is problematic and nothing has changed with that since the 3.06 update. Only that my own FW already had up-to-date ReTimers, so that was not an issue this time around.

1 Like

Following up on my attempt yesterday i just installed a fresh copy of Windows 11 23H2 on an SSD and tried to run the installer.
Surprise Surprise: It did not work…
Unfortunately i did not make any pictures, so i dont remember the error message…

I had to run Windows Update, restart the device and only then the BIOS update would install.
@Matt_Hartley Did you even test this method, before recommending it?

Matt is the Linux Guru at Framework. While it is conceivable that he would help with Windows testing it is not directly his lane. Furthermore, because it didn’t work for you, doesn’t mean it doesn’t work for someone else.

It would be really great if you could share the error you saw as this would help to improve things.

1 Like

I should have been clearer with the above statement. I did test it Friday after this went up, no, it is lacking msiexe in the installer, so it’s a no go. Post was updated to reflect this.

For exe’s, you just drop them in and hit enter. For msi packages, you would need msiexe, which is not available from the install media itself unless the OS is installed. We were able to determine this afterward.

I have spoken to engineering and the course of action is to continue to work on getting the efi option sorted.

However, those who do not wish to wait can install Windows and run the MSI which has a solid success rate in testing here in with the community and with us. Ideal, no. But it does mean there BIOS are available now, but for efi we need to get some things sorted as there are some configurations that are not playing ball.

For those of you using Linux that are not thrilled with this. Yes, I get it. Fulltime Linux user here. However the ventoy method of creating a Windows installer USB is sound and works.
Install Windows, run the MSI updater, complete the process. Then once you have confirmed the BIOS update, wipe Windows.


I know, but this is exactly where im coming from.
EFI was pulled, so FW recommends all Linux Users to install Windows or use the Windows installer method, that Matt suggested.
We know at this point, that installing from a Windows install works, but no one ever gave a heads up, that an Windows Update is required, to run the BIOS update.
The windows installer method does not work at all…
Imo FW should test these methods from a Linux users perspective, before recommending them.

1 Like

Updated the post and also replied with extended details here as well.

But to your point, this is where it fell down on my end:

I should have been clearer with the above statement - shaping up did not mean tested by me, it meant a lead on a likely fixes.

I did test it Friday after this went up, no, it is lacking msiexe in the installer, so it’s a no go. Post was updated to reflect this.

Please see this for details:


Im pretty confident the general recommendation is not to install this update at all since this is just a beta. There are still no updates for the 12th gen laptops as far as the average user is concerned.


*All Linux users, who want to participate in the beta :stuck_out_tongue:

1 Like

Suggestion: Ship a bios update ISO in addition to the zip. This will help users work around incorrectly formatted USB drives and should reduce customer support requests relating to BIOS updates.