About the Linux category

Setup guides, advice, troubleshooting, and more for Linux-based Operating Systems on Framework Laptop 16 (and BSD’s and other OS’s too!)

Cannot install Linux

Distribution: Artix Linux (Arch without Systemd) - But my issue is distro independent.

Created installation USB key from the ISO with the KDE Ark application:

$ ls
$ ls -la artix-community-qt-openrc-20230814-x86_64/
total 96
drwxr-xr-x  5   16384 May  9 12:13 .
drwxr-xr-x  4   16384 Jan  1  1970 ..
-rw-r--r--  1       0 Aug 13  2023 .artix
ddrwxr-xr-x 3   16384 May  9 12:09 boot
-rw-r--r--  1    2048 Aug 13  2023 boot.catalog
drwxr-xr-x  3   16384 May  9 12:07 efi
drwxr-xr-x  2   16384 May  9 12:13 LiveOS

The size of the data is 4GB, as expected.

Insert the USB key in Framework port and turn on.

I get this error message:
“Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key
Then Select ‘Boot Manager’ to choose a new Boot Device or Boot Recovery Media”

When selecting “Boot Manager”, I get an empty Boot Option Menu.

From FW “File Explorer” I can see the contents of the USB key.

USB Boot is enabled.
Timeout: 3 sec
New Boot Device priority: Auto

The USB key is shown in the attached device list.

Secure Boot Database: Installed and Locked
Secure Boot Status: Disabled
User Customized Security: NO

I keep getting the same error message: “Default Boot Device Missing or Boot Failed.”

System Details:
FrameWork 16, batch 13
BIOS version: IFGP6.03.02 (01/23/2024)
PSP Boot Loader Version: 00.2D.0.74
PSP Secure OS Version: 00.2D.0.74
RomArmor 3: Enable
Ec Ver: ec:d2b3a1
PD Controller 1 Ver: 0.0.1E
PD Controller 2 Ver: 0.0.1E

Thank you for your help.

1 Like

Probably the reason was in the application I used to process the ISO image.
I tried to do it from a Mac, and now the image is recognized and I can start the installation!