Alternating red/blue with the Ryzen 7840U board in standalone

I’m trying to run my Ryzen 7840u board in standalone mode, but it won’t boot. Al it’s doing is lighting up red and blue led in an repeating alternating pattern.

When I try to boot, sometimes it displays the diagnostic LED codes, which shows there is no Battery, Touchpad, Speakers or Audio or internal display plugged in. Which is natural since I’m trying to run it in standalone mode.
Then it gives me an error code, which I’ve looked up in Insyde bios manual. The code is B8, which I can’t find in the manual.

I’ve searched forum and found this thread, but I’m unable to reproduce his results with his method.

I’ve also found this Reddit thread

So this seems to be a general problem with the Ryzen boards.

I’ve tried contacting support, but it doesn’t seem like problem they are able to help me with.

Any tips or advice would be greatly appreciated.

Board: 7840u
Ram: Crucial 32gb 5600
Power: 100w ugreen charger

Have you tried booting it with one stick of RAM?

No, just tried though and I get the same results. Same codes. Thank you none the less :pray:

Is this in both RAM slots? And have you given it 5-10 minute?

I tried with both stick for hours. No change.
Just tried with one stick, in both slots, for about 30-45 min. Same result.

What’s your expansion card layout? And do you have anything plugged in other than the charger?

Charger in the lower left port, and nothing else. Apart from ssd and WiFi card.

Try using the charger in the upper left port and remove the ssd and wifi card. If it can’t boot after that, only support can really help you out.

I’m just posting my results for anyone finding this in the future.

I was able to get my hands on a spare Framework battery, and plugging it in stopped the blue lights, so it was only blinking red.

After some reading, I found out that the red blinking means that the top input cover isn’t on, and pressing the button in middle of the board.

I tried putting some tape on the button, and now the red blinking stopped as well, and there is a constant clear white led.

So what I think this shows, is that the mainboard isn’t set up to run in standalone mode, no matter what.

When I try boot now, I get a ‘keyboard isn’t connected’ code. So next step will be to try to get my hands on a input cover.

Well I got the input cover, and its working now. Which is nice. Hope this thread can help anyone in the future, if Framework cant fix the problem.

Replying to this so other can see what the constant white LED means.

It means the battery if fully charged and power is still plugged in.