AMD 7840U - initial setup fails

Hi there, after trying everything that comes to mind I see no other way than to write here to ask for help (please read the entire description before answering <3 ):

First of all, my setup:

  • Model: Framework Laptop 13 DIY Edition (AMD Ryzen™ 7040 Series)
  • SSD: WD_Black SN850X NVMe
  • RAM: Crucial DDR5 48GB 5600Hz SODIMM (CT48G56C46S5)

First considerations:

  • I plan to install linux (Fedora with updated kernel for display glitches).
  • I know the ram is not included in the support list but the community seems adamant that crucial ram should work.
  • Also I am somewhat used to tinker with electronics, so I installed everything carefully, the ram slots do not have any bent pins.
  • I already opened a support ticket.

What goes wrong:

  1. I installed everything (hardware) according to standard procedure. (followed instructions)
  2. I plugged the charger in (LED indicates charging)
  3. I pressed the power button
  4. After a few seconds the fan starts spinning and the proper LED-blinking-series flashes (white, some green, orange, more green) as described here: Mein Framework Laptop (Intel® Core™ der 11. Generation) lässt sich nicht einschalten
  5. Fan spins happily, I give it time
  6. After a few minutes, the fan-noise decreases
  7. Eventually the notebook powers down on its own.


Any other suggestions from you wonderful and tech-savvy folks?

Thank you very much in advance, I reeeally want to get going after waiting for the machine for so long :cry:

That’s a single 48GB ram stick? That size is rather unusual, it’s a new thing for DDR5, they didn’t exist for DDR4 and previous. (Also, 48GB in one stick is big.) Even if it theoretically should work, I’d try to borrow some cheap more-conventional DDR5 5600 to test with, to confirm the RAM is not the issue.

I don’t really worry about the 48gb stick. While not officially supported, based on previous reports 5600 crucial work fine and 48gb sticks work, it should probably be okay. That said I don’t think a single stick of that particular ram has been tested before. If you have the chance, test some known good one. Like 2x16 or 2x32 crucial 5600 sticks or the official Framework RAM.

On my laptop, I assembled all the parts, inserted a Linux boot stick into the front left usb A port, turned it on, waited a few minutes for ram calibration and it automatically booted from the stick.

Have you inserted a known working boot stick?

Are you sure you put it in the right slot? The slots are labeled “slot 0” and “slot 1”. On my first install I put the stick in “slot 1” without reading under the flap for the other one assuming it was the primary slot. My laptop wouldn’t boot with that setup.

Yes I am sure it is the right (quite literally) slot.

I tried starting it with the boot stick the first time. The stick was created with the fedora media writer. I have to admit I have no other way to test it at the moment. I expected however, that the Laptop would at least show a BIOS-screen if no installer medium was present.

The 48GB size is unusual ( I thought the same) but not as unusual as exlaining my problem. Unfortunately my funding does not allow for more ram-experiments at the time :confused:

I now tried again what Jonathan_Haas described but the laptop shows the same behaviour.

(I forgot to mention, that I have yet to see a single blinking pixel on my screen. It has been black (like off) the whole time, no matter how I tried booting.)

It might be possible the display is damaged and it’s actually booting. Can you try connecting an external screen using usb c or an expansion card?

I think I had a framework logo very early when turning it on.

I just tried, the external display did not react either.

Edit: Is it actually normal behaviour that it powers down after a while? (I’m talking about 3 Minutes of fan noise and then poweroff)

Update: Had some time during the break and used it to un- and re-install the ssd and ram. Plugged in the Fedora USB-stick and power-cable and started the laptop anew. Result: laptop with dark screen running for 2h with varying fan speeds. Other than that, no apparent reactions. Even the led-sequence was not showing (I did not monitor it for 2h straight , though).

I just tried to use this status to plug in a USB-C display again. To no avail. The only thing working in this connection seems to be the power charging function.

Update: 2 crucial 48GB Ram sticks together do not work either. The support ticket still has no response whatsoever.

Dis- and reconnecting the battery between boot-attempts also did not work.

So yeah…it was a bad RAM apparently. After a little more switcheroo I am now able to install fedora. Thanks for sticking with me.