[RESOLVED] AMD Laptop Won't Start

I just received my order today. I set it up following the quickstart guidelines for AMD. Turning it on, the fingerprint reader lit up white, and I could hear a light hum of the fans turning. I waited over 10 minutes with the screen never turning on. I decided to turn it off, and back on. Again nothing. I read some of the community support and noticed that some people have had issues using Crucial RAM cards. I go to the store and buy a Rip Jaws. I went back home, and again, I had the same issue. I tried both memory slots, and verified that they are both DDR5 and everything. Last I decided to unplug and replug the display. Same issue. At this point, I am lost. Any suggestions or things I can do to figure out the issue? I have already reached out to support, but they are swamped currently, so I figured I try here as well.

What speed RAM are you using? Also, have you tried using one RAM stick at a time?

1 Like

Both are 5200. The Crucial is 32GB and the Rip Jaws is 16GB. I only bought one of each and tried each of them separately on both RAM slots. I didn’t mix them or even attempt to.

So based on a community poll, there are 3 cases of individuals not being able to boot with 5200 mhz ram. At this point, Framework is investigating if it’s a RAM speed issue but they are not sure what the cause is. However, your best shot is to get 5600 mhz ram. Almost everyone that responded said they didn’t have issues with 5600 mhz. I used 32 gb of Crucial 5600 mhz ram and it booted in like a minute.


I will head to the store tomorrow morning and get some 5600s then. Afterwards I will give an update on the results. Thank you for your help.


I think you can try to read this article My Framework Laptop (Intel 11th Gen Intel® Core™) is not powering on and read the post code to make sure it is a ram issue.

The boot code is pretty hard to read, as it omly flashes once and flashes very fast. My laptop started posting while I was restarting it to try to read the post code LOL


So I just want to let everyone know. I switched to two Crucial 16GB 5600 RAM and it worked! Thank you for all your help!