AMD Framework USB-C charger compatibility issues

Same problem with a 30W UGREEN Nexode charger.

It is possible to limit battery charging to a SoC lower than the current one, which disables battery charging and results in low-enough power draw so the charger can ramp up successfully. After that, charging can be reenabled. But this only works if the battery has a SoC higher than 25% (minimum charge limit).

It is also possible to plug in a second working charger, which seems to still request the higher voltage from the unused charger. In this case, the 30W UGREEN charger also continues to work if the second working charger is unplugged.

1 Like

Another workaround I found to charge via low-power chargers is the PD direction change (role swap):
When using one of these portable USB-C docks with PD passthrough (for me, a Novoo Dock with HDMI, SD card reader, Ethernet, etc., model number “NVHUB8P60N5DNS”), PD just works, probably because the dock first requests 5V from the laptop, then requesting a power role change to pass through the PD PSU that is plugged in.

In the case of this specific dock, it does subtract 7.5W for itself and its USB ports though (as it should), so plugging in a 20W PD charger results in the laptop charging with 12.5W (which is still enough to very slowly charge during light loads).

Obviously not a great solution, but might help out in a pinch.

Edit: funnily enough, this even works with 5V 1.5A, in which case the dock takes almost all the power for itself and just advertises 5V 0.1A to the laptop, which it accepts and starts to veeeeery slowly charge (if even at all).


According to earlier replies in different threads, it is supposed to work even with low-current non-PD 5V chargers. But this seems to be somewhat glitchy as well. A 5V 1.5A USB-A charger does work if it is plugged in while the framework is charging from a different port (which is then unplugged). If the 5V 1.5A charger is plugged in first the frameworks starts drawing power shortly (~0.8A) and quickly stops again, without retrying.

1 Like

The only reports I’ve seen are on 11th gen, which presumably have different circuitry then AMD. The only official thing I’ve seen is 15w PD is the minimum. Where did you see that non-PD chargers are supposed to work?

for now (ignoring the general issue of starting charging), it seems like the Framework should charge with basically any charger, at least it does so when using @fbl’s workaround of plugging in both a working and non-working charger, then unplugging the non-working one.

This includes:

  • USB PD chargers with active communication (anything above 5V with C-to-C cable)
  • USB PD chargers without active communication (5V 1.5A and 5V 3A with C-to-C cable)
  • USB BC 1.1 DCP chargers (5V with bridged D+ and D- with A-to-C-cable)

Which all worked during my testing.
During DCP charging, it only pulled 800mA, but that is absolutely fine, because you don’t want to overload “dumb” chargers either.

QuickCharge and other proprietary standards aren’t implemented afaik, but at least 5V DCP-style charging should work on these chargers as well (and has done so in my tests)


@Second_Coming Yes, I recently got my Laptop 13 with the Intel i5 13th gen and have had the same problems. I have a 3 port anker gan 65w charging brick with a type c-c cable that supports 100 w. Usually, when the laptop is turned off it charges ok but as soon as I plug it in while doing something it starts to have this problem of charging off and on constantly. There haven’t been any new bios updates that I could find for this issue for my chipset.

I didn’t want to post originally just a “me too” but since others have been adding their feedback I just wanted to say I also experience this issue on the AMD framework 13 with 45W Anker nano II gan charger as well as the Raspberry Pi 27W USB-C charger.

@patagona covered the issue well in their first post so I don’t really think we as a community need any more "me too"s. We should just accept that any proper charger (that respects the spec and shuts itself off due to over current) should NOT work with the current bios.

@Kieran_Levin I understand things take time to go through proper QA but it has been three weeks already. Can we get some sort of timeline on a new bios being released with this issue corrected? I think it’s safe to assume there are many users who can’t properly charge their devices.


I just basically ran through most of my collection of pd chargers and powerbanks to se what works and what doesn’t. Only tested with the laptop on and around 20% charge (and stress --cpu 16 to simulate max power draw).

It does indeed look like something may be a bit bugged with the pd controller (or the ec or something in between), all the 20V capable ones worked (well except that one sketch powerbank board but that one barely works at all, which sucks cause on paper it is exactly what I want). The 12v capable ones tend to need a kickstart (connecting and removing a directly working power source) but work fine after that.

Appart from one of the 12v powerbank bugging into 5v charging (it actually stayed charging untill I removed it doing about 2.2A into the direction of the laptop) more once 5v charging from non pd sources doesn’t seem to work at all which is kinda sad. Sure it’s mostly a gimmick but I like that gimmick and the laptop seems perfectly capable of charging off 5v once it decides to do so.

Here a list of the chargers tested with negotiated voltage and max observed current

  • No name 45W powerbank → 20V 2A
  • Baseus 65W powerbank → 20V 3A
  • Baseus 100W multiport charger → 20V 4.5A
  • Baseus 30W wallwart → 20V 1.4A
  • Baseus 20W wallwart → 12V 1.5A (needed kickstart)
  • No name 65W charger → 20V 3A
  • Wotobeus 100W power brick → 20V 4.5A
  • Wekome 40W wallwart → 20V 1.8A
  • Random 100W powerbank board → fail (but that board is scuffed anyway)
  • IP2368 powerbank board → 20V 4.5A
  • Random 22W powerbank board type 1 → 12V 1.4A
  • Random 22W powerbank board type 2 → 12V 1.5A (needed kickstart)
  • Random 22W powerbank board type 3 → 12V 1.4A (needed kickstart, probably ocp looped otherwise)
  • random qc3 powerbank → briefly powers after kickstart, does not stay on
  • 5v only powerbank c to c → 5V 1.1A (needed kickstart)
  • 5v only powerbank a to c → 5V 0.8A (needed kickstart)
  • 5v phone power supply → 5V 0.8A (needed kickstart)

Edit: added retests of the 5v ones


You’re a braver man than I! I would not feel comfortable messing with chargers to that degree, knowing from past, cheaper laptops how easy it can be to plug a bad charger in and damage a port.

It’s not actually that easy to damage stuff without going way over voltage and it’s not like I have never tried any of those before, hell I got some of them expressly to stress test them.

I have done way sketchier stuff than plugging pd power supplies into a pd device XD

1 Like

Both 5V C-to-C and A-to-C with proper resistors should work with kickstarting (both worked for me).
Maybe your 5V C-to-C source and/or A-to-C cable is faulty?

For USB-C-sources: some don’t have the necessary resistors (should have two, some have one or none)

For USB-A-cables: some don’t have the necessary resistor (should have one, some have none)

Maybe try some different cables or try turning them around (on both sides).

1 Like

Hell let me do some more retesting here.

For stuff past 5v you need full negotiation over the cc pins, resistors are just for the really basic stuff.

For the c to c I was using an e-marked 5A thunderbolt cable, I could try a few different a to c cables though.

Edit: interresting, with a fully charged laptop both a to c and c to c worked with 5v with a bit of kickstarting, I tried a basic 5v phone charger, and old anker 5v power bank and a 5v usb-c + usb-a powerbank board, the a to c all did 0.8A which is a hell of a lot better than nothing and the c to c did 1.2A. I’ll discharge the laptop and see if it still works at lower charge because some of the 12v pd sources also worked without kickstart on a fully charged laptop but needed one when it was discharged more.

Edit2: Yeah even discharged they work now, maybe my kickstart technique just wasn’t good enough the first time and some of them do take multiple tries to stick but they can indeed be kickstarted. Updated the list.

Edit3: It keeps getting weirder, when the laptop is powered off, the a to c connections are still capped at 800ma but it somehow happily pulls 2.7A out of the 5v only power-bank with the c to c cable once kickstarted. The qc2 powerbank also goes over 2 a briefly and then turns off which is more than it does when the laptop is on.

1 Like

Same problem for me with the same 30W Ugreen charger.
The red charging led blinks always on and off and after some time (maybe) it starts charging.
A bios fix or a info why it is not working would be appreciated :slight_smile:

Summary Post

Please stop saying you have the same issue, that just causes a lot of unnecessary noise in this thread, upvote the original post instead!

The issue has been acknowledged by the Framework team, who are probably looking into the issue for the next firmware version (though I feel like with the upcoming Framework 16 launch, they might be a bit busy right now).

Problem Description

The main issue seems to be that the Framework laptop overloads chargers with more than 5V but less than 3A. This means, the laptop needs multiple retries when trying to charge via a 20W/35W/45W charger, if it even starts charging at all (60W and 100W chargers should not be affected).

Additionally, the laptop does not seem to start charging on 5V (but does charge with the described workarounds below), neither with the resistor-based PD communication, nor with USB-A chargers through A-to-C-cables.

For now, this issue seems to be independent of the PD controller / embedded controller firmware upgrade, but some reports say this only occurs since the 3.03 firmware package.



Charging via the non-working chargers works when “kickstarting” the laptop with a working (>=60W) charger first.
For example, plugging in both a 20W and 60W charger, then unplugging the 60W charger leaves the laptop charging from the 20W charger without issues.

PD Passthrough

With at least some portable USB-C docks that have PD passthrough and can be used both with or without external power, charging via the PD passthrough works without issues (I’ve personally tested a NOVOO unit).

Additional Information

Charger Type Result Example Chargers
100W USB-C PD Works Storm2 USB-C1, UGREEN Nexode 100W
>15W <60W USB-C PD Starts charging with workarounds Storm2 USB-C2, Steam Deck charger, Anker PowerDrive Speed+ Duo, Belkin WCH001dq, 30W UGREEN Nexode, […]
7.5W/15W 5V USB-C PD Does not start, workarounds untested cheap No-Name USB-C 5V charger
5W 5V DCP (A-to-C) Starts charging with workarounds (5V 0.8A) Anker 24W 2-Port USB-A charger

There seem to be some outliers (“Anker Prime 67 W” and “MiniX Neo P1” apparently have issues, even though they have >=65W)