AMD RAM issue

Attenion: AMD Batches
While the sample size is small (three reports), RAM modules rated for 5200 MT/s do not appear to work at this time.

If you purchased 5200 MT/s and can still return it, I would recommend you do that.

If your return window has passed, you may still be able to return your kit if you accept a restocking fee (Amazon taxed me 20%). Of course, you can always try your luck on the used market; however, without a way to verify functionality, you may be forced to accept a reduced price.

Regardless, if you need a working machine the day it arrives, I would recommend you order a kit rated for 5600 MT/s.

You may also check latest BIOS and RAM compatibility pages to see if 5200 MT/s support is listed. Perhaps FW will have patched support by the time you are charged, but you should be mindful of any BIOS release dates to make sure there has been at least 1-2 weeks preceding your charge date (otherwise your mainboard may have been sent to fulfillment prior to the availability of the updated BIOS).

Latest BIOS:

List of officially compatible RAM modules:

Original Post

I don’t think the memory I bought is compatible :frowning:

Tried both sticks and let it run for quite awhile (at least 10 minutes). Took one out and its been 10 minutes.

Going to try booting up without the USB installer if it gets to 15 minutes.

My kit:

Crucial RAM 64GB Kit (2x32GB) DDR5 5200MT/s (or 4800MT/s) Laptop Memory CT2K32G52C42S5

1 Like

If you used the memory compatibility selector from crucial, they guarantee compatibility or your money back -

If you order one of our products using our Crucial® System Scanner or Crucial Advisor Tool on our site, we guarantee they will be compatible or your money back.

If you ordered an incorrect product and need to exchange it for a different product. Just set up a refund within the 45 day refund period, and then place a new order.

Note: Crucial reserves the right to charge a restocking fee (up to 20%) at our discretion.

1 Like

I ordered the memory in July to take advantage of a sale. There was no known working modules at that time. I started a thread to get answers but there was no guidance.

1 Like

I would at least try contacting crucial to see if they would be able to do an exchange or work with you on it, since the memory models should still be in good condition. Worst they can do is say no. Risk to reward ratio is looking good on this one.

Crucial Contact Info:

US & Canada

Customer Service & Technical Support

Toll-free: 800-336-8915
Phone: 1-208-363-5790
Hours (MT): Monday - Friday: 7am - 6pm

1 Like

It never hurts to ask, and they were advertised as “Ryzen” compatible. I only see 5600 modules listed in the QVL, so maybe that’s the only supported speed.

It’s making noise. And I did see the LED on the right flash green/blue. Just nothing happening.

For those of you who already have a working system, did you boot for the first time with or without the USB installer?

1 Like

That’s unfortunate if that kit doesn’t work. Oddly Framework sometimes seems to struggle with speeds slower than the rated maximum. Case in point, in past gens the DDR4 3200Mhz kit of Kingston Fury Impact worked flawlessly with most users from what I’ve seen, but the 2933Mhz kit would flat out not boot at all when I tested it, and this was corroborated by multiple users.

Granted, Kingston Fury Impact kits have nonstandard timings, so I’m surprised the same would be true with more standard JEDEC kits… might be a one off, either way, agreed worth reaching out to Crucial, and though I doubt they can do anything might also be worth pinging Framework support just so they’re aware… I don’t see why this kit wouldn’t work under normal circumstances.

Edit: I’ll also say I am absolutely cursed with buying new RAM and I’ve had to RMA multiple kits where the replacements worked fine.


I believe there are multiple reports of this kit working CT2K16G56C46S5

It was also heavily discussed a few weeks ago for being quite affordably priced.


You know, this thread brings me back to my experience with my 11th gen batch 4.

Including this! I couldn’t get a screen either.

And it did turn out to be the RAM. With both sticks, no boot. It did boot with one stick, then the other. So it turned out to be that the RAM wasn’t properly seated, even though it locked into place. I guess the SODIMM retention locking mechanism doesn’t work as well as it does with desktop RAM.

Long shot then - have you tried reseating the RAM? With one stick in, then both?


Thank you for the info. Might be the boat I’m in :frowning:

I almost bought that kit, but I wanted 64 GB to compliment what I have in my desktop currently.

Things I’ve tried:

  • Mem 1: Channel 0, Mem 2: Channel 1, USB installer
  • Mem 1: Channel 0, USB installer
  • Mem 1: Channel 0, No USB Installer
  • Mem 2: Channel 0, No USB Installer
  • Mem 1: Channel 1, No USB Installer
  • Mem 2: Channel 0, Mem 1: Channel 1, USB installer

Your timing is funny… Channel 0 has no resistance whatsoever. I wasn’t paying attention earlier, but I remember wondering when I first installed the kit if I put it in correctly. It just fell in without any effort.

I am going to try booting with no memory and see if the lights are the same. I’m noticing one orange light in between the green and blues.

Edit: Lights seemed identical…

Edit2: I also carefully inspected the slots and was able to get Channel 0 to register a little resistance, but barely any. Both Channels have way less resistance than I am used to, but there is a least some resistance in Channel 1.

Can anyone comment on whether you need a USB installer for the first boot? If so, does it need to be FAT32?

Please write down and send the exact sequence of the flashes. They are the POST code for troubleshooting.

How about a video?

Apologies if it shows up grainy. I think that’s Google’s compression at work…


@Todd_Freeman are you waiting long enough? Whenever you change the memory it does something on the first boot, it takes longer when you have more memory. For me with 64gb it took 3 to 4 mins before the screen showed anything.

They describe this in the quick start guide i think (i read it somewhere because i also thought something was wrong).

1 Like

I believe he said he waited 10 minutes. Unfortunately, it doesn’t seem to be that simple.

That’s the million dollar question, I suppose. The longest I’ve let it sit so far has been about 20 minutes.

Makes me nervous. I have a laptop cooler underneath it now, but it was getting pretty toasty.

In case anyone else is wondering, the sequence shown in the video is:

  • White
  • Green (x12)
  • Red
  • Blue
  • Green
  • Blue
  • Green (x5)

Thank you, @Brod8362!

I also connected it to my TV to see if maybe the display was compromised somehow. There’s no damage as far as I can tell, but I am not seeing any kind of backlight turning on at all. Nothing coming out through the USB-C to HDMI adapter.

Referencing my above sequence, and using this knowledge base article, the post code is either 0b10100000 (0xA0, 160) or 0b00000101 (0x05, 5) depending on what order they send the bits in (not 100% sure)

The twelve green flashes indicate “internal display initialized OK”.

Not sure what we can actually do with those codes, but here they are.

1 Like

Whoops, that does not sound good, especially if channel 1 feels different.

Was worth a shot. :slightly_frowning_face:

Get in touch with support and show them the POST LED code.

Also referencing this, the laptop is claiming “DDR initialized OK” (indicated by the 11th blink being green instead of red). I doubt that actually indicates a memory training success but I feel like it’s worth mentioning.

@Todd_Freeman do you think it’s worth making another thread about this and asking a mod to move our comments over? I don’t think this discussion belongs here anymore.

Agreed so this is all in a new thread. Anyone, feel free to change the thread title.