AMD Ryzen 7040 Series BIOS 3.03 and Driver Bundle Release

Any kernel should work now. There might still be other issues still, but I’m not seeing any on 6.5.x now. So anything after 6.1.x is probably going to be fine.

1 Like

For others, a refresh may not be necessary, a sudo dnf distrosync --refresh --allowerasing might fix the problem as there was a buggy version of mutter released to F39.

1 Like

Successfully updated from Debian unstable, thanks. I didn’t notice any difference so far, it was already working for me previously with BIOS 3.02 and kernel 6.5.6.

I’m getting important graphical glitches (with both 3.02 and 3.03) after switching to a text VT and back to the desktop : big flickering white squares in several parts of the screen. Is it a known bug, has anyone else seen this ?

I was able to boot into 22.04.3 with the normal 6.2 kernel, and open wayland firefox without freezes for the first time!

Also, i just install all these updates under a free windows install since i have had so many issues already, just works so much easier there

I successfully upgraded to the 3.03 beta on Arch Linux using fwupdmgr. It took about 10 minutes and it booted straight into wayland afterwards. No graphical issues so far. Thanks for getting this update out so quickly!

1 Like

I successfully upgraded to the 3.03 bios using a flash drive then I was able to successfully install Fedora 39 KDE spin (it would boot to a blank screen on 3.02). So far things are working really well although I did run into the flickering white screen issue and had to add the suggested kernel param to fix it. The fingerprint system also threw an error while trying to enroll a 3rd finger and got into a bad state. I had to use this tip to fix it, but now it’s working great.

1 Like

After the update to 3.03 yesterday everything seemed to work fine. Today however the machine feels really sluggish and cores do not get over 544,4xx MHz, temps hover around 33°C. Has anyone experienced something similar after the update?
Fedora 39 Beta, practically untouched GNOME install (installed steam, some console utilities and configured wifi).

Edit: Don’t now why or how, but for the time being it seems to have fixed itself :man_shrugging:

Following the above instructions, I’m having issue with the UEFI Shell method. I have disabled secure boot and placed the files on a FAT32 USB driver. When I boot from it, I see the startup.nsh script run, and echoing turned off the screen goes black after that and just sits.

Any suggestion what would cause this?

I did the UEFI shell method, and it stayed on a black screen for a minute or two before it brought up an upgrade progress screen. Perhaps you just need to wait a bit longer for it?

If that doesn’t work, maybe try a different storage device? On my system, I used a micro SD card via the Framework micro SD module, and it went flawlessly, other than that mildly concerning period of black screen.

1 Like

I’ve had the same experience. Suspected issues with the FAT32 formatting or age of usb key. I then reverted to the other method and that worked.

1 Like

I attempted with 3 different USB drives, no luck. Worked perfectly with the first micro sd card.
Thanks for the help.

1 Like

I had the same Error when updating with the UEFI method. Was using a (somewhat better?) chinese baseus 65W charger. When i switched to the official framework charger all worked perfectly.

I’ve had issued with USB 3.0 drives with a USB-A port, specifically Toshiba ones. My Samsung USB-C stick as well as a Kingston DataTraveller USB 3.0 with USB-A port have worked in the rear ports, as well as the front left one.

After successful install of the 3.03 BIOS firmware, things are better…

  • the system now boots into Wayland instead of X11; no need to log out and back in to get the chosen window manager
  • the touchpad is smoother as reported by @Bumblebee; specifically, I was getting a lag-and-jump when initiating a two-finger scroll, now it initiates scrolling smoothly
  • the frequent screen flickering is greatly diminished but not eliminated


  • I’m now experiencing times when large areas of the laptop screen (I have an external monitor connected) get blocked out in white. This can last from seconds to minutes and the machine is unusable until it finally resolves (which, so far, it always has). I’ve only been running Firefox and Terminal in the GUI.

So it’s an improvement, though it’s still not quite a usable machine.

13" AMD Ryzen, vanilla Fedora 39beta, BIOS 3.03

Could you also share your kernel version.


FYI, if you swapped over an existing Fedora install from Intel → AMD you may have to sudo dnf repo-sync to fix fwpupdmgr.

Running 3.03 beta right now, will report if I find any issues.

1 Like

I installed firmware 3.03 with the UEFI shell update zip, worked fine with no issues. It did take longer than I expected, about 10 minutes, rather than the 1 minute or so that I’m used to from other motherboards, but that’s not really a problem. I was also a bit surprised that it didn’t reset all my bios config, since I read that warning for most of the previous firmware updates for the older intel models, but I’m not complaining :slight_smile:

It is working a lot smoother than 3.02 did, for ubuntu-22.04 with kernel package linux-oem-22.04c as instructed. Before the update, on 3.02, I also had lots of hitching and some freezing when using a wayland session, and while using a Xorg session was smooth, starting it took like 10 seconds of struggle switching video modes and sometimes crashed back to GDM. Now both types start and run smoothly as expected.

I also experimented a bit with the linux-oem-22.04d kernel package which is based on linux-6.5, and back on firmware 3.02 it didn’t start GDM successfully, but now on firmware 3.03 it does seem to work fine (maybe wifi driver is flaky, maybe just a fluke with my network, I haven’t had much testing time yet …)

Anyway, when I pre-ordered this many months ago, I fully expected it to take a few months after release for this brand-new platform to have really solid linux support. I’m very happy to see this timely beta bios release. Thanks!


I just updated my drivers and then the bios. It did restart the pc, but then it still shows the old bios version in msinfo32. I tried to install the bios again, but it has the same version after the second reboot:

Unable to install BIOS update on Windows 11, reboots but then displays EFI error code 21. Charger is connected.

Edit: Charged to 100%, and connected a different charger, and it worked.