[Announcement] Linux on your Framework Laptop 13 (AMD Ryzen 7040 Series)

Tested on Gnome in Fedora in a live ISO and everything worked fine right away off a single thunderbolt cable into a dock. Now I reboot back into Arch and it seems to be working too. There were some updates in Arch today maybe those fixed them or maybe it’s a fluke. Going to see if the flickering or white screen issue is fixed too, hasn’t happened yet.

Appreciate the update. Docks are the bane of my existence as 99.99% of the time it relates to the symptoms you’ve described. More often than not, I see docks not playing nicely, but not consistently bad. Brand name docks “should” be fine, but I have seen experiences where it can go sideways. Worth watching and noting the logs for hints that the dock contributes to any issues.

Myself, I always, always recommend video using expansion cards (HDMI and DP) with docks sticking to USB-A/C duties exclusively. But I know it’s not ideal. For my USB related needs, Anker has always been good to me. :slight_smile:

1 Like

Got my AMD 13 an hour or so ago. I installed Mint 21.2 Edge and so far it’s worked great out of the box.
Will keep playing around and post if/when I see any major issues come up.

The fingerprint reader does not work out of the box, which seems to be a known issue. The firmware out of the box does not support it and fwupd fails to even start. It’s running version 1.7.9.

Edit 2:
Change the kernal 6.1.0-1023-oem as recommended. This does seem to make the system feel a bit more snapy. Ran geekbench for a baseline. Link below. But the numbers look great from what I see.
Also I was able to get fwupd running now as well. Will see if I can get the finger print reader working next when I get some time.

Edit 3:
Got the fingerprint read to work after a few steps. Looks like it is a new firmware for the fingerprint sensor itself. First needed to follow “If the devices is not detected” part of this framework guide.

Then I installed libpam with:
sudo apt install libpam-fprintd

I could then run fprintd-enroll to get my right finger added.
Finished up by running sudo pam-auth-update
Did a reboot and could now log in using my fingerprint.


Awesome. You will absolutely want to make some kernel adjustments on AMD. While unofficial, this should still apply as it’s still based on Ubuntu 22.04.

Sourced from here.

NOTE: This is NOT official and is done as I need folks on Mint using the correct kernel. 6.2 is not going to be amazing. The recommended, tested, supported OEM C kernel will be far, far better.

For ticketed support and official vetting, we ask users to run Ubuntu 22.04.3 over Mint.

If you need to use Mint and understand I provided no support here to this, here is your best experience below.

Install the recommended OEM kernel.

sudo apt install linux-oem-22.04c


sudo nano /etc/default/grub

Identify your OEM C kernel

Back up GRUB

sudo cp /etc/default/grub /etc/default/grub.bak

Right now, the AMD target kernel we want folks on is 6.1.0-1023-oem - but this may evolve in the future. 6.1.0-102x-oem in the future. We use a Zenity alert tool on Ubuntu for this. You will need to do this manually or customize it yourself.
Again, this mini-unofficial guide is for Linux Mint, not other distros.

Change the following.



GRUB_DEFAULT="Advanced options for Linux Mint 21.2 Cinnamon>Linux Mint 21.2 Cinnamon, with Linux 6.1.0-1023-oem""

Then run

sudo update-grub



I’m expecting my batch 1 AMD to arrive tomorrow, question about Ubuntu: would Ubuntu 23.10 work or should I be sticking to 22.04.3?

1 Like

As indicated the batch email with the specific distro recommendations. You will have the best experience following 22.04.3 and using step 4 of the provided guide.

1 Like

I can not get external displays to work. I have tried Fedora 39 and Arch. I have tried both displayport and hdmi to different monitors from the back ports. Has anyone had any luck with external displays?

I have been able to get the HDMI port to work without any issue. Also tried a couple of different docks with mixed results.
On one HP dock, I could extend to one display and only mirror to the second (total of three displays counting the laptop). Did not spend much time troubleshooting yet before moving on to the next hub.
On a random amazon hub I was able to extend my display across all three screens without an issue.

1 Like

This is with Framework HDMI and/or DP expansion cards? And if so, tested on multiple expansion bays? If it’s a dock/adapter of some sort, that’s another thing altogether.

I was using a USB C to HDMI connector and a USB-C to Displayport cable, via a dock and directly connected to the laptop.

I then tried the Framework HDMI card, v1, and it seems to work. Going to keep digging.

Has anyone tried OpenSuse Tumbleweed on the AMD laptop?

1 Like

I’m putzing on fedora 39. So far the problems seem to be suspend not coming back. fwupdmgr and tools locks up with no apparent warning or error. If you immediately reboot, it hangs on fwupd service for 6 minutes. When resuming from suspend, the monitor doesn’t come back sometimes, other times the keyboard doesn’t come back. The whole X is your only choice on initial boot is annoying, though the workaround of logging out and back in gets you wayland works for me.

New thing after writing this, firefox youtube experience is bad. Tried with hardware decoding enabled/disabled. Just glitchy and lots of amdgpu errors in journal.

Do we have a list of bugs for Fedora that we can track/contribute to?

This is the “head” tracker bug, so new ones should probably be also added as a dependency to it:


I’m in batch 2 and plan on trying it. Probably with Gnome as the default, if that doesn’t work well I’ll try KDE.

exact problems i had with fwupd. impossible to use the command at all, yet the guides have no mention of this. had to install windows just to update the trackpad

Is it possible to distribute the firmware another way than fwupd? I cannot get the fwupd service to start on my system. It just hangs.

Not in today, however, I need to address some stuff before this becomes a huge thread. Only reason I’m touching this today is I rather not see this blow up over the weekend.

Outside of the fingerprint reader and the linked doc how to update it in the guide, firmware updates should be held off on.
Meaning at this time, I’m unaware of anything outside of drivers (Linux or Windows) being updated.

Monday I’ll look into fwupd on F39. If it can be duplicated, I’ll file the bug report personally.

Regarding suspend, on both of my AMD laptops, suspend resumes flawlessly. Mind you, this is only connected to ac power.

Which BIOS is installed (even though it should be what I have, I must ask) and what is attached when you’re resuming? This is fully updated (dnf) F39?

Thanks and I’ll be by Monday to go over this.


In Fedora fwupd was stuck in waiting and dmesg was showing some amdgup timeout errors.
I managed to run fwupd using another distro using X11 to avoid the amdgpu errors and it worked like a charm. After the update I moved back to fedora and the fingerprint reader worked.

1 Like

It does seem like fwupd hanging is related to the amdgpu errors.

Hoping my experience can provide useful data. On Arch, with sway:

  • The first time I start sway after booting, it crashes with:
  • Starting a Wayland session triggers the amdgpu error reliably for me. I have not used Fedora, but I suspect Fedora could be falling back to X11 after Wayland fails.
  • Regarding fwupd,
    • Running fwupdmgr before launching sway (and causing the amdgpu error) works.
    • Running fwupdmgr anytime after attempting to launch sway will hang.
  • I suspect that the two issues are related, which would explain why using X11 works for fwupd.

If anyone is having issues with fwupd while attempting to update the fingerprint reader, I suggest either trying X11 or booting into a console instead of Wayland.

Have yet to test suspend, but I think I will wait until after 3.03 to do so.


@Gabriel_Esposito what you have written up exactly matches my experience using sway, including the initial crash when starting sway.

In my testing suspend also crashes with the same amdgpu error output as sway. Hibernate works though.