Arch installation ISO not booting

I got my Framework, cloned my old hard drive to my new laptop, and unsurprisingly encountered some issues.

I decided to use the Arch installation ISO to troubleshoot these. I copied it onto a flash drive and made sure that it worked on my old laptop.

When I entered the boot device select screen on my Framework, my flash drive showed up as a boot option, but the entry didn’t work. Selecting it just caused the screen to clear briefly then redraw the boot entry selection screen.

Oddly, the Debian installation ISO boots just fine on both my old laptop and Framework.

Has anyone else had this issue? Any guidance? Because I’m not even getting any output from the kernel, I’m really not sure how to troubleshoot this.

I’m running firmware version 3.07. The Arch ISO is using kernel version 5.17.1

1 Like

Of course, as soon as I post this I figure out the answer: I needed to disable secure boot.


This! I had the same problem trying to boot from lan PXE.
Once I disabled secureboot, everything worked like a charm!