Arch on 250g expansion card | IO error drops root FS to read only

Hi guys!

I’ve been running my framework laptop since January and absolutely love it. I’m a longtime windows user just out of the fact that I’ve always used it, but recently wanted to try to daily drive Linux for a bit (powershell pissed me off one too many times, haha)

Being a CS student/hobby developer, I’ve had a good chunk of experience in and around Ubuntu and Debian terminals, but felt I’ve never really known them, or Linux in general, that deeply; Naturally, I chose Arch :D. I bought a 250gb expansion card to boot it from, got a copy of the install medium, and I’ve had a blast with it so far.

That said, I’ve been running into a pretty gross error. Every so often- either minutes after boot, hours later, or not at all for any particular boot- seemingly with no consistent trigger, my system will hit some sort of IO error, and my FS will drop into read only mode, forcing me to perform a force-restart by holding the power button.

I’ve been through various archlinux wiki & forum threads, all of which seem to suggest that there might be something wrong with my drive. I tried to use smartctl to analyze it, but the tool reports that it’s an “Unknown USB bridge”, and I haven’t found any—device flag that works for it. Other threads have mentioned issues with sata cables and the drive’s physical connection, but I I’m hesitant to think that I’m having an issue with the mainboard’s ports- I’ve used that port for various other expansion cards (USB A/C, micro SD, HDMI) with no problems since I received the laptop.

I went ahead and reinstalled Arch just for the hell of it, and ~60 seconds into my first reboot after spinning up KDE plasma, it died again.

I also just fsckd the drive from the install medium; It found some orphaned inodes and an incorrect block & inode count, but I have no idea whether those are grave errors that would be causing my issue. I’m also 67% of the way through a e2fsck -fccky test of my root fs, currently sitting at (0/0/0) errors.

That all said, has anyone else booting Arch, or other Linux distros, from an expansion card had any similar issues with the card? Or does anyone see any obvious troubleshooting routes I’m missing or info-sources I haven’t searched yet?

If it does end up being a bad drive, I’m well within warranty (less than a week old) and I’m sure FW support will be more than helpful, but I have a pretty solid hunch that I just don’t have the full picture yet.


1 Like

Related to



Thank you for the link! Not sure how I missed this thread, it looks very similar what I’m seeing.

Poking through old dmesg logs, I don’t see any USB-disconnect messages, but the collectively described behavior is almost exactly what I’m seeing. I setup a terminal to watch for USB related events with dmesg just for the hell of it, in case I manage to catch a crash.

This is equal parts relieving and frustrating. On one hand, I hadn’t hit the “what the hEll is happening here this makes no sense” with arch yet, and figured this was it- so yay for still not ‘officially’ being stumped by arch! On the other hand, what a hell of an issue to debug for everyone involved.

1 Like