[SOLVED] Arch Linux Display Port Expansion card not detected

I’m having an issue with my display port expansion card being recognized by the machine. I’m running Arch Linux on the 6.1.37 lts kernel however the problem is also present on the mainline 6.3.9 kernel as well. I’m running kde plasma 5.27.6 in wayland mode. The card was working yesterday by switching it to other ports and would be recognized to connect to my external monitor but today it won’t be recognized under lsusb unless I remove the display port cable I was using last night. I know the cable is fine. I’ve previously updated the card to the new firmware version for the DP expansion card using my windows 11 desktop machine. Should I attempt to boot into a live fedora 38 or ubuntu image to see if the problem persists or would I definitely be looking at a problem with the card itself?

1 Like

Our Linux friends @Matt_Hartley and @Loell_Framework are taking a well-deserved break, but I can tell you that is exactly what they would recommend.

If it doesn’t work on that, document it and they will be on it.

1 Like

I tried both ubuntu 22.04 LTS and fedora 38 live images. My assumption is that the card should have been picked up by both of those environments and should not disconnect from the system and it showed the same behavior in both systems even moving ports. I’ll put in a ticket with support and see what happens.

1 Like

I got my Framework and a DP card while on Vacation. When I get home tomorrow, I will see if I have an issue. I also use Arch and Plasma.

1 Like

Hi Nathan, I want to make sure I have this correct:

On multiple kernels on Arch and using Ubuntu 22.04 and Fedora 38, you finding the card is not showing up in lsusb, correct?

You also indicated that the only way it shows the expansion card again is to remove the display port cable. If you can confirm that it is failing when using the otherwise believed to be a good cable, I’d try two things:

  • Test another known to be good cable on the expansion card, see if it disappears again in lsusb.

  • Test the expansion card with another display or even same display/cable, connected to another laptop.

The rationale here is to determine if this is a bad cable (super common) or an issue with the expansion card itself.

@Matt_Hartley Yes that’s correct. However doing some testing today and the plot has thickened more. The card has now come back to working with the same cable. It seems to get itself into a broken state where it won’t be recognized by the system and only sometimes will come back in the same session. If it gets into the broken state, it won’t be recognized after reboot, or using any other distros. I’m currently working through support and I’ll try to see if I can use another laptop with the card to see if the issue persists.

Interesting, we’ll definitely want to keep an eye out on the logs when it happens again. Using dmesg and journalctl should give us some details.

One thing that I find helpful when it’s difficult to track stuff like this down is to keep a terminal open and let journalctl -f going in the background. When it happens, you will see it in real time and can then copy/paste the results. Useful when we don’t really know for sure what we’re grepping yet.

I will be sure to include a readout of dmesg and the journal log when it occurs again. Support is going to send me a new card but I’ll use the old one and see if I can get it to show itself. it’s currently in a broken state and I haven’t been able to get it to show back up.

1 Like

Understood, appreciate the update.

Jul 07 13:55:20 arch-framework kernel: usb 3-6: USB disconnect, device number 8
Jul 07 13:55:44 arch-framework kernel: usb 3-6: new full-speed USB device number 9 using xhci_hcd
Jul 07 13:55:44 arch-framework kernel: usb 3-6: New USB device found, idVendor=32ac, idProduct=0003, bcdDevice= 0.00
Jul 07 13:55:44 arch-framework kernel: usb 3-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jul 07 13:55:44 arch-framework kernel: usb 3-6: Product: DisplayPort Expansion Card
Jul 07 13:55:44 arch-framework kernel: usb 3-6: Manufacturer: Framework
Jul 07 13:55:44 arch-framework kernel: usb 3-6: SerialNumber: 11AD1D008CA83E0B20310B00
Jul 07 13:55:44 arch-framework kernel: hid-generic 0003:32AC:0003.0009: hiddev96,hidraw2: USB HID v1.11 Device [Framework DisplayPort Expansion Card] on usb-0000:00:14.0-6/inpu
Jul 07 13:55:44 arch-framework mtp-probe[7047]: checking bus 3, device 9: “/sys/devices/pci0000:00/0000:00:14.0/usb3/3-6”
Jul 07 13:55:44 arch-framework mtp-probe[7047]: bus: 3, device: 9 was not an MTP device
Jul 07 13:55:45 arch-framework mtp-probe[7071]: checking bus 3, device 9: “/sys/devices/pci0000:00/0000:00:14.0/usb3/3-6”
Jul 07 13:55:45 arch-framework mtp-probe[7071]: bus: 3, device: 9 was not an MTP device

Here’s the output from journalctl when I plug in and unplug the cable. The first message is when I plug the cable in. I got a couple other display port cables and tested them on my other system and have verified that they work. The following messages after the first are when i disconnect the cable

I met this problem today. TL;DR:

  • DP expansion card stopped working.
  • I booted into Windows, it worked again.
  • booted back into Ubuntu 22.04, and it works.

I am not completely sure as to how it happened, but the general steps are here:

  1. Laptop connected to second display, both working and displaying.
  2. Laptop auto-suspended
  3. Laptop woken from suspend mode
  4. Laptop seems connected with second monitor (mouse can move over and such), but second monitor is showing black screen.
  5. DP cable disconnected and reconnected
  6. Laptop no longer recognizes the connected DP cable. Second monitor no longer reconnect with any attempt at solving this issue (re-plug cable, re-plug expansion card, reboot)

The last thing I tried is to reboot into Windows 10 and then back, and that seems to fix the issue. I am sorry I can’t provide much diagnostic information as I just wanted to solve the issue quickly, but I thought the solution might help people like me who just want it temporarily fixed and then maybe an update will prevent it from happening again.

For the developers, I hope this helps at least a little bit. It seems to me what @Nathan_Ross mentioned with the DP card falling into a broken state makes sense to me, as it wasn’t fixed by re-plugging the DP cable, re-plugging the expansion card, or rebooting, but clearly all of these devices are working (cable, expansion card, laptop, second monitor) as booting into Windows solved the issue. I’m not very well versed in the linux kernel or the expansion card firmware, but maybe there is a difference between how Windows scans usb devices vs Ubuntu, and the way Windows picks up the DP expansion card fixes it?

Let’s have you open a support ticket.

I had opened a ticket earlier and got a replacement gen 1 card. I’m not sure which firmware version this card has, but it worked out of the box so that would be the resolution at least to my issue with the card. For my part this thread can be marked as solved.