AX210/AX211/AX411 WiFi died suddenly on Windows 11

Posting this here in case somebody runs into the same issue I had - along with how I resolved it.

For context, I typically run on Ubuntu, however in the last week or so, I have installed Windows 11 natively onto my Framework laptop (i7-1165G7 CPU). Windows 11 21H2 22000.739.

I had no real issues until this evening, when, after rebooting my laptop as part of normal use, WiFi stopped working.

Symptoms:

  • WiFi disappeared entirely. Nothing in the taskbar in relation to it, and nothing in system settings that could be toggled on.
  • Opening device manager and looking for the WiFi adapter, I found it with an exclamation mark and I was getting an error along the lines of Windows has stopped this device because it has reported problems. (Code 43) or that the device failed to start.

I also booted up an Ubuntu 22.04 LTS Live USB image, and coincidentally or otherwise, WiFi wasn’t working either. Worth noting that WiFi used to work for me on Ubuntu 22.04 until a week ago, but that was an actual install not a live USB, so some drivers might differ there.

On Ubuntu, looking at dmesg / syslog, I had Failed to start RT ucode: -110 error messages.

Finally, my Windows 11 installation was set up with Windows 11 Framework Laptop Driver Bundle 12_15_21 obtained from here: https://knowledgebase.frame.work/en_us/framework-laptop-bios-releases-S1dMQt6F

Reinstalling the above didn’t work.


Solution time

Windows

Official Framework driver bundle (mentioned above) provides driver version 22.80.0.9G.

I downloaded the latest Intel driver for the AX210/AX211/AX411 card from here: https://www.intel.co.uk/content/www/uk/en/download/19351/windows-10-and-windows-11-wi-fi-drivers-for-intel-wireless-adapters.html which upgraded me to driver version 22.140.0.3.

Reboot.

The laptop forgot my saved networks for some reason, but at least it now started working again.

Ubuntu 22.04 Live USB

# as root

cd /lib/firmware

mv iwlwifi-ty-a0-gf-a0-71.ucode /root/.
mv iwlwifi-ty-a0-gf-a0-68.ucode /root/.
mv iwlwifi-ty-a0-gf-a0-67.ucode /root/.
mv iwlwifi-ty-a0-gf-a0-66.ucode /root/.

modprobe -r iwlwifi
modprobe iwlwifi

The above effectively downgraded the firmware to v63 which is the next latest available version that I retained at that point in time after removing the above.

Hope the above helps, and hope it’s a long term solution and issue doesn’t reappear.

Unfortunately, I still don’t know what caused it in the first place. I suspect it’s some very recent Windows update or module that is not compatible with the old WiFi driver :crossed_fingers: however this is just a theory without any real basis.

1 Like

Sometimes my Killer 1535a/ac reports this after having the computer on for too long (continuous for 2 weeks or so). Disabling (and then re-enabling) the device will solve the problem.
I suspect it’s some very minor problem with the driver/wifi chiplet. It might also have to do with some bad WiFi access points (e.g. when the WiFi access point suddenly disappear during the middle of a transmission, etc)

Since a single (known) error code is still considered as (reported problems) so Windows will disable it, and won’t allow you to re-enable it until you have cleared the error flag (which is to override it by disabling the device)

I don’t know how to deal with it on the Linux side. Perhaps something similar.

@Xavier_Jiang I had tried disabling the device, removing it, reinstalling the Framework drivers, and nothing worked. Same error after re-enabling. The upgrade was the only thing that resolved it.

2 Likes

To me this sounds like it is completely Windows 11’s fault. Thank you very much for detailing how you fixed it!

1 Like

Technically it’s not framework’s fault as they are provided with the drivers (from toe company) and modules. They only built the motherboard that connects things together. So if it works, everything is great. If it’s a bad driver/firmware it’s the wireless company’s problem (in this case intel) or the OS’s fault (microsoft/linux community in those cases)

Try those.
I’m curious whether if there is a way/need for you to update the firmware on those wireless cars too. Or if the driver will do that.

210 and 211/411 seem to differ in interface. Not sure if that’s why (a faulty driver, for example)

1 Like

Just to clarify, I have resolved my problem, as per my original post.

This post was done in case somebody else ran into a similar issue. Thanks for the feedback though :slight_smile:

2 Likes

oh right I saw. you have listed the same website for the Intel Windows drivers.

Intel does not seem to be providing drivers for Linux.

How does open-source driver on proprietary hardware even work? Must be a incredibly avid group of developer/hackers that manage to piece together all the different commands.