Intel AX210 wifi adapter suddenly no longer working on Ubuntu 22.04

Hey everyone, I’ve been enjoying my Framework Laptop for the past few months now, then out of nowhere the wifi adapter decided to stop existing when using Ubuntu 22.04, meaning I had no option to connect to wifi. I’m running the 11th gen Framework laptop, dual booting Windows 10 and Ubuntu 22.04. I’m kinda new to linux and I don’t want to give up and switch to windows unless I really have to. Some help would be appreciated! Could the Windows 10 partition screwed things up?

Just some things I tried:
I checked my pci devices using “lspci” in the terminal and confirmed that the Intel Network Controller AX210 is there and knows what its name is, etc. So, correct me if I’m wrong, but the OS seems to detect the wifi adapter.
I also tried re-installing the current wifi adapter firmware from Proceeded to download the firmware version 59 for Intel AX210.
After that I extracted the files and copied the .ucode file of the firmware into my lib/firmware folder.
I’ve also tried some of the package repair utilities in the ubuntu recovery mode to no success. Any thoughts?

Hello there!

One thing that comes to mind is, have you opened up the laptop to see if the NIC is seated comfortably.

Another thing that comes to mind is, have you opened the settings and checked if the WiFi toggles are on?

I, too, am a user of Ubuntu on my Framework, while I have not yet encountered the same issue as you, if I do I’ll keep you posted, especially if I also manage to fix it.

You can also try submitting this same issue to the Ubuntu forums and maybe one of the boffins over there can provide a higher quality answer :slight_smile:

Best Regards,

1 Like

@Varg Hey there!
Forgive me for not responding. What I found caused the issue was my sudo apt update somehow broke a package associated with the iwlwifi firmware. I basically had to remove it and re-run the update software over a line in internet and that fixed it! I can’t remember exactly which package was broken at this time, but that was what I found. Thanks anyway!

1 Like