BIOS 3.07, EGPU, Win10/11, Linux

Hi everyone,

After updating my BIOS from 3.02 to 3.07, I now have issues with my Razer Core X Chroma + RX590 EGPU.

Let me first say that I was running 3.02 since I received this laptop back around September '21. Things ran well with this set up on Windows 10. I was able to hot plug/unplug the EGPU, each USB port functioned properly, and ethernet worked flawlesssly. The only caveat is a I needed to run a batch script to reset the Intel GPU drivers to reduce the stuttering I would get.

I decided to “upgrade” to Windows 11 (if you can call it that). Performance there was worse, but I chalked it up to the new OS. In particular, I’d occasionally get issues when having the EGPU plugged in on boot. For instance, it would get stuck in a boot loop or just not use the EGPU at all. If I booted the laptop then hotplugged, things would usually work. But, sometimes I’d have to restart my laptop after a few hotplug/unplugs. I take my laptop to school and bring it back home and was really hoping to just have this as a station at home that would let me use my dual 4k set up and do some gaming if I’d like. All of this was manageable, but really not ideal. This was all still on BIOS 3.02.

Next, I decided to go with PopOS 21.10 since I have been wanting to go back to using some distro of Linux again for a while. I was attempting to get hot plug/unplug working on Linux in both x11 and Wayland with no real ability to do so. There are scripts that allowed me to at least have this work upon reboot, but that really kills workflow since I have to restart everything I was working on any time I want to plug/unplug. Naturally, I tried flashing BIOS 3.07 to see if this would help. It did not. I tried the latest kernels which did not help either.

So I tossed in my old NVME drive with Windows 11 on it and I found that the EGPU use was far worse. Ethernet hardly works. It really only works if I restart the device with the EGPU plugged in, and even that seems to be hit or miss. I am also unable to detect sound devices connected to my monitors now except on the occasional boot with the EGPU plugged in.

So, I went to do a fresh install of Windows 10 to see if I could get back to the performance I was expecting. In short, I cannot. Functionality is pretty miserable now and I’m suspecting that it is BIOS 3.07 causing this issue.

I am mostly just trying to get these issues to be noticed. I’m happy to give anything you all can suggest as a try. I have adjusted PCI-E power settings to “off”, I have turned off quick boot, and I have the latest Framework drivers and Windows updates installed. Ideas? Comments?

1 Like

Edit: I should note that now on the latest BIOS 3.07, I can’t really hotplug/unplug at all. No matter how I start up my laptop (either with TB cable in or not), I can run with the EGPU after plugging in. But, after one uplug, I can’t plug it in again since I will get stuck in a loop of AMD xConnect opening and closing itself.

Not to discredit you, but I’m also running an AMD eGPU setup on BIOS 3.07. Hotplugging has always been iffy on Linux. I am able to get it to work if I restart my GDM session. Though, hotplugging still works for me on Windows 10.

What you are experiencing seems very odd. I’m curious if the CPU on your laptop is running at full speed. I had a problem with my Framework when I was in Windows 10 where the CPU was staying around 1000mhz. As a result, everything was extremely choppy.

I’m also experiencing something iffy with my AMD gpu when gaming with fluttering FPS. I originally thought this was due to the age of my card, but after reading your POST, I’m curious if its not the case.

I’ll try swapping out my current card with another one to see if I’m still experiencing the same issues.

On the Windows side… I haven’t looked at the CPU speed when I first plug in the EGPU. But seriously just reloading the Intel graphics drivers completely fixes the FPS problems. It’s as if the internal GPU is still trying to process graphics until I reset them and let the AMD EGPU take over. This particular problem isn’t really a big deal, but it may point to the bigger issues. Really my problem is rooted in the BIOS change 3.02 → 3.07 completely changing how hotplugging works. I am happy to provide more details if anyone else is interested. I would also be happy to try beta BIOS versions that attempt to fix this problem. It’s quite frustrating. It’s basically meant I have to restart my computer any time I want to plug into my EGPU. This was NOT that case on BIOS 3.02. Not at all.

As for Linux, I’m not really that surprised. It seems like this is just not really supported at the kernel level. I’m not worried about this at the moment. I just need one OS to work properly.

I believe this would work for x11/GNOME since you can just restart the graphics service. So this is a decent workaround that at least gets you past a complete restart. Though you would still have to open everything graphical up again, which is definitely a pain.

I am not currently dual booting so I don’t have a convenient way to try this right now. I can pull my Linux NVME drive from my other desktop once I get code I have running on there done.