BIOS can't see M.2 SSD

I have a Toshiba THNSN5256GPU7 M.2 NVMe which fits, mechanically at least.

But the SSD is not recognized by the BIOS/UEFI also not by the Windows 11 installation stick, created with the MS Media Creation Tool.

Are there any other compatibility issues known?

SATA drives aren’t supported, but would mechanically fit. Does the drive have 2 notches in its row of contacts?

No there is only one notch. Labeling and specs i could find online say it’s an “NVMe”
It worked well just minutes before in my old laptop, so i don’t think there is any defect.

Due to the fact this is an older generation of SSD I’m thinking about to buy a new one. But what if the new one also doesn’t work?

Weird. If its NVMe, it should definitely work- SATA definitely arent supported. Are you able to maybe format it first and then see if the installer will recognize it?

Formating on my old laptop (XPS13) might be an option. But if this really helps?
From my old-school knowledge perspective, the BIOS doesn’t care about the formating of a storage. But maybe this changed within the last years , the introduction of UEFI and the mysterious stuff laptop manufacturers as Dell do with it their devices :grin:

In this case it does - it will have problems with drives formatted MBR and can only use (can only even see) drives formatted GPT. This is new, this is one of the newer laptops that supports GPT booting only.

Note: this is the low-level format, the partition table, rather than the filesystem format like NTFS, ext4, etc.

Before abandoning it and moving on, you may want to see what partition table it’s using and change it to GPT if necessary using GParted Live. GParted -- Live CD/USB/PXE/HD

Thanks, I thought already it must be something like this.
Diskpart clean/delete and a full “Data Wipe” from the Dell UEFI didn’t help.

I’m running GParted now. But also there: No SSD recognized :disappointed_relieved:

I’m really wondering if the M.2 slot even works. As i could read there was some issues for the first badges of framwork laptops, but hard to believe this quality problem is still not under control

I’ve been on thsi forum a long time and never heard a report of the NVMe slot not working, usually issues have been firmware on the SSD if anything. Suppose its possible though. If there a nearby computer shop you could try a cheap drive from there and return it quickly?

I don’t think this kind of computer shops exist anymore here. The ones i know are just sellers. Once you open the box there is no guarantee for a free return.

So maybe it’s the best solution to just buy a new WD Black SN850, which is ultrafast and 100% tested and supported by framework.
Using the old one was more like a “why not? It’s finally possible with framework” and “sustainability” thought. Just little sad it didn’t work as expected

I realized I gave you some bad advice.

If your BIOS can’t see it, no OS can see it either. GParted Live will not see it.

So unless you have another computer, there’s nothing more you can do.

Rather than waste it, why not turn it into a very fast, very large USB drive? This one works fine for me:

Thanks for clarifying! I was already wondering why i didn’t know about such magic BIOS invisible low-level formatted storage :grin: But anyway it was worth a try.

Waiting an answer from framework Support now. Then i will buy a new one or probably get and old from a friend.

Maybe i will just put the the current one back into the XPS13, which still works, with only one loose USB-C but no USB-A or Thunderbolt functionality

It’s too bad you can’t use GParted Live with that, because I can’t see what else the problem could be.

The Framework laptop will only work with drives with a GPT partition table, and this is new - older computers can work with either. If it was formatted MBR in an older computer, the Framework laptop won’t even see it.

I got my DIY laptop today and trying to install on a well working Toshiba M.2 NVMe SSD taken from my old XPS13 , Model is THNSN5256GPU7

The SSD fits perfectly, snaps-in, remains in 20° angle, then screwed down to the board. Mechanically everything looks fine!

But: UEFI or Windows installation doesn’t recognize any storage (except of the USB stick for the OS installation, of course)

Is there any other possible incompatibility?

Thanks for help

If you boot a live Linux distro with a new enough kernel from a USB drive (ideally using Ventoy because Ventoy is awesome), is it even able to see that the NVMe SSD exists?

It’s important to first figure out if the hardware is even detected before deciding what to do with the software which may or may not work.

If you have no experience with Linux at all, then I can recommend Linux Mint as a good “baby’s first Linux” for people familiar with pre-Win8 Windows… not that the use-case in this example is to actually daily-drive it as we just need it for testing the hardware; just note that, until Mint 21 releases, you will specifically need to use the “Edge” version of Mint 20.3 for it to work on the Framework laptop.

And on a somewhat related subject to this thread, I recently found out that one can use “Disk2vhd” to convert an existing Windows partition into a vhd file for use in virtual machines (just know that VirtualBox specifically requires you to use vhd rather than the “vhdx” format that Disk2vhd likes to defaults to). Also, being a portable program, it may theoretically even work when ran from Hiren’s BootCD PE.

I was running GParted Live on USB in the newest stable version. I think this is similar to the way you describe.
But also GParted is not able to recognize my SSD.

I just checked and GParted Live comes with kernel 5.10 which may or may not be a slight bit old for the Framework Laptop…

@Michael_Meier I’ve moved your posts regarding your issue to the new “Community Support” category. The Support people will be monitoring this category.

Please contact support if you haven’t already.

By the way, the kernel GParted Live is running shouldn’t matter for just seeing the drive. It should see the drive and should be able to work with it - perhaps nicities like the WiFi and the fingerprint reader won’t work, but the drive system should. Since your BIOS can’t see the drive, no OS can either. I still think that the drive’s partition table might be MBR and if you can change it to GPT on your other machine using GParted Live it should work.

Unfortunately my old laptops USB ports are all broken or unsteady. The Live USB sticks couldn’t be booted

But i think when i was cleaning my SSD on the old laptop, the Windows diskpart command tool did show GPT enabled.

GParted so as Linux Mint booted from USB couldn’t see any SSD on the framework. So i don’t think there is a way to get it work.

The support team didn’t reply yet. I’m going to order a new WD Black now and really hope this will work

1 Like

Got my brand new WD Black 1TB. And it works like a charm.
Full Windows 11 installation from boot-to-desktop inside of incredible 6 minutes!!! Unbelievable :love_you_gesture:

1 Like