Ssd failure (WD_BLACK™ SN850 NVMe™)


I received my batch 3 diy edition last week. Install was smooth (Arch Linux) and I had everything setup how I like it. I left my laptop to charge on Friday night and did not touch it until this morning (Sunday). When I did, I found that kde said that the login manager had failed. I then attempted to switch to a tty, but that was filled with error messages related to my drive. When I attempted to reboot the bios said there was no bootable media detected. I then plugged in a live arch usb and “fdisk -l” did not show my ssd. I opened up the laptop and visually inspected the ssd. I removed it and plugged it back in to no avail. It is still not seen by my the bios or the arch Linux live usb. The only thing I can conclude is that the ssd just failed one week into use? Does anyone have any suggestions for further debugging?

(Edit: I wonder if it is related to This

@Garrett_Finucane The blue stuff is normal, it’s a there to make sure the screw doesn’t come loose from vibration. It’s commonly known as “locktite”.

From what I am reading, it looks like yo could have a bad NVMe, only way to find this out though is to test the NVMe in a different device such as an external or a computer with a M.2 port. Amazon has some here is one that supports NVMe/SATA so it’s useful if you want to expand your storage.

If you got this drive through Framework, I highly suggest you contact them and let them know, since you posted the link referencing someone else having a similar issue with the SN850 they might want to be aware of it and maybe even contact their WD rep so inquiry about the issue.

@digitalknk Thank you for your help! I just contacted framework support.

@RandomUser thank you for the info! Unfortunately I don’t have a windows computer so I won’t be able to update the firmware.

Make a windows install USB, no need to pay for activation, you aren’t going to be using it long and windows won’t restrict you from updating firmware

@GhostLegion I made a windows install USB per your advice. Unfortunately, it fails with a Machine Check Exception which suggests to me from googling around (I have never been a windows user) that Windows is also unable to recognize my drive.

After getting in touch with Framework support I was able to confirm my drive is recognized by lspci, but not fdisk. The arch install ISO dmesg has errors:

nvme0: Device not ready; aborting initialisation CSTS=0x0
nvme0: Removing after probe failure status: -19

The drive is not found if I run

nvme list

Any developments on this? I have the 750 and I cannot install ubuntu because it is trying to install to the flash drive instead of the hard drive. Because the ssd is not being detected.

1 Like

@Gabriel_Pumple I am having the SSD replaced after contacting Framework support.


@Garrett_Finucane what steps did you take to make sure the SSD failed instead of something else? I’m waiting to hear back from framework support, and want to make sure I do everything I can.

@Gabriel_Pumple I tried multiple different linux live USB’s and found the same dmesg errors (above). Seems like this can be a problem with some 850s.

My SSD was bad. I got a new one and everything worked. I expect framework will reimburse me for the bad one.