Update BIOS Failed

Any ideas for why I can’t update my BIOS to the latest version?

-The USB is vfat32 with only the contents of the BIOS update zip folder.
-Secure boot is disabled in BIOS
-Power is plugged in
-Battery is above 20%

(EDIT: fixed upside-down picture)

Could you try for windows using something like Windows To Go?

Blockquote
Could you try for windows using something like Windows To Go?

Not sure what Windows To Go has to do with me updating my BIOS, perhaps you know something I don’t? Can Windows To Go help with this process?

(I don’t use Windows)

Just upgraded to BIOS 3.07 from 3.06 with no problems.

Perhaps you are encountering this as your current BIOS seems to be 3.02 (from the screen shot).

You could try to upgrade to 3.06 first (or an earlier version) and if that works then try the 3.07 upgrade.

2 Likes

@Stephen_Oberski Good idea, thanks! I’ll give it a try when I get the time and report back.

Attempted to update it to v3.06 and got this message:
“The BIOS image to be updated is invalid for Secure Flash or onboard BIOS does not support Secure Flash.”

I then tried the v3.07 exe via windows (as opposed to the LVFS firmware I already tried in my OP)

I appear to have the same problem a few people on the main BIOS update thread:

I checked my EFI parition. I partitioned it to 100MiB leaving 32 MiB for the BIOS update to use (which apparently is enough according to SodaStream: BIOS 3.07 + Windows 10 and (11 Alpha) driver bundle - #47 by SodaStream)

Since my NVMe simply has a fresh install of Arch, I will wipe it and install windows just to complete this BIOS update I need to use the motherboard as an SBC. Sucks.

I can’t be bothered to troubleshoot this further. Will report back if a windows install allows me to install the BIOS update.

UPDATE: Installing windows on my nvme ssd allowed me to flash the new BIOS firmware. Something about the firmware installer did not like my EFI partition that I had on my arch install.

Hey @bobo - Just out of curiosity, when you were running into this issue do you recall if you had either the 250MB or 1TB Expansion Cards currently installed in the system?

To anyone who just bought a new Framework laptop with 12th Gen Intel. If you get the same error just be aware you have to use the bios specifically made for the new Mainboard. Which is listed here(It isn’t out as of writing this comment but I assume it will be updated in the near future)

Just writing this as someone who tried updating the bios and was confused why it wasn’t updating. Best of luck to anyone else who was bashing their head in from the outdated documentation and forum posts

I did this update with Windows and I get the error as described here:

I’m stuck. EFI partition is 512MB and BIOS version on 3.07.

Help :frowning:

I had exactly the same issue when updating from 3.10 to 3.17, and I was not able to update in both Linux and Windows. I ended up using the UEFI update tool and cleaned up my EFI partition, and it finally worked for me.

On Windows, I got this confusing message.

On Linux, I used LVFS, but the update failed, too.

With the UEFI update tool, I got the “Update BIOS failed” message as well. It turned out that I needed to clean up my EFI boot drive (which is 100MB). The Linux LVFS update actually copies the BIOS to the EFI partition, which took a lot of space. After deleting it, updating in Windows and Linux still fails, but the UEFI update tool works for me.

If your EFI partition is really small and you cannot find sufficient space, one other solution that might work is to unmap/unmount EFI partition when you are in the EFI shell, so the UEFI updater may use the EFI partition on the flash drive instead. It might work, but I did not try.