Bluetooth mouse lag

I am having bluetooth mouse lag issues. When ever I stop using the mouse for more that about 1.5-2 seconds, and then go to move it again, the mouse doesn’t move until about 1.5 seconds later and then it jumps to where it would have been otherwise. Quite annoying when you are scrolling through a document or web page. I’ve tried the usual bluetooth mouse lag fixes but no change. I upgraded to bios 3.07 and the Dec 21 driver pack - also no change. I’m up to date on all Microsoft Windows patches. There are no power management settings associated with this mouse. My mouse is the most basic microsoft bluetooth mouse (bought 3 weeks ago). I also own a logitech M510 mouse with a dongle that works perfectly (I just didn’t want to give up a port for the dongle if I didn’t have to - so my preference is to use a bluetooth mouse). I’m about to replace the mouse but thought maybe someone else had seen a similar issue?

Existing discussion here:

TLDR if you’re on Windows 21H2 with all drivers updated, try disabling USB Selective Suspend. After this there is still a tiny bit of lag but it’s usable IMO.

1 Like

Where is USB selective suspend? I have looked under the advanced power options - where it usually seems to be, but I can’t find it there. Is there another setting required in order to see this?

1 Like

Can confirm… disabling USB selective Suspend is how I decreased the lag on my MS Bluetooth mouse after I stopped using it for a bit… it’s now muscle memory when I go to use it again that there is a brief half second where it “wakes up”… I don’t even notice anymore… until you mentioned it again of course. I only use a BT mouse when traveling though… fully wired mouse and keyboard etc when docked at home.

1 Like

feesh - I found that step1 didn’t work either. Hopefully it didn’t do something that will come back to haunt me in the future, but step 2 did work (although the “attributes” parameter already existed so I changed its default value from 0 to 2.

I then disabled USB Suspend for both battery and plugged in modes. I believe this may have worked. It seems much better (possibly a tiny lag - but nothing like before where moving the mouse 5cm in one direction caused the pointer to fly to the opposite side of the screen a second later!

Thanks for the suggestion!

Additional Win11 setting to try-
Just got the Framework and a Logitech MX Anywhere 3 mouse for it (using Bluetooth option). Very annoying lag after stopping movement for just a few seconds. I was almost ready to return the mouse until I decided maybe it’s Windows related. Attempted the above but couldn’t find “USB selective suspend” in Win 11. Tried several other “fixes” found online without anything working, or not finding the settings due to Win11 changes, until I ran across the following. For me it stopped all lag immediately!

Device manager → Intel Wireless Bluetooth → uncheck “allow the computer to turn off this device to save power”.

6 Likes

Works for me! I was reading that I needed to add registry keys etc to fix this but this works

2 Likes

I can confirm this works. I was also having this erratic behavior with a Logitech MX Ergo via Bluetooth. Disabling this setting resolves this issue.

Works on Framework DIY Batch 6 on Windows 11.

Thank you!

2 Likes

I have a mx master 3 and it would go to sleep every 10 seconds. This fix helped me. Haven’t had an impact on battery yet. Apparently it is a intel Bluetooth driver issue from what I have found.

I used the solution from Reddit on a Windows 11 install, worked perfectly.

Finally found this post after having this very issue for a few months and struggling to find a solution which worked. Followed the suggestion from @mjnz and this solved the problem immeditately! Thanks so much!!

2 Likes