Booting from USB, only grub command line, no menu

I am having an issue booting off USB, seems to be only on the framework computer. I booted from and installed Pop OS on the framework with no issues at all. Now, when I put a bootable USB and try to boot off it, all I see is a grub command line, and no user-friendly normal USB boot menu to select from. (Use live mode, install, etc.) Not only that, but the grub seems to lack many commands that allow me to manually load the kernel. (No linux command, no kernel command, no chainloader etc.) How do I get the framework to get bootable USB menu’s to appear again(?), please help!
Some things:

  1. Secure boot is off, and I have booted and installed an OS previously on this framework. (it had a boot menu)
  2. The bootable USB works on other computers, a Mac and PC. The boot menu appears on them.
  3. The grub console lacks any commands to load the kernel. I can see the partitions and browse through them, and I can set the root, but the grub has no commands that can load the kernel.
  4. I have tried multiple different linux distros, all USB bootable (with menu) on other computers, yet always grub line on this framework now.

Thanks y’all, and happy to be a part of this great community! :slight_smile:

1 Like

That sounds like it’s going into grub rescue mode, which usually happens if something goes wrong (unable to find the drive, etc) during startup.

Does it happen to all USB or just that one?

I’ve personally had really good luck using Ventoy to load various Live distros (Ubuntu, Arch, etc) on the Framework.

1 Like

Great advice! So I have tried multiple different USB sticks, and I was able to get Ventoy to boot… I am able to see the ventoy menu on startup when booting off the disks. Unfortunately, when I select a linux distro .iso to boot, it goes straight back to a flat grub prompt. These USB sticks work on other computers btw.

I have tried:

  1. With Ventoy I did GPT as well as default MBR partitioning.
  2. I even tried one USB stick with the secure boot option in Ventoy enabled, and switched secure boot back on and tried it that way as well. Ventoy menu worked there and I added some records to the trusted list, yet no matter what once the .iso’s start to load it goes to grub.
  3. I have tried multiple distros, all options in ventoy, secure boot on and off, I don’t know why the OS distros are not loading. I have tried Etcher, popsicle, Ventoy. Help, what could this be!?
1 Like

For myself I am using it with EFI and secure boot disabled.

The fact that it is happening on multiple OSes is kind of odd.

Since you were able to get the Ventoy menu to show, it’s unlikely that it’s trying to boot the NVME.

I guess there could be a mismatch between EFI/BIOS between Ventoy and the ISO you are trying to load?

When the grub menu comes up, what happens if you try typing exit?

Typing “exit” returns, “Can’t find command exit”. This isn’t like any grub I have seen before, it doesn’t have total functionality. When I pushed tab to see all possible commands, it seems to be lacking a few. I attached a screenshot of what commands it does have. All distos boot to this limited grub menu, with the only difference being the title. (where version and distro name is)

  1. Secure boot is disabled. I have made bootable USB’s with Ventoy, etcher, and/or dd command line. The bootable USB’s all work on other computers. I have tried multiple distros.

  2. For some reason the Ventoy Menu does work, and I can see the .iso’s placed on it. When selecting an .iso to boot though, the limited grub menu appears.

  3. On bootable drives without Ventoy, when I select the USB in the BIOS boot menu (F12) it immediately goes to the strange grub menu.

This is very strange, as I believe the flaw lies somewhere on the Framework BIOS, not on the boot medium or the disto .iso files. I have tried Ubuntu, Mint, and Parrot so far, but I think the problem has nothing to do with the type of distro. All the bootable USB drives have worked on other computers, regardless of how they were created.

I don’t know where this limited and strange grub prompt “is”. It doesn’t have the commands needed to load the kernal manually.

In desperation I have even opened and modified the distro .iso’s to include stuff from the Ventoy EFI/boot folders (since Ventoy boots), but that doesn’t work either haha. Perhaps a BIOS firware update will fix this? I suppose I could use some Virtual Machines until its fixes, though I do need to run some OS’s natively on the hardware. I have no idea where the problem could possibly be coming from!

Thanks so much for your help malachid.

1 Like

That screenshot is very helpful. It’s clear from the first line of text that it was the parrot version of grub there.

ls is listed as an available command. What drives are found when you use that?

Let me reboot into the BIOS and see what my settings look like.

1 Like

Checking my BIOS, I have:

  • Secure boot disabled
  • TPM no operation
  • USB boot enabled
  • Timeout 10 seconds
  • Device priority last
  • Automatic failover enabled
  • EFI boot order only shows one device
  • Quick boot enabled
  • Quiet boot enabled

While reviewing the list, one thing caught my attention. If you had automatic failover enabled and had some grub config on your NVME – maybe it’s failing over to the NVME?


Adding support for the theory the device isn’t found and it’s failing to the NVME.
I have Linux Mint on an expansion card fully self contained with its own bootloader, however I was unaware at first that the 20.2 installer will install the bootloader on the first drive it sees (my NVME) while ignoring your choice of drive, so if I removed my expansion card and tried to reboot, the GRUB in the NVME boot partition would fail to find its storage device and go into rescue mode.

It was the exact same minimal rescue prompt as you’re seeing, albeit with an Ubuntu label.

Thanks for the replies. Be_far, when I used Ventoy on a USB drive it would load into the bootloader menu, but fail to that minimal prompt once I selected an OS. It’s detecting the device to boot off of, just when the OS (many distros tried) tries to load is when it fails. The bootable USB stick works on other systems (Mac and Windows)

I’m somewhat at a loss at how to proceed, since I am apprehensive that this is something from the Bios. Both of you have given me confidence that it is most likely some sort of Configuration on the NVME. I will try to format the drive and see if that clears up the problem. Thanks so much!