Both CTRL Keys do not work

Hi folks - using the blank RGB keyboard and all keys seem to work except for both CTRL keys. I wonder if they are somehow disconnected per
Framework Laptop Key Matrix :: HowettNET assuming it’s still relevant?

1 Like

That page is for the FWL13. It has a different keyboard matrix and is handled by the EC (Embedded Controller).

You have a FWL16, correct? The 16 uses qmk open source firmware. You configure it with Check what the keys say there. And have you made any changes?

Thanks @MJ1 thats cool.

The tool says they are set properly to lctrl and rctrl- i also tried wiping and resetting them to no avail.

Other thing I just noticed is that they do not send pulses withe the reactive keyboard LED effects but seems like all other keys do.

Adding: nothing output from qmk console on depress

Are you on Windows, Linux? And do you have the blank iso or ansi keyboard?
Couple things you can try, clearing persistent memory and reflashing the firmware.

But other keypresses do show up? I don’t recall if console is enabled by default on the keyboards.

Looks like you’re out of ctrl! :smile: Sorry I couldn’t pass up that joke. My suggestion is maybe check the contacts for the keyboard. Also, just re-seating the keyboard might help.

1 Like
  • On Linux
  • blank ANSI version
  • no prior changes - just found out about these tools from you :slight_smile:
  • seems like all other keys show up in qmk console yes

I’m taking a look at how I can clear data or reflash- doesn’t seem to be built into the web tool hmmmmm

:laughing: :laughing: get out!

For real though I tried re-seating a few times - even tried re-seating some of the cables on the back of the board :frowning:

That doesn’t bode well. What output are you getting for others keys that do work?

Unfortunately, there doesn’t seem to be an easy way to clear EEPROM persistent memory from the GUI. Framework created a qmk hid tool that does offer clearing memory, but there are only precompiled releases for windows. For Linux you’d have to build it, though it’s straightforward if you’re familiar with git and compiling.

Reflashing is easier, but since you’re getting nothing from console, and you’ve never changed anything, you might want to just contract support. I can give the reflashing steps if you want.

Just to update here in case anyone comes across this - only way I managed to solve it was to replace the keyboard.