Broken delete key - like literally stopped working

The delete key on my laptop stopped working for no clear reason. All the other keys are fine, it’s just the delete key that doesn’t work.

When it first stopped working, I could bend the case a bit to get it to restart; now that doesn’t work at all.

Does anyone have any suggestions or should I just by a new input cover or something?

1 Like

Hi, welcome!

Couple of things:

If you haven’t already perhaps it would be good to contact support and see if they can help you.

Without knowing the usage of the keyboard and anything that might have happen to it, it is hard to offer much more. I would guess that moisture somehow got to the delete key either from a spill or high humidity, etc.

Other wise it is a warranty or repair thing.

Bummer that the key is acting up though and I hope there is a quick resolution for you.

1 Like

same thing happened to me! mine doesnt seem to be a hardware problem?

I have also had the same issue sporadically for months, although it’s nearly constant now. Every other key works fine. (And delete does work with an external keyboard, just not on the laptop itself.) Super annoying.

Same here. I noticed it when I realized ctrl+alt+del doesn’t work on the Framework keyboard, although it does work on external keyboard. The insert/del key doesn’t seem to work at all. I’ll contact support.

Interesting, same here! Just does not respond to being pressed anymore. External keyboards are fine. I will also contact support then.

@devnull let us know if you learn anything interesting!

I’ve had the same issue, for about the same timeframe. all of my keys work fine except the delete key - I thought maybe my kids messed with filter keys or something, but no, that’s not it. I did do a bottom cover replacement about a month ago, but I don’t think that has anything to do with it.

1 Like

I too have the same problem, except that for me it’s the right Ctrl key.

I make this posting to try to indicate that the problem is not rare.

The cause appears to be a tiny bit of dust or the like, even though i have taken great care to avoid that, and to remove that.

The non-working key was used constantly by me (in tandem with an external keypad on the left side of pc, to reduce the repetitive stress on my right hand).

I have the Framework ‘batch 7’ notebook pc, assembled-by-self.

I also have a problem with the delete key. I ended up trying a different input cover - and the delete ket was working. It’s a hardware problem with the original input cover. I’m unclear on if it was like that since I first bought it, or was something that developed later.

For anyone with a delete key that doesn’t work, I’d suggest considering trying another input cover.

Also, I just have to note - I am NOT pleased with the way Framework support handled it. I explained to them all of my troubleshooting steps, even took a video of the delete key being pressed at their insistence. Their response was the extremely insulting approach of explaining what the delete key does, as if I’ve never seen a computer before:

In text editing:

When pressed while typing in a text editor or document, the Delete key removes the character directly to the right of the cursor. This is in contrast to the Backspace key, which removes the character to the left of the cursor.

In file management:

When used in file management systems, the Delete key marks the selected file or folder for deletion. The actual deletion typically occurs when the user confirms the action, such as by pressing the Enter key or clicking the “Delete” button in a confirmation dialog box.

This has been happening to me for a month or two, intermittently. The key doesn’t seem to be stuck or anything, it just stops working for a while, and later comes back.

Very glad to hear this is a known hardware problem and not just ghosts!

1 Like

I thought that it was due to the delete key having dual functionality dependent on the fn key, however there is no combination or setting that fixes specifically the delete/insert key on the Framework 13. It would mean a lot to me to at the very least hear something about this from Framework before we all think about wanting to upgrade and purchase new 16’s… if they are ever available.

Framework, we would like this problem addressed please!

i’m having the same issue, the del button just stops working. I checked with xenv and the key just doesn’t send any signal to the os anymore, so i guess it’s a hardware problem.

sometimes when pressing the button often and for longer time, the functionality comes back, but it’s very unreliable, that this helps, sometimes it just stays days.

please provide a fix for this!

Just wanted to report that I have the same issue, delete key just suddenly stopped working, tried a fresh live linux (Fedora) iso but it wouldn’t help. German layout, input cover from 11th gen. Contacting support.

Had this issue with my 11th Gen’s Delete key back in August, reseating the connector didn’t fix it. I just ordered a replacement keyboard and that’s resolved the issue for several months now.

I’ve had this problem for a while and only recently thought to check if others had it too. At first I assumed it was a software problem, until I thought to check with showkey in the terminal - my delete key doesn’t even register a keypress.

I had a similar issue where it was working intermittently until it completely gave up the ghost a couple weeks ago.

Worked great as soon as I replaced the touch cover. Be warned, it’s a lot of screws.

Same issue here. Sometimes it worked, sometimes it didn’t, then stopped working completely. Now, 2 weeks later, I removed keyboard cover to swap WiFi card, and del started working again.

I would like to try this. When you say you “replaced the touch cover” do you mean that you bought a whole new input cover kit, or just that you took the input cover off and put it back on again? Would love to not shell out $100 for one key…

Replaced as in purchased a new one and installed the new one.