Broken delete key - like literally stopped working

Did you replace the whole input cover, the keys or the touchpad module? Trying to figure out what to buy, my del key stopped working and this time for good.

I purchased a new input cover kit. The keys are not user replaceable individually.

2 Likes

I’m on my second Input Cover from this specific issue and just started experiencing it again, it’s definitely a hardware problem. See [RESOLVED] Framework13 Keyboard has intermittent keys - #13 by Matt_Hartley and Some keys not working - #7 by Be_Far . CC @Matt_Hartley

On this (second, 13th gen model) input cover, I’ve disconnected the connector exactly once to add a memory module and that was months ago. This is likely not a connector wear issue and is something in the input cover or mainboard directly.

Delete on my 2 years old 11th gen intermittently stops working since about a month ago. Can’t see a pattern yet, but probably the same issue.

I ended up replacing the keyboard part – now del works again. There are a lot of screws, took me about half an hour.

I had this problem happen AGAIN, with a different input cover and different mainboard. In both cases the delete key worked at first, but stopped working after some months. I verified that literally every other key works.

I’m no hardware expert, but I was thinking of what I would investigate if I worked at Framework. I encourage everyone to post with more information about their setup - perhaps trends will emerge that will guide Framework’s investigation. Here are my suggested questions with my answers:

  • 13" or 16" system? 13"
  • Which mainboard? 11th gen and 13th gen
  • Which OS? Windows
  • Do you frequently use an external keyboard? Yes
  • Do you use a powered USB Hub? If so, which kind? Yes, Anker PowerExpand 13-in-1 USB-C Hub
  • Which port do you usually use when charging your laptop? Rear right port, closest to the delete key
1 Like

Maybe Support will replace it under warranty and try to do an RCA on the faulty one? Worth reaching out to them.

Same, delete key appears to have no response at all on my batch #3 AMD. Is the consensus to just replace the whole keyboard?

@ lbkNhubert unfortunately Framework support has not been helpful. The last time I ran into this issue I found their conduct insultingly patronizing:

But at least they did replace the input cover.

This time, after leading me through a lot of pointless troubleshooting, they refused to replace the input cover.

I could pay $50 for a new keyboard or $100 for a new input cover, but have decided not to at this time - especially as I suspect that a third input cover would also have the delete key fail after some months.

Instead, I used the Keyboard Manager tool in Microsoft PowerToys to remap the Framework button (alternate for F12) to the Delete key. Now I am able to delete text and use ctrl+alt+del without an external keyboard, and all that button did was launch the Framework website anyway. (Note: Keyboard Manager describes this key as “Send Media”.)

@pinkhatbeard you are welcome to try various troubleshooting steps (reboot, update, blow canned air, and so on), but… yeah. Almost certainly the keyboard is at fault. Previously I was able to try a good and bad input cover with two different Framework laptops and verify that the problem is with the keyboard. I encourage reaching out to Framework support, assuming your laptop is within warranty.

Again, I also encourage everyone who ever has or ever will post to this thread to answer some diagnostic questions Broken delete key - like literally stopped working - #26 by Chad_Schultz if enough people answer, that might provide some clues as to why the delete key fails for some people.

1 Like

same problem here. was able to wiggle the cover a little to get it to work but its completely dead now.

Hi @Chad_Schultz ,

Sorry to hear your frustration with the keyboard and input cover along with others. The silver lining I suppose is the Framework is extremely repairable. compared to other devices out there.

All the parts are covered by the 12 month warranty though correct? Or are you outside the warranty period again?

I do not know if I could use a keyboard without a functional delete key. Kudos to you for getting by with the F12 key as a substitute. :star_struck:

Great idea, that saved me!

2 Likes

Good thought on the warranty! I just took them at their word that I was out of the warranty period. Knowing now that it’s a 12 month warranty, I realized my input cover was well within that period and pushed them to replace it.

We had some back and forth - Framework support argued with me, not wanting to replace it. Apparently they were trying to use the date of the very first Framework order I had ever placed (more than a year ago) instead of the most recent input cover I had ordered (less than a year ago).

Annoyingly, there’s still no indication that they have any intention to investigation and resolve the root issue.

1 Like

@Chad_Schultz I wonder if we had a bad batch of input covers? I also ordered my now-defective one less than a year ago. Support has replaced it under warranty and the issue is gone.

That is entirely possible. If it was a bad batch, Framework should have been able to identify that from the affected customers, and should have been able to have the supplier told them what happened. One of my recommendations to them was exactly that, to communicate with the manufacturer and see if there was a known issue.

But I also wonder if the problem just hasn’t come back yet for you. Both times it happened for me it seemed to take a couple months to develop.

There are a numbero f possible causes. I still wonder if it could be related to me always plugging in the powered USB hub to the port near the delete key - wonder if somehow that fries the delete key over time. Ah well.

I now have the same issue… My delete key stopped working after updating the BIOS on my 12th gen.

  • 13" or 16" system? 13"
  • Which mainboard? 12th gen
  • Which OS? Windows, Linux
  • Do you frequently use an external keyboard? Yes
  • Do you use a powered USB Hub? If so, which kind? LG Monitor with built in HUB
  • Which port do you usually use when charging your laptop? Left Rear Port when using the monitor, Both rear ports when using the official charger