13" AMD - Keyboard has stopped working, as well as the power light

This started a couple days ago. I tried to wake my framework, but the power light was off, and the keyboard unresponsive.

Holding the power button down for, 10, 15 seconds the machine rebooted, but the keyboard remains dead, and the power light dead as well.

I’m using it right now docked to a thunderbolt hub, with an external keyboard.


  1. Keyboard unresponsive
  2. Fingerprint reader works (!?)
  3. Power button appears to unresponsive, but when held down for a long time appears to reboot the machine
  4. Trackpad works
  5. I have the internal display off when connected to an external display via my dock. When I unplug, normally the internal display comes back to life. Now, if I unplug, the display lights up for a few seconds then goes black. Plugging back into my dock everything’s fine.

This has happened twice. The first time, a couple days ago, I took the keyboard off and checked if any of the ribbon cables seemed loose, but I’m not really an expert. They seemed fine. When I put it back together everything worked normally. This second time has not had a happy ending.

Any suggestions for self-diagnosis of this before I escalate to customer service?

I’m running Fedora 39 for an OS. BIOS 3.03. Not certain if that’s an important data point.

Emphasizing this data point: When the failure occurs, simply rebooting does not resolve the problem. On reboot the keyboard remains dead, the power button light remains unlit. Trackpad works fine.

The fact that this persists after a reboot signifies a hardware failure to me.

I had a similar issue and it fixed itself after a few minutes. What I expect is that the embedded controller or something crashes or gets confused, however I haven’t been able to pin it down.

What I would suggest is, that you open it and disconnect the battery for a bit. That should reset the whole system and possibly make it recover? In general modern hardware doesn’t seem to power down completely when turning it off and disconnecting the battery often seems necessary to reset hardware glitches.

1 Like

I’ll give this a go when I get home from work, and will report back. Out of curiosity, did this only occur once for you?

So last night I pulled the battery, gave it a few minutes, and reassembled. Currently, the keyboard is working. But the last time it mysteriously started working again, it only worked for a couple days before repeating so I don’t know that I’m out of the woods yet.

Anyway, thanks for the suggestion, and I’m keeping my fingers crossed.

Nope, the keyboard has failed again. It was working this morning, until I let it go to sleep, at which point the failure re-occurred. I’ll have to reach out to customer support, as this renders this computer unusable.

Followup - I re-seated the ribbon cables on the keyboard component (keyboard, trackpage, etc). My framework has now been waking from sleep successfully since Sunday. I’m cautiously optimistic that this is resolved.

1 Like