Can not update EFI to 3.03

So I have a Framework 13 Ryzen. I’m dual-booting Windows 11 and KDE Neon (linux).
I’m trying to update EFI from 3.02 to 3.03

I have attempted to update the firmware in three different ways:

  • I’ve seen the firmware update show up within KDE Neon, the computer restarts, nothing changes.

  • I’ve tried the EFI boot updater, on an external flash drive. It reboots, but then hangs with a black screen. Forced power off is required…and a screen appears saying the update could not be extracted

  • I’ve tried the Windows update util, and I get the same hanging black screen.

I’m rather confused, as I’ve generally found EFI updates rather simple on other machines.

If you’re dual-booting Windows 11, have you tried the .exe updater in Windows? And have you installed the new driver pack before attempting the BIOS update?

Yes, I tried the Windows updater. I installed the driver pack when I set it up, but I can check if there’s a newer driver pack.

There’s a new driver pack on the 3.03 update thread and you must install the new drivers before attempting the update.

It looks like it’s displaying the same behavior after updating the drivers. Windows reboots then…the power light and keyboard light up, but black screen. No indication of anything else.

How long should the update take, and what should I see?

The BIOS update should take 5-10 minutes and there would be a splashscreen saying that the BIOS update is happening along with a progress bar. Afterwards, it should just reboot as normal. From what others have mentioned, if the BIOS updater has failed, it should spit out an error code.

Yeah, I’ve never seen the progress bar, nor anything on the screen. And I’ve had the same result attempting via the EFI-run version on a flash drive.

At this point, I think it’s best to open a ticket with Support.

Are you using Framework power adapter or third party? I’ve seen some third party having issues with BIOS upgrade. Also the battery shouldn’t be on 100% when upgrading. But it should throw an error.

I’ve tried with the. official and third-party adapters, but generally pretty fully charged.

I get EFI Error 02, and a mention of unable to decompress.

I think the battery should be less than 100% before applying the upgrade, let it discharge to 95 for example, plug the adapter and try again.

Non-full battery didn’t seem to make a difference either.

How big is your EFI partition? The 100 MB default of Windows? Could it be already too full to decompress the archive completely before installation?

1 Like

It looks like the size of the EFI partition was the issue.

I took out my main M.2 drive, and set up another with basically a 128GB FAT32 partition, with the EFI updater. After booting that, I now see the update progress bar, so it seems to be working.

Apparently it takes more than 50MB of space on the EFI partition to do the update.

Edit: Yes, the update successfully completed.