Cannot charge laptop

Framework laptop does not charge.

Read this:

Tried all the solutions listed there and the charge LED never illuminates and the laptop will not boot.

I would remove the CMOS battery with it unplugged and hit the power button a few times (while still unplugged)… put the CMOS back in… plug it into the wall again and try… beyond that… hit up support!

Tried the CMOS to no effect. Sent in a support request. Hopefully we get an answer soon. Thanks.


If the LED doesn’t illuminate that seems like a bricked laptop most likely… Hopefully it gets sorted!

Got an answer back from support giving me this guide to follow:

But unfortunately, even with the battery and the CMOS battery removed, there were no red blinking lights.

Troubleshooting steps given:

  • please let the laptop charge for 24hrs, this will trickle charge the RTC cell and will charge the main battery.
  • After the 24hr charge, please reseat the RTC from the MB & it should fix the issue.

I have tried this and there was no effect. Relayed this information to Framework.

Was given more troubleshooting steps:

  1. Try removing all the expansion cards and carefully plugging the power adapter directly into your USB-C Expansion slots.

  2. If Step 1 fails, try removing the SSD NVme and WiFi adapter, leaving you with just the ram module/s installed. Try to charge and/or power it on and see if it will give you any side LED indicator.

  3. If all above fails, carefully remove the battery cable connector to its connector pin on the motherboard. Check if there are bent pins that may have caused the issue.

Tried and checked all of this, no changes.

Was asked to remove the SSD and WiFi adapter again. No effect.

also try charging with different USB-C ports… that one it’s plugged into in the picture (top right) I sometimes have trouble charging with on mine!

I am suspecting a bad motherboard

Framework has confirmed that they think it is a bad motherboard and are planning to send a no cost replacement.