Laptop not booting

Hey y’all, just got my DIY framework laptop yesterday and I’m having some trouble. I popped in the ram, storage, and Wi-Fi card and my expansion cards but can’t get the computer to boot. I left it plugged in overnight on my charger (which I’ve confirmed works by plugging in another device) and the charging indicator stays off. Anyone else in my situation and knows how to fix? Thanks!


Have you tried charging via each of the four ports, to determine if you have an issue with a particular port? You also might try disconnecting the main battery and removing the button cell for several minutes - if you do remove the button cell, please follow the procedure in the knowledge base as apparently its holder is very fragile. Best of luck, looking forward to hearing that you were able to get things working.


I’ve switched the USB-C port to all available expansion slots with no success. I’ll give the battery removal a try :+1:

Make sure the battery connector is plugged in fully. Scan the QR code on the battery for the guide.

1 Like

I’ve disconnected and reconnected the battery connector, but I’ll give it another try

After about 20 seconds, do you get an LED boot code?

The same thing happened to me. I thought the boot code said “red” to “DDR Initialized OK”, pulled a RAM stick and it booted fine with one stick. I thought I had a bad stick but just before declaring it bad I reinstalled it and it booted fine again. So you may want to reseat your RAM if the boot code LEDs indicate a RAM issue.

1 Like

No, the LEDs don’t even turn on.

That sounds like a very serious issue. I’d contact support if I were you.

I’ve contacted them but slow back and forth :upside_down_face:

Update: removing the RTC battery worked! Procedure:

  1. Open laptop
  2. Disconnect kbd
  3. Follow this guideHow do I replace the RTC Battery in my Framework Laptop? to very carefully remove the RTC battery.
  4. Wait a few minutes
  5. Pop it back in
  6. Close it up
  7. Plug in to power

Holly crap it worked for me too! Thanks for the tip! I can cancel that service ticket now.

Had to do this for my DIY Edition, thank you!

1 Like

Just received my machine today (batch 6) and I needed to do this as well.