Does it need to charge on arrival? Should there be a light? Is my charger working?

My laptop arrived today and it won’t turn on.

If it’s shipped dead empty that might explain it. But most electronics I’ve bought have at least some battery charge on arrival.

I’ve had it plugged in for 30 minute or so, and it still does not turn on. I don’t see any lit LEDs on the outside, there are no sounds of any sort and neither the charger or the laptoip are making any heat.

Does this just need to charge all night? How can I tell if it’s charging? Did I get a bad charger?

Hi and welcome to the forum

  • There is no light on the provided charger you can try charging something else to be sure it works.

  • You can try charging with any other phone/pc charger with a USBC port. You should then get a red/orange light by the expansion card you use. The charger must have a reasonable power output.

If the above fails it may be the bios battery isn’t charged which is a bit of work. Framework use a chargeable version.


the battery is soft-disconnected before it ships. External power must be supplied in order to reconnect the battery.

The OP had connected according to the initial post :slight_smile:

So I left it overnight, no change. There still no LED lit.

The framework charger will charge a phone. The phone charger will not power the framework. So it looks like it’s the computer, not the charger.

1 Like

Hi @Matthew_Scouten :wave: @Steffen_Storbeck mentioned in this post [Windows 11: Wrong Time after resume from Standby} that he was ‘affected by the “not starting to charge” issue and had to reset the board before getting it to work’. That could be the solution you’re looking for.

He links to the guide on how to do that in his post.


@Lawrence_Gardiner Exactly :slight_smile:

@Matthew_Scouten Try this support article about resetting the mainboard:

Be careful removing the small RTC battery - the holder is very fragile!


Yeah, I guess that’s where I am going to have to go next. I’m not sure when I’ll have time for a couple hours of computer surgery this weekend, so I’ll get to it when I get to it.

Now to take a moment from the practical to emote about this because I need to feel heard:

I’m a little cheesed. I bought the fully built version rather then the DIY for a reason. Getting the laptop bricked on arrival (even if it turns out to be recoverable) is disheartening.

Even if I fix it and love it, I will now have to be hesitant to recommend this to non-enthusiasts.

Although I suppose the fact that the community has a prompt and helpful response is a big plus.


@Matthew_Scouten Actually - it will take you around 30 minutes max, i got it done in 10 minutes.

Try the second charger fix first and if that does not help - reset and done.

I had an DIY Build, so it wasn’t that troublesome for me. But I understand your frustration. Don’t forget the BIOS Update to 3.07 afterwards :slight_smile:

Does this just mean trying any other charger? I have a samsung phone supercharger and I tried that. That’s the most capable USB charger that I have on hand.

If the “second charger fix” is something different, link or instructions please?

1 Like

I understand the frustration, Framework is a brand new company though and hopefully the fact that you have a fully repairable, upgradeable laptop with long term support (:crossed_fingers:) will more than make up for it.

Best of luck sorting the issue.

@Matthew_Scouten Check this link before:

If your Samsung did not help (but even that might be too “smart” to wake the framework), i guess you will need to do the reset.

1 Like

Alright, that reset procedure worked. It was easier to do then it looked.

I also tried several dumb chargers for the dumb charger trick. Either it wasn’t the right problem, or I didn’t have a charger dumb enough.

Thanks for everyone’s help.


@Matthew_Scouten Great :slight_smile: Thanks for sharing, have fun now.