Can't Turn on Laptop, Inconsistent Behavior

I got my DIY edition today. Went through all the expected steps (installed storage and RAM, did battle with the Wi-Fi module, etc.).

When it came time to turn it on, however, nothing happened. The light was white for a bit, then blinked red a few times, then nothing. Since then, I’ve been trying over and over again. Strangely, what actually happens when the power button is pushed is seemingly random:

  • most often, the right side LED flashes green once, very fast.
  • sometimes, the power button LED blinks red twice; this seems to happen if I hold it down for a second or so.
  • also sometimes, the power button LED turns white, then the side LED stays lit green for about 5 seconds…before turning off and having nothing happen.
  • very rarely, the power button LED turns white, blinks red five times, and I get the right side LED boot sequence.
  • exactly once, I was able to get the laptop to turn on, but of course I didn’t have my boot media inserted :man_facepalming:; I will note that this happened during my troubleshooting, when I only had one RAM stick installed (see below).

When I was able get the side LED to blink its startup sequence, I was able to see lights 4 and 10 were red (seemingly indicating a CPU error). I’ve tried every troubleshooting tip recommended. I unplugged the main battery and reset the RTC battery (waiting 15 minutes between disconnect and plugging them back in, at which point all the LEDs inside the laptop started blinking red). I tried using just one RAM stick, which seemed to work at first, but that turned out to just be an anomaly; even with only the one RAM stick, I haven’t been able to get the screen to come on again. I’ve tried turning it on with a charger, without a charger, with a charger in a different card, with a charger in a different port…

Is there any hope for me? Framework doesn’t seem to have a support line, so…

1 Like

Oh hey. Apparently I got a badge for making this post with an emoji. That’s nice.

1 Like

Well, I went and did everything again, and now it works. shrug


did you change anything, or just let it sit, and then it decided to work? I know i’ve had to let it sit for a few min (2 max) to do the ram test, then it came up, but then i disabled that all from the bios. Its voodoo, like most of IT right :smiley:

Ah. The lengthy one.
happened to another laptop of mine, too. Was flashing a bios. Thing turned off after saying it finished flashing, the fan would spin but the screen wont light. After a couple confused power cycles, I let it sit there for about 5 minute and then after a extremely loud beep we have splash.
Now that you had notion the behavior, I will keep it in mind and let it find its body parts for as long as it want.