CentOS on AMD Ryzen 7040 Series?

I’d prefer centos to fedora - I ran fedora for 15 years and was wanting a bit more stability in my life :smile:

Is there any knowledge on running centos - I’ve attempted to boot off the centos 9 net install, but the bios doesn’t see it - I then tried to boot of fedore 39 live and it went without a hitch.

Any ideas?

The CentOS 9 stream (not CentOS 9)'s kernel version is 5.14.0 according to the RPM package list. Perhaps, the kernel version is too old to run it on Framework Laptopo AMD?


Yes, soz - forgot the steam bit.
You’re definitely correct - I just did a similar check on fedora 39, it’s at 6.64…
I guess I should just run with fedora and change a bit further down the line - any idea how long it would take centos to get what ever it is that fedora has to run the AMD hardware?

I don’t know it. It depends on your action. You can ask to support CentOS 9 Stream or coming CentOS 10 stream on Framework Laptop 13 AMD on the forum or by submitting an issue ticket. If it’s not hard to backport the patches from Fedora to CentOS 9 stream, perhaps it may be possible.

https://www.centos.org/ - Community - Forums or Submit Bug

Thanks @junaruga - those are very good suggestions and really ones I should have come to myself - but, hay, now everybody has the benefit of your help! Thx :smiley:

1 Like