Charging problem, led ok but battery still draining

I’ve the framework intel 11th gen. I’ve been trying to charge it for an hour now but the battery continue to go down. I’ve try several usb charger pd compatible, the icon and led always indicate that it’s charging.
When I use the CMD line
gwmi -Class batterystatus -Namespace root\wmi
in Powershell, it indicates zero amp in charging state .
Does anybody has any idea?
I’ve tried all the ports. With or without expansion card.

i am not share but maybe you need to update the bios and check the setting for the battery maybe try checking this guides see if it’s helping

As the first article @Mina linked says, make sure that your charger can support 60+ Watts of power. Just because a charger is PD, does not mean it can charge the laptop at it’s needed wattage. If your charger is enough, make sure that it isn’t charging at 15V, as some Framework laptops can’t charge correctly at 15V and need 20V instead. If all of these fail, I would recommend contacting Framework Support if you haven’t already, as they should be able to help you diagnose your issue, and can help you with an RMA if you happen to have bad hardware.

I’ve tried with three charger. The one I’ve been using for a year, 45 watt, the one from my Nintendo switch and other one from my phone at 30w. The thing is, as far as I know, charging with a 60w wouldn’t resolve my problems because the problems is not that it doesn’t charge fast enough but that it doesn’t charge at all.
I’m ok with trying a bios update. The problems is that I’ve left very little battery (5% or less). If I update and that it power off during, it can break the mb.

45 watt usb PD chargers aren’t required to output 20v. Often 15v is the highest they do. So you may be running into the issue with some 1st gen Framework laptops where they can’t properly accept 15v. A 30w PD charger is ̶o̶n̶l̶y̶ ̶r̶e̶q̶u̶i̶r̶e̶d̶ ̶t̶o̶ ̶s̶u̶p̶p̶o̶r̶t̶ ̶9̶v̶ ̶c̶h̶a̶r̶g̶i̶n̶g̶ and almost certainly won’t do 20v. That one might just not be providing enough to power the laptop and charge. I don’t know what Nintendo switch chargers provide.

There is a chart here that shows what different wattage chargers are required to provide.

I’d suggest trying to charge your laptop while it is off using the 30w charger. If the charge level increases at all, then that would indicate you’re running into the 15v issue with your 45w charger.

Sorry, I misremembered my charger wattage. Here the specs

Hmm, well, that should charge your Framework.
Still, you should eliminate the possibility that, that 65w charger isn’t working right. It could be failing to negotiate PD properly and falling back to a voltage level that isn’t enough to charge your battery.

So I’d still suggest trying to charge your laptop while it is off using the 30w charger.

Oh wait, a 30w charger is just over the limit for requiring 15v. And I googled Nintendo switch requirements, and it uses 15v, so your switch charger may be 15v max as well.
Meaning you could be running into the issue where some 1st gen Framework laptops can’t properly accept 15v with both of those chargers.

See if you have any other chargers. I think I recall that Framework laptops can even accept just 5v, it will just be an extremely slow charge & only when turned off.

Just to rule out the possibility that your 65w charger isn’t negotiating properly.

It’s has been charging on my 30w charger the whole night. I didn’t get any charge but when I started again with my 60w charger, IT WORKED.
Thanks for your help, I’m not understanding what happened but whatever. Just hopping it doesn’t happen again.
Have a good day
Edit: maybe your right and the two other charger I tried were in 15v and my laptop doesn’t accept it

Oh, good.
Just so you don’t run into it again at a bad time, you still might want to try to find out if it was the 65w charger’s fault or the Laptop’s fault.

Yeah, I’m not sure how to test the charger. Because it output the right voltage depending on the load. So I would need to connect it to the laptop and find a way to check the output voltage. Kind of sketchy.
I’ve thought about a laptop problem, like an overtemp safety. But when I check the battery level history. I saw that it stopped charging when I was a work, in the middle of the day, as it was closed.
So there is no reason that it overtemp, it isn’t that hot where I live.

The really weird things is that the led and the icon where indicating that it was charging.

f it’s problem with USB-PD negotiating i think you should buy new one from reputable company (like Anker or UGREEN) that has 65 watt just to be on the safe side or buy one from framework
you can open the laptop and test it with multi meter may be call framework support to give you guidance with testing if it’s the case