Clock stuck at .39Ghz

“Agreed, would be nice to have the ability to flash it via a bootable media.”

You can use a utility called Rufus and a generic win10 install iso to create a “windows-to-go” install which boots and runs from usb. You don’t need a windows license, it will run well enough and just disables some personalization stuff like setting the desktop wallpaper. It’s annoying and overkill and you shouldn’t need to do that, but it works and you can do it right now for free from public downloads. I installed to the framework 1T usbc module since it’s read/write specs are better than any thumb drive.

Update, I only just now discovered:


The beta BIOS 3.07 is working for me so far! Thanks framework team!


Just wanted to give an update on this issue. I installed the new drivers as well as the 3.07 BIOS and I haven’t had any issue anymore. My laptop has been running the best it ever has! Thank you @Kieran_Levin and whoever else from the @Framework team that worked on this!!


Well well well… Lookie what I have here :frowning: Good to know there is an update. Going to install now.

EDIT: Well that got scary for a minute. Update success!


Updated to 3.07, still having issues where the clock drops down to 800Mhz and then slowly creeps up again. Disabling BD PROCHOT in ThrottleStop doesn’t help.

posting this here since this thread is the top search result for CPU clock issues: if anyone with a batch 1 machine is still experiencing this symptom even after updating the BIOS to 3.07, consider replacing the thermal paste on the CPU. not only did this fix the clock issue on my machine, but it seems to be running much cooler overall and the fan doesn’t seem to spin up nearly as often (prior to this, i would sometimes hear the fan running at maybe 50% capacity when the computer was mostly idle).

1 Like

@Kieran_Levin I can confirm that my batch 1 model slows down heavily after a few minutes of usage if and only if “Processor performance boost mode” is enabled:


I got 0 issue if that setting is disabled.

Already did that. It feels much cooler/silent now. But I still got the very agressive downclocking issue described above.

I also have the problem of my device throttling to 400 MHz whilst gaming. I’m playing Far Cry 5 via an eGPU with a GTX 970 and an i7-1165G7 with 16 GB of RAM. All cores regularly throttle to 400 MHz and reduce the TDP to around 5 W. I’m running BIOS 3.10, which sadly didn’t fix the issue.

@Kieran_Levin is there going to be a fix for this? This problem seems to be persisting for a long time. I’m a Batch 8 user so there’s something critically wrong with production.

1 Like

sadly, this is why I canceled my order.

This is the exact issue I’m having. First framework laptop I had worked fine, but was replaced due to refusing to power on or charge. The second laptop would regularly throttle. I was then shipped a replacement mainboard (laptop #3?), which seemed to fix it for a few days.
The issue still persists, I’ve tried pretty much every reasonable thermal paste, including Thermal Grizzly, Shin-Etsu, and Arctic MX-5.
I really want to keep using my Framework, but this is driving me insane. I’ve emailed another request to support. They’ve been very helpful, but regardless I’m really not hopeful this can actually be fixed.

@cowpod if you turn off the CPU turbo in Windows power settings, the throttling is resolved. You might need to edit the registry to see the option. Sadly the only solution I’ve found.

@preston thank you, even though this isn’t a solution - it completely removes a majority of the CPU performance.
It’s a shame that I’ll have to handicap my processor (not an issue with any other $1000+ laptop) in order to use it normally.

@cowpod I agree. It’s sufficient for me to be able to play Far Cry 5 smoothly so I can live with that. In the end the base clock isn’t that low either. But I’m also looking forward to a fix by Framework. @nrp please look into this.

Actually it is a common behaviour with intel cpus for a quite some time.
The new XPS 13 Plus is dealing with the same issue right now…
Havent had the issue myself though, therefore i have never looked into it and have no idea if it is fixable by the user…

I’m seeing this issue with the new 12th-gen board as well (not sure if anyone else here has the new board), on Linux. For me, it looks like:

  1. Start playing a game
  2. After several hours playing, it suddenly slows to a crawl.
  3. Check CPUs; all are running at 399MHz. Check temperatures; max is around 65C.
  4. Quit game.
  5. Wait 15-20 minutes.
  6. CPUs recover and start working at higher speeds again.
  7. I can go back to playing the game, and it seems fine for at least a few more hours before slowing down again.

I’ve tried rebooting, but that doesn’t solve it. Even the Framework logo boot screen, and the GRUB bootloader screen paints slowly, before Linux is even loaded, so it doesn’t seem to be an OS issue. I feel like a BIOS/firmware update might be necessary to fix this, assuming it’s not a hardware/board design issue. I’ve had the laptop plugged in during all this (charged to 100% or near-100%), and haven’t yet tried unplugging it.

Have you tried kernel 5.18 ?
It brings a lot of improvements for 12th gen. Like 20% efficiency even on high loads.

That would be 5.19, I guess

@cowpod Two adjustments you can make on Throttlestop that potentially could be a temporary fix until framework comes with a bios fix… The problem seems to be when it throttles to some critical temperature, it goes to 400 mhz and doesn’t know how to come back up again.

You could maybe use throttlestop to decrease the temperature at which it throttles 2-3C so it never gets too hot, though if the bug could happen anytime it throttles, this might cause the bug to happen more frequently.

Another potential solution may be to lower the turbo ratios down incrementally to decrease the spiky nature of turbo and or set PL1 and PL2 time to infinity and cap the TDP value to a wattage that it will never reach a thermal limit and start throttling. You can maybe start at 28W and increase or decrease the TDP to maximize wattage while never throttling.

Have you tried kernel 5.18 ?

Yes, I’m running Debian testing, which is on 5.18 now. I’ve also tried 5.19 (in experimental), but that caused unusable mouse pointer jerkiness and stuttering.

I’m getting stuck on 0.39 Ghz with both linux and windows 10 on the alderlake laptop. I just started up the laptop today and it was slow, even in the BIOS.

It doesn’t make any difference if it’s on battery or plugged in, it’s still stuck at 0.39 ghz

edit: hmm, disabling the battery through the BIOS seems to have fixed this…

edit 2: This is weird… it seems like the disconnect battery option only applies for the next reboot (it isn’t saved like the rest of the BIOS settings).

Anyways, I think what happened was that I set the “disconnect battery” option, then on the next boot I disconnected the power to see if disconnecting the battery would cause it to fail to boot. It seems like it tried to boot, but ran out of power and shut off again. This seems to have reset something internally and fixed my problem in the process, so I will leave this here for anyone else who happens to stumble on this issue:

My steps were to set the “disconnect battery” option in the bios, then disconnect the power and try to turn it on again. It should try to boot without power and then fail. After that, it should work.