Clock stuck at .39Ghz

“Agreed, would be nice to have the ability to flash it via a bootable media.”

You can use a utility called Rufus and a generic win10 install iso to create a “windows-to-go” install which boots and runs from usb. You don’t need a windows license, it will run well enough and just disables some personalization stuff like setting the desktop wallpaper. It’s annoying and overkill and you shouldn’t need to do that, but it works and you can do it right now for free from public downloads. I installed to the framework 1T usbc module since it’s read/write specs are better than any thumb drive.

Update, I only just now discovered:

3 Likes

The beta BIOS 3.07 is working for me so far! Thanks framework team!

6 Likes

Just wanted to give an update on this issue. I installed the new drivers as well as the 3.07 BIOS and I haven’t had any issue anymore. My laptop has been running the best it ever has! Thank you @Kieran_Levin and whoever else from the @Framework team that worked on this!!

7 Likes

Well well well… Lookie what I have here :frowning: Good to know there is an update. Going to install now.

EDIT: Well that got scary for a minute. Update success!

3 Likes

Updated to 3.07, still having issues where the clock drops down to 800Mhz and then slowly creeps up again. Disabling BD PROCHOT in ThrottleStop doesn’t help.

posting this here since this thread is the top search result for CPU clock issues: if anyone with a batch 1 machine is still experiencing this symptom even after updating the BIOS to 3.07, consider replacing the thermal paste on the CPU. not only did this fix the clock issue on my machine, but it seems to be running much cooler overall and the fan doesn’t seem to spin up nearly as often (prior to this, i would sometimes hear the fan running at maybe 50% capacity when the computer was mostly idle).

1 Like

@Kieran_Levin I can confirm that my batch 1 model slows down heavily after a few minutes of usage if and only if “Processor performance boost mode” is enabled:

image

I got 0 issue if that setting is disabled.

Already did that. It feels much cooler/silent now. But I still got the very agressive downclocking issue described above.