[CLOSED] My Framework is not displaying anything

I just receive the FrameWork Laptop from yesterday. And I trying to installation the operation system from UBS Drive is not showing any sign for installation and is not display Framework logo.

Hey there, I think we need to know a couple more thing but I suggest you check out this guide first as it will be better explained. In a short summary:

  • Have you contacted Framework Support?
  • What operating system are you trying to install?
  • Is this the DIY version?
  • Does the fingerprint reader lit up when you start the machine?
  • Does the side led between the USB-C port lit up right at startup, and if so what are the signals?
1 Like

Hey, please reply in this thread. You can reply directly using the red “reply” button, You don’t need to create another thread for that.

The led light is white

Are you talking about the fingerprint LED or the side LED ?


Continuing the discussion from My Framework is not display anything:

The LED light is white. At the starting, I did pressing on button an is not showing any sign of FrameWork Logo. I did turn off and put the USB with Windows 11 to step up the Operation System but still nothing showing? Yes this is DIY edition


Yes, it is correct fingerprint LED is white and both side where the expansion slot also is white.
My FrameWork Laptop, I did press Fn + F12, still not showing nothingness. I also did try with Fn + F2, and Fn + F10. It is still showing nothing yet.


My Display of FrameWork Laptop it is not showing any sign of any image.

Is it a 11th or 12th gen? I have linked you to the 11th gen guide, so here is the 12th gen guide.

At the first power up, have you waited a few minutes for the RAM to initialize?
Have you followed the 12th gen DIY guide ?

Edit: Yes, you have a 12th gen.

1 Like


Yes, it is 12 gen Intel Core.

It did following the 12th gen guide as let the FrameWork laptop on more time. But still not showing anything yet?

Power down then power up the machine. Note the led signals on the side of the laptop and the colors.

  • Is it staying white at startup?
  • You may see the led blinks, please note every single one of them (white - green - green - green etc.)
1 Like

Do you think that the Display is the problem?

I can’t say if I don’t have the led signals. Could be.

Ok, I did turn on again in both side at start is showing colors light. I did not put the energy charger this time to observe the my Framework behavior. At staring is showing different colors and then stop showing lights. But I do hear my noisy fan.

What is the color sequence ? Take a piece of paper if you need it and note down the colors. Be careful not to miss one of them. At the end you should have 1 white + 12 green or red then one orange then 7 blue or green.

Those colors light so fast. I remember Green, Red, Blue. I wonder that Fan can place with AirJet thema cooling?

Record it then note the colors later. You don’t need to send the video.

I remember Green, Red, Blue

I need the precise sequence

At the star is white 1, green 12, red 1, orange 1, blue 1, green 1, blue 1.

12 green and 1 red is not possible, (should be 11 green and 1 red).

It seems to be a display issue as it is before the orange. You need to contact framework support, ask them to resolve your issue and link this thread to them.

1 Like

If you are brave enough, you could open the laptop and try to check the internal display connection. Have you experience opening your laptop?
Maybe it’s just the display connector that is not completely plugged.