Community reviews

It’s part of a custom modifier layer I implement using AutoHotKey. The layer is activated by holding caps and I have bound various keys for easy access (e.g. hjkl arrows). I bind caps+x to delete and also take into account ctrl/alt/shift modifiers.

So my frequently used shift+caps+xshift+del mapping to permanently delete files doesn’t work on the X1 :pensive:

I’m hoping when Framework releases the EC firmware source that I can implement this directly on the keyboard firmware!

3 Likes

Great review @feesh ! Looking forward to receiving mine and running it through some Hyper-V stuff.

1 Like

Thanks for the reviews @jeshikat @Michael_Lingelbach @A_L and @feesh

Highly appreciative of anyone else willing to share their experience because the core team appears to be watching these threads and issuing updates for issues, which makes the overall experience better for all of us.

11 Likes

Got my Batch 1 DIY edition last week and finally had time to set it up. I have the DIY i7-1165G7, 2x32 GB memory, FireCuda 520 2TB, and AX210 non-vPro on Windows 10 Pro.

What I love:

I LOVE that it is modular and built to be repaired. My past two laptops were 2 in 1s (Surface Pro 3 followed by an Eve V) and the SP3 developed a screen discoloration issue after an MS firmware update caused it to run full throttle while inside my laptop bag. The cost to fix that three months out of warranty, $450, no thanks. My Eve V has been plagued with a wireless card issue since day 1 and I ended up getting a USB dongle to have consistent connection which laughably cost more than the AX210. I love the idea that if/when this machine starts having issues I can just buy a replacement component.

I love that both the microphone and the webcam have physical switches to disable them. It looks like the webcam is electrically disconnected as it disappears from device manager, however, the microphone does not, so not sure how that is being done.

Concerns I have:

Only real concern is with the hinge for the monitor. Pulling on one side or the other encounters more resistance than I’d like and you can see the panel bend just a little. I’m sure I can learn to pull it down from the middle, but would prefer a slightly less resistant hinge.

Other stuff:

Keyboard/Touchpad: Since I’ve been using 2 in 1s for the past 7 years my standards for things like keyboard travel and touchpads is going to be quite a bit lower than everyone else. To me, the keyboard feels really good. I feel like I could type on this all day. The touchpad is responsive and accurate.

Screen: I have it set at 1.25 scaling and I’m really enjoying the 3:2 aspect ratio. I do wish it was a 4K panel though. Coming from the Eve V with a 12.3" 2880 x 1920 panel and knowing that the upcoming Eve V is a 13.5" UHD+ 3840x2400 panel I wish there were additional options. I definitely notice the considerably lower PPI. I mention this only because I had originally pre-ordered the upcoming Eve V, but cancelled it when I heard about the Framework. I figured reparability was more important and that I could always swap the screen later with a higher resolution panel (and hopefully I’m right about that).

Disassembly/Assembly: Both were ridiculously easy. Everything is well labeled and the guides online (only needed them for the wifi card) are very well written.

Battery: The jury is still out on the battery. My battery monitor app says I should get around 8 hours surfing the web and running Office apps. I am however also experiencing the sleep issue that others have seen with the Realtek driver. I’ve also noticed that waking from sleep is sometimes slow and other times it’s instant. Might dig into that later.

Fan: Normally it’s silent. Only time I’ve heard it is when I put it on the couch for a few minutes and it didn’t have proper airflow.

10 Likes

@Steve_Koch 4k panels are quite hard on the battery. I think this resolution is ideal for the size.

1 Like

HIgh refresh rate is probably a better choice honestly

2 Likes

I think the current panel resolution is great, and any addition resolution would come at the expense of battery life. I’d be more interesting in a textured glass surface (built into the display glass, not a cover) like the Apple Pro XDR display or the Valve Steamdeck (top model) to reduce the glare, and any lower power display tech, but this really depends more on display manufacturers moreso than framework.

3 Likes

A glass cover would have the added benefit of making the display housing a bit more rigid. However, it might complicate the ability to repair the unit as well, so not sure about it in the long run. Then again Framework, as a company, has proven that they are wizards at taking tech that is not repairable and designing it in such a way as to allow it to be.

What I secretly hope for is a touch and wacom / pen panel display. That would be the ultimate display for me. Still super happy with what I have.

1 Like

Massive props to Framework

2 Likes

Hmm, I am on Fedora 34 (a respin published yesterday, 8/16), and I have libfprint-1.90.7-3.fc34.x86_64 installed. I wanted to try the later version to try to see if that would help me reset my fingerprint reader, but when I did the above, it did not install 1.92.0:

[root@fedora ~]# dnf install fedora-repos-rawhide
Last metadata expiration check: 1:45:53 ago on Tue 17 Aug 2021 08:46:50 PM EDT.
Package fedora-repos-rawhide-34-2.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@fedora ~]# dnf --disablerepo="*" --enablerepo=rawhide --releasever=35 install libfprint
Fedora - Rawhide - Developmental packages for t 122 kB/s |  11 kB     00:00    
Fedora - Rawhide - Developmental packages for t 977 kB/s | 3.3 MB     00:03    
Last metadata expiration check: 0:00:12 ago on Tue 17 Aug 2021 10:33:23 PM EDT.
Package libfprint-1.90.7-3.fc34.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
[root@fedora ~]#
1 Like

Because the reason might be the rawhide repo is already Fedora 36 right now. You might need to install not rawhide repo but Fedora 35 repo. I don’t know the exact commands.

The following command options are to specify the Fedora 36 repo, and trying to get Fedora 35 package. There is a mismatch here.

--enablerepo=rawhide --releasever=35
1 Like

@junaruga Thank you for that tip. After a little internet searching, I installed it with the following (update instead of install):

dnf --disablerepo="*" --enablerepo=rawhide --releasever=36 update libfprint

Sadly, that did not resolve my problem of not being able to re-enroll my fingerprints. I clicked the button to delete fingerprints, and it acted as if it had done it, but a subsequent attempt to register a previously registered fingerprint failed with the same error as before – Failed to enroll new fingerprint.

1 Like

Here’s my latest writeup:

5 Likes

@Ian_Darwin Nice review

Small correction needed:

you can add DDR4 SODIMM memory up to 64MB

I guess 64MB should be enough for everyone :slight_smile:

1 Like

Umm, yes. :frowning: Finger memory sometimes shines through. Has been emended.

Before that: 64K should be enough for everyone.

Before that: 3 or 4 of these new “computer” things should be enough for the world.

@aquaticDolphin Thanks for the nudge.

2 Likes

My review:

Assembly

Disassembly was well thought out and extremely easy. The included Framework screwdriver with its Torx T5 was all that was required.

The 4 captive screws and the 1 “pusher” screw is a brilliant arrangement, the cover popped off easily, I flipped it over and slid it halfway down the internals, covering the battery as recommended. The keyboard and touchpad cable is folded and split so it expands this way without putting tension on the cable or connector.

Installing the M.2 drive and the memory was easy. I was not overly familiar with the SODIMM latching mechanism arrangement but it seemed idiot-proof: the memory could only go in one way determined by the notch and the retention mechanism not only held the module down by the top but also firmly in place against the socket by the holes in the module and tabs in the retention mechanism.

The only part I had been warned about and dreaded was the wireless card installation. Yes, it was tricky. I was very careful not to damage the tiny connectors by pushing them down at an angle and the wires were stiff enough to twist the connectors so they wanted to go down this way. I had to pull a fair amount of slack out of the wires to ensure they were coming in from the bottom to avoid the cable torsion pulling off the connectors. Finally they both snapped into place. I routed the wires carefully and had to redo this several times. Placing the retention bracket with the wires in place behind it was tricky and took several attempts.

Perhaps I pulled a bit too much slack out of the white wire but it does clear everything and the connector is definitely oriented towards the bottom.

A final inspection to ensure everything was well-seated and I closed the lid and tightened the screws.

First Boot

I plugged my Ventoy drive in containing various Linux installation media. I plugged the power in - an orange LED indicated it was charging properly. I pressed the power button which lit up. The screen did not turn on but I was led to expect memory training would take a few minutes. After 15 minutes and no screen, I realized something was wrong, held the power button down to power down and powered up again. This time I noticed the boot code LED was flashing a sequence of green and red LEDs. That LED flashes by very quickly. I could not be sure if it was red on “DDR initialized OK” (bad but not the end of the world) or “Internal display initialized OK” which would be very very bad.

I opened it up again, checked all connections and checked the display connection very closely. I couldn’t find anything. When I sealed it up again and tried booting (no dice) I thought it might be a bad stick of RAM and removed one. With one stick removed it finally booted up. Just before declaring I found one bad RAM stick I reinstalled it and it booted up!

Without detecting a valid OS boot drive it immediately took me to a first boot menu as expected. It saw the Ventoy drive fine but would not boot from it. After several attempts I put the Linux Mint “edge” install media in an old USB thumb drive and it booted fine from that. I installed Linux Mint very easily - the edge ISO contains a 5.11 kernel that allows the wireless card to work out of the box. I documented the rest here.

Keyboard and Trackpad

The keyboard is good, decent travel, nice and clicky, a bit of a soft landing. My older laptop, an MSI GS30-2M Shadow, has a keyboard that is almost as good, but the keys are smaller and have a harder landing. My corporate laptop, a Lenovo Thinkpad E560, has a lighter spring feel and a harder landing as well but similar travel and “clickiness”. So the Framework keyboard is good but not the very best thing about the laptop. However I very quickly got used to the split arrow keys. They work fine, no problem.

What I really like is the trackpad. It’s much better than my other two laptops. It’s larger, and the surface is incredible to the touch. It’s glass so it’s very very smooth and silky-feeling, yet hard. It should be very durable. The plastic touchpad surface on both of my other laptops is wearing shiny and slightly sticky which feels awful to the touch compared to the Framework.

Expansion Modules

This is a great idea and I do not find that “only having 4 of them” is a detriment. I was able to use exactly what I need, nothing more and nothing less. I kept it simple and have installed two USB-C modules and two USB-A modules, one of each on each side. This way I can charge the laptop from either side, have one high speed USB-C port available for data transfers and two USB-A ports available. Perhaps I should trim it down to 1 USB-A port but I still have many more USB-A peripherals than USB-C peripherals. The USB-A port worked perfectly with my old thumb drive for installing the OS and the USB-C port works fine for charging and docking.

Charger

Speaking of charging, the official Framework charger is excellent and I’m glad I got it. It is incredibly small and light. The included USB-C cable is nice and long, the wires are very heavy gauge and the cable is tough. The right-angle connector means that it doesn’t stick out as much from the laptop as it would otherwise.

Screen

I don’t find the glossy screen much of a problem except for taking photos of it with it off for review purposes. I just put on a light background and the light from the background washes out most reflections. The 3:2 aspect ratio is nice, it makes the screen seem much larger than it is - the 16:9 screen in my 13" MSI GS30-2M Shadow seems positively tiny by comparison.

Scaling was a bit of an issue but I got it to work as outlined in my Linux Mint thread.

The screen is very bright, clear and sharp, due in no small part to its lack of a diffusing anti-glare coating which many have gotten used to I believe. I have no problems with colour balance and have tweaked it using Redshift colour-adjusting software as mentioned in my Linux Mint thread.

Size, Weight and Construction

Its size and weight make it very easy to carry. The 3:2 screen means there is lots of real estate for large keyboard keys and a huge trackpad. It’s deep for its size. It’s not as wide as my MSI laptop but a little deeper.

The aluminum chassis is very rigid and very solid. The fit and finish is excellent, I do not see the keyboard cover lifting or any gaps and the screen bezel is firmly held in place with no gaps.

Performance and Cooling

I’ll cover benchmarking in another thread but the executive summary is that the Intel Core i7-1165G7 is fast. Single-core, it often approaches my 105W TDP desktop AMD Ryzen 9 5900X.

When the CPU is pushed hard, the fan makes itself known for sure, but it’s mostly blowing air I’m hearing. It doesn’t spool up all that quickly and it’s not whiny.

The temperature tops out at 82°C. It can stay there continuously so it seems to be throttling at that point. One core can attain 4.7 GHz and all cores can briefly attain 4.1 GHz, exactly according to Intel’s specifications, but long term they will settle down to about 3.8 GHz. I did see a brief spike to 95°C with one core at 100% before thermal throttling and cooling brought it back down.

Battery Life

I have not tested this extensively yet but it seems good to me. I’ve used it on battery almost every night, mostly web browsing. In about 3 hours it goes from 100% to about 70%. My software is reporting it still has 4 or 5 hours remaining. I’ll take that with a grain of salt but I see no reason this laptop should not get 6 hours + on a charge. Maybe not 8 hours.


In short, I am THRILLED to have this laptop. It feels well and truly MINE and to be able to get into it with not only the permission but the assistance of the company behind it is wonderful. I am very eager for future upgrades. Perhaps not the very first upgraded motherboard released but maybe 5 years from now when several CPU generations have led to significant improvements.

My MSI laptop is still somewhat relevant but only because it was so fast at the time that it’s still competitive today. It was more expensive than the Framework. Had I not spent as much as I did on it, it would be about as competitive as my budget corporate laptop, which is newer than the MSI but much slower. It will be a while before the 1165G7 is severely outclassed, but it’s fantastic knowing there’s the possibility of upgrading the laptop while keeping the rest of what’s great about it, and costing less than a whole new one.

12 Likes

Great review, the only time that I get the fan going full blast is during photo editing (Canon DPP4) and Spotify, other programs and Edge browser open. I’m very happy with the purchase and hope Framework is around for years to come. I’ll be interested in what the v2 or v3 laptop with be capable of.

5 Likes

Here’s my quick review after a day. I am typing this from my Framework laptop. So that you have a reference point, I am coming from a M1 MacBook Air and Surface Pro 6. Here are some of my impressions. I hope that this helps someone make a decision on committing to the Framework life.

TLDR
I knew coming in that Framework won’t be the perfect laptop and that there will be compromises. And there certainly are. Personally, my biggest compromises are battery life, the heat and that crazy LED from the power button. The short battery life holds it back from being a modern laptop where you just don’t have to think about battery life during the day. Coming from the M1, the temperature on the lap kinda came at a surprise with a conclusion “hmmm…it’s Intel”. The LED from the power button is an unprovoked assault on my retina. A fix is coming but it’s gonna take a long long long time.

With all that said, Framework is MY laptop. It’s all mine to do as please. The sense of freedom is exhilarating. I won’t hesitate on breaking the screen if I want to, by applying a screen protector. I LOVE the Framework laptop. I expect to use it for 10 years. I hope that Framework succeed in its mission and over that 10 years, my Framework laptop would slowly morph into a still very capable device yet nothing like the Framework laptop I hold in my hand today.

Specs

  • DIY i5
  • Crucial 32GB x 1
  • SK Hynix Gold P31 1TB
  • Non-vPro AX210
  • Type C Card x 4
  • Type A Card
  • HDMI Card
  • 250GB Storage Card

Build Quality
Build quality is definitely not at the same level as the MacBook or the Surface. It feels solid but I could see some weird things even in my first 30 minutes with the machine. The first thing I noticed was the eject button for the expansion cards were exposed at different levels for the left and the right. Also, there’s a gap between the trackpad and the input cover.

DIY Experience
It was fun. Even the annoying bit of installing the wireless card felt rewarding. I felt a sense of achievement and control. It’s MY laptop and I can do what I want with it. Not just dressing it up but make real changes to it. I just have a rush of feelings I had from working on my very first desktop. I love it!

Display
It’s beautiful and there’s nothing to complain about other than the extra shiny surface, which could easily be resolved with a matte screen protector, assuming I don’t break the screen in the process.

Speakers
They are on a weak side. I really wouldn’t mind removing one of them to get a bigger battery. I don’t really use speakers on my laptops anyways.

Keyboard & Trackpad
It’s a bit spongy but feels much better than most laptops nonetheless and I doubt I would have any trouble using it going forward. The trackpad feels cheaper than both the Mac and the Surface. The surface of the trackpad is rougher than I am used to.

Hinge
The hinge feels a bit weird too. It was a bit tight as you open the lid position and wobbles at the opened position around 100°. I hope that Framework improve the hinge going forward and maybe sell a new hinge at some point?

Performance, Fan & Temperatures
I do find the performance lagging. Compared to my M1 Mac, it feels like the Framework has to struggle to do similar tasks without having to ramp up the fan. I was working at my desk with a clean flat surface. Between Dropbox and iCloud trying to sync the files, the fan was going all out like a little jet engine. On the other hand, the temperatures were kept at a very comfortable level. After Dropbox and iCloud finished syncing, I used MS Office with Edge and messaging app open. The Framework ran it without the fan on and it was just a little warm. As I used it on battery on my lap for about two hours, it does get a bit too warm for my liking. The fan didn’t run during that time.

Battery
Windows battery report is showing that only 53,207/55,009 out of the designed capacity. But this is expected rise to designed capacity after a few charges. I used the laptop on battery doing some non-intensive work and I got 4 hours and 22 minutes after going from 100% to 20%. Compared to the Mac, it’s abysmal but not so different from the Surface Pro. It took 33 minutes to get back to 50% using a 60W charger while the screen was on and not being actively used. It took another 90 minutes to get to 100%. After that I unplugged it closed the lid for 7 hours, in which I lost 6%.

Power Button
The light on the power button bothers me. Thankfully, in bios version 3.05, we will get ability to adjust the brightness on it. For now, there’s a post-it note on the power button. Curiosity got the best of me and I looked up with version we are on and it’s only 3.02. And worse, 3.03 is still in beta. It will be forever until we get 3.05, in my mind. So, the post-it note was retired and an electric tape was employed.

Docks

  • Caldigit USB-C Pro Dock connects via Thunderbolt and works great. It is connected to a single 4K display, Denon receiver, webcam, keyboard and mouse.
  • Elgato Thunderbolt 3 Docking station also works great. It is connected to dual 1080p displays, speakers, webcam, keyboard and mouse.
  • Belkin USB-C Express Dock 3.1 HD works great as well. This one connects via USB protocol, not Thunderbolt. It’s connected to a single 4K display, speakers, webcam, keyboard and mouse.
8 Likes

Configuration:

DIY i5 & BYO Wifi + Storage:
  SK Hynix Gold P31 1TB
  Intel AC9560ngw
  Some unbranded RAM I found on aliexpress (16GB @3200)

Expansion cards:
  4x USB-A
  2x USB-C

I others, I chose the DIY configuration to save on money. I was actually surprised that the RAM I got actually worked without issues. However, I can’t comment about performance about other expansion cards, as I only have the USB-A and USB-C ones.


Boxes!
When I first got the notification on my phone that FedEx has delivered my package, I was thrilled, but only to be concerned with how the box turned out. When I eventually opened it up, I was relieved that nothing bad happened to the contents within. The framework team did an awesome job at keeping the laptop safe from FedEx’s abuse.

First Look
This is the first laptop that I have bought brand new. I’ve been rocking old second hand laptops, so this was a pretty big change for me. When I first opened the box, my first thought was that the laptop looks so much like a MacBook. It’s sleek, it is surprisingly light, the keyboard is bouncy, and the screen is surprisingly crisp like a new bag of chips.

Assembly
After admiring the look and feel of the laptop, it is time to assemble it. Like an impatient adolescent, I immediately flip my framework over, grab the torx screwdriver, and start unscrewing the five screws. I was a bit too trigger-happy at my new toy, I didn’t read the quick start guide and spent three minutes wondering where and how to open the laptop from the bottom.

The one first thing that stood out to me in this disassembly process were the capacitive screws. There is no need to worry about them disappearing after unscrewing them. As for the laptop cover, it is surprisingly difficult to remove with just my hands. Using the given screwdriver end, made the whole disassembly way easier.

Being a clumsy guy, I also found it easy to pull the keyboard off the motherboard with the finger loop on the ribbon cable. Adding the storage was a breeze, but connecting the antennas to the wifi card took some time with my fat fingers, but the process was surprisingly fast, and not as tedious as I thought.

Putting everything back together was also a breeze, so not much else to say here.

Into the computer (Debian linux)
I opted to install Debian 11 (aka Debian Stable) on my configuration. Amusingly enough, the laptop is able to boot off the USB with secure boot enabled, but I ended up restarting the laptop into the BIOS to disable secure boot.

The way I installed Debian requires two USB sticks: one for the official installation media, and another one to hold firmware for the installer to read and grab.

Long story short, here’s my installation process:

  1. Disable secure boot in BIOS
  2. Plug in installer USB and start installation
  3. Plug in firmware USB after the installer asks for it
  4. Complete the rest of the install
    eg: partitioning, setting passwords, encryption, etc

Issues in linux

  • The fingerprint reader does not register (libfprint too old in current Debian 11)
  • Mic doesn’t work in the TRRS audio port

Aside from that, the whole linux experience was smooth and flawless. I’m not using the latest wifi card, so my experience is obviously different from others. I also don’t use the fingerprint reader, so that is also not a priority for me, but I can always figure it out later.

Battery
After a full charge, the battery was able to last me around 6.5-7.7 hours on full brightness on both the screen and keyboard, while listening to music while setting up my environment. The most strenuous task I did was installing programs/packages after updating. Power consumption hovered around 10 to 15 watts, and jumped to 20 at the highest on battery.

Screen
Setting the screen to full brightness really burned my eyes in a dark room. Looking at a webpage with a white background made the contrast between the black keyboard seem like it had dots between the keys. The display itself, however, has a great color range and contrast that is great for content creation. The 3:2 ratio definitely helps with the extra vertical screen estate.

Expansion cards
With only two types of cards to play around with, there’s not much to say about them in terms of functionality and such. Mechanically, however, the expansion cards take a little effort to slot into the laptop. Taking them out, on the other hand, take an amount of force to remove. The cards seem like a secure fit and doesn’t seem like they would fall out by themselves.


Overall, I’m happy and satisfied with how the framework laptop is, and I do hope and wish for them to succeed. This laptop is definitely a keeper!

6 Likes

AFAIK, the Debian secure boot is a shim that enables programs to sign and run. It might work in the meantime, but seems like a hassle to maintain in the long run.

2 Likes