Converting Framework Laptop 13 11th-gen to Chromebook Edition

What are the minimum required parts from the market place to covert a Framework Laptop 13 11th-gen to a Chromebook Edition? Is it just the main board?

Keyboard/fingerprint reader are different

The finger print reader won’t work at all actually, keyboard should work I think but key-mapping will be off

Iirc, the camera is different too but I could be wrong there


Thanks @GhostLegion!

Has anyone successfully converted their 11th gen?

I think you don’t need to replace the button, it’s just that the Chromebook doesn’t have a fingerprint reader / doesn’t support it, so it’ll just act as a normal power button.

1 Like

I don’t know anyone who’s actually done it, once they know of potential hardware incompatibility, I’ve never seen anyone follow through with it

1 Like

Need to replace the mainboard, camera, touchpad, keyboard, and power button for a full conversion.

Tested my chromebook-fw with parts from my AMD-fw, and touchpad/keyboard did not work/did not work correctly. Power button worked, but fprint was ignored, camera did not work.

Edit: Top shell for the logo, but this is aesthetic, not a functional issue.


Thanks @Forge!

That’s what I’ve been trying to figure out for a while. Thanks for testing it out (hopefully not just for me), I appreciate it!

I was hoping it was just going to be a mainboard swap.

I’ll try to get some side-by-side photos for you. The Chromebook edition keyboard is different, weird layout. The touchpad appears to be a different model. The general one didn’t work for me, on a quick attempt. The power button worked, fprint reader wasn’t seen by ChromeOS in any way I could spot. Definitely not used/supported. It would probably be mostly functional to get the Chromebook top half (keyboard, case top, touchpad, power button) and just ignore the camera. I don’t know a lot of folks using it.

And now I’ll save the page for future reference. Thanks @Forge

No need to go through the trouble for pictures for me, but if it’s for the community please do :smile:

I already knew about the fprint not working, but I didn’t know about the keyboard, camera, and touchpad.